Pandora FMS community forums
He añadido un par de servidores más y no arranca ningún módulo - Printable Version

+- Pandora FMS community forums (http://pandorafms.org/forum)
+-- Forum: Pandora FMS (http://pandorafms.org/forum/forum-3.html)
+--- Forum: Español / Spanish forum (http://pandorafms.org/forum/forum-8.html)
+--- Thread: He añadido un par de servidores más y no arranca ningún módulo (/thread-15012.html)



He añadido un par de servidores más y no arranca ningún módulo - rnacher - 03-19-2020

Buenas tardes,
Tengo PandoraFMS funcionando perfectamente desde hace tiempo. Hoy he añadido dos nuevos servidores donde les he instalado el agente y me los muestra perfectamente pero no carga ningún módulo, ni de los que me envía el agente ni de los que le creo yo manualmente. He probado con un agente versión anterior porque mi versión servidor es la 732 pero tampoco. Miro el debug y parece que todo va bien. Hay algún límite en la versión gratuita? lo digo porque he llegado casualmente a 1000 monitores.
Dejo el log del debug.
gracias

2020-03-19 15:08:10 Run begin
2020-03-19 15:08:10 Run CPU Load
2020-03-19 15:08:12 Run TCP_Connections
2020-03-19 15:08:12 Executing: cmd.exe /c "netstat -an | find /c /v "estab""
2020-03-19 15:08:12 Run plugin
2020-03-19 15:08:12 Executing: cmd.exe /c "cscript.exe //B "%ProgramFiles%\Pandora_Agent\util\df_percent_used.vbs""
2020-03-19 15:08:12 Run plugin
2020-03-19 15:08:12 Executing: cmd.exe /c "cscript.exe //B "%ProgramFiles%\Pandora_Agent\util\mem_percent_used.vbs""
2020-03-19 15:08:12 Run plugin
2020-03-19 15:08:12 Executing: cmd.exe /c "cscript.exe //B "%ProgramFiles%\Pandora_Agent\util\network.vbs""
2020-03-19 15:08:12 Error opening eHorus configuration file C:\Program Files\ehorus_agent\ehorus_agent.conf
2020-03-19 15:08:12 CPU Load getXML begin
2020-03-19 15:08:12 CPU Load getXML end
2020-03-19 15:08:12 TCP_Connections getXML begin
2020-03-19 15:08:12 TCP_Connections getXML end
2020-03-19 15:08:12 plugin getXML begin
2020-03-19 15:08:12 plugin getXML end
2020-03-19 15:08:12 plugin getXML begin
2020-03-19 15:08:12 plugin getXML end
2020-03-19 15:08:12 plugin getXML begin
2020-03-19 15:08:12 plugin getXML end
2020-03-19 15:08:12 Copying XML on C:\Program Files\pandora_agent\temp\720ef9dd10e255984602d80f3168414a7b28e95465c82492139b46953cee90a4.13883.data
2020-03-19 15:08:12 Remote copying XML C:\Program Files\pandora_agent\temp\720ef9dd10e255984602d80f3168414a7b28e95465c82492139b46953cee90a4.13883.data on server srvpandora
2020-03-19 15:08:12 Command tentacle_client.exe -a srvpandora -p 41121 "C:\Program Files\pandora_agent\temp\720ef9dd10e255984602d80f3168414a7b28e95465c82492139b46953cee90a4.13883.data"
2020-03-19 15:08:13 Successfuly copied XML file to server.
2020-03-19 15:08:13 Next execution on 300 seconds


RE: He añadido un par de servidores más y no arranca ningún módulo - rnacher - 03-19-2020

Bueno, he leído algunos problemas parecidos al mío, y me he puesto a actualizar aunque la verdad no me gusta mucho por las malas experiencias que he tenido, pero parece ser que hoy ha ido bien. El caso es que solo entrar me saltaba una notificación que la consola y el server no tenían la misma versión, y me lleva a actualizar la versión, donde aparece que hay una nueva versión pero parece que es inferior, o me lo parece a mi? que hago? actualizo? (mirar adjunto)

Gracias.


RE: He añadido un par de servidores más y no arranca ningún módulo - Diego.M - 03-20-2020

Buenas Rancher,

Pandora FMS se compone de 3 partes que se actualizan de distinta manera, la consola visual, la base de datos y el servidor. Tanto la consola como la base de datos deberian actualizarse automaticamente mediante el update manager online, pero el servidor requiere que se actualice mediante terminal.

En el caso que nos mencionas, los agentes te dejaron de funcionar debido a un cambio que realizaron los chicos de perl en el funcionamiento del codigo, por lo que desgraciadamente todas las versiones de años anteriores han dejado de funcionar correctamente y requiere que se actualice el servidor (que es donde se usaba la funcion que te mencionaba anteriormente).

EL problema que planteas ahora de que la consola y el servidor estan en versiones distintas implica simplemente que la consola la tienes completamente actualizada pero el servidor probablemente no. Esto no deberia de afectar al funcionamiento de Pandora FMS de momento, pero puede que en un futuro si, por lo que te recomiendo actualizar dicho componente a la ultima version.

Saludos
Diego


RE: He añadido un par de servidores más y no arranca ningún módulo - Jimmy_Olano - 03-20-2020

(03-19-2020, 04:49 PM)rnacher Wrote: Bueno, he leído algunos problemas parecidos al mío, y me he puesto a actualizar aunque la verdad no me gusta mucho por las malas experiencias que he tenido, pero parece ser que hoy ha ido bien. El caso es que solo entrar me saltaba una notificación que la consola y el server no tenían la misma versión, y me lleva a actualizar la versión, donde aparece que hay una nueva versión pero parece que es inferior, o me lo parece a mi? que hago? actualizo? (mirar adjunto)

Gracias.

¡Excelente respuesta del sr. Diego.M! Creo que él se refiere (puedo estar equivocado) al inconveniente en Perl 2020, por favor leed mayores en el blog: https://pandorafms.com/blog/es/perl-2020/

¡Tengáis un feliz día! 8-)