Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
All module graphs empty
#1
Hi all,

Noticed that when I view a module's graph it is blank. It is also showing "Error: No available data to show" when I go to view the current data. I queried the database and the data is there, just will not display in the console.

I did notice in my servers logs I am getting the following error:
Warning! The server does not have access to the API, this can trigger problems in the generation of reports and graphs.

I performed the API check in the console and it returned OK. Any help troubleshooting this issue would be appreciated.

My version is: v7.0NG.743 - Build PC200129 - MR 30 running on Windows 10
 Reply
#2
Hello itszech,

I see that you are in version 743 with MR 30, this is a bit outdated, version 743 corresponds to MR 35, so you should update this last one. I leave you a link to the documentation where you can see how to update the database.

https://pandorafms.com/docs/index.php?ti...elease_.29

Greetings
Diego
 Reply
#3
(02-20-2020, 10:29 AM)Diego.M Wrote: Hello itszech,

I see that you are in version 743 with MR 30, this is a bit outdated, version 743 corresponds to MR 35, so you should update this last one. I leave you a link to the documentation where you can see how to update the database.

https://pandorafms.com/docs/index.php?ti...elease_.29

Greetings
Diego

Hi Diego,

Thanks for the reply. As per your recommendation I've ran the scripts to update my database from MR30 to MR35. I however am still facing the issue of graphs appearing blank.

Cheers,
Zech
 Reply
#4
Hello Itszech,

Check your a API configuration in the Setup of the console and in the pandora_server.conf And send us images of it, to check that is not a configuration problem.

Greetings Diego
 Reply
#5
See bellow:

[Image: 1.png][Image: 2.png]

I performed the API test again with the console user and password in the conf file and it was successful.

Cheers,
Zech
 Reply
#6
Hello Itszech,

Try typing a "*" in the section of the IP list with API access. This will allow any IP to access using username and password.

Greetings
Diego
 Reply
#7
Hey,

Tried setting the IP list with API access field to * but no luck.
Here's a screenshot of the error in the logs:
[Image: 3.png]
Cheers,
Zech
 Reply
#8
Hello Itszech,

I just realized a probable error in the .conf file, you have put your user password is 1234, but the user that is created for the API has its own randomly generated password, so the most likely is that it does not match and that is the reason why it does not allow you access.

My advice is to try to change the password of your internal API user to "1234" as you have in the .conf or to change both in the .conf and in the console the password for a more secure one.

Greetings
Diego
 Reply
#9
Hey,

I gave that a try and got the same error. I also tried creating a new API user.
This issue seemed to have started after updating from 742 to the 742 fix Perl version.

Cheers,
Zech
 Reply
#10
Hello,

This is strange, try to configure in the .conf of the server the Admin user of the console, maybe the error is for some permissions, let's check that the error does not happen the same with a user with Pandora Administrator.

I can assure you that it is not an update problem, it could be something of configuration that is missing to change or a bug that could happen with your concrete configuration.

Greetings
Diego
 Reply


Users browsing this thread: 2 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes