Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
upgrading the agent to 7.45 - sed error
#1
I'm trying to upgrade to pandorafms_agent_unix-7.0NG.745-200504.x86_64 on oracle linux 6.x and centos 7.x (latest builds).  When I run the update or try to do a fresh install I get an error:

Resolving Dependencies
--> Running transaction check
---> Package pandorafms_agent_unix.x86_64 0:7.0NG.745-200504 will be installed
--> Processing Dependency: /usr/bin/grep for package: pandorafms_agent_unix-7.0NG.745-200504.x86_64
--> Processing Dependency: /usr/bin/sed for package: pandorafms_agent_unix-7.0NG.745-200504.x86_64
--> Processing Dependency: /usr/bin/grep for package: pandorafms_agent_unix-7.0NG.745-200504.x86_64
--> Processing Dependency: /usr/bin/sed for package: pandorafms_agent_unix-7.0NG.745-200504.x86_64
--> Finished Dependency Resolution
Error: Package: pandorafms_agent_unix-7.0NG.745-200504.x86_64 
           Requires: /usr/bin/sed
Error: Package: pandorafms_agent_unix-7.0NG.745-200504.x86_64
           Requires: /usr/bin/grep

I checked the spec for the rpm and as indicated in the dependencies above, it's looking for grep and sed in /usr/bin.  These files are installed in /bin.  I've tried copying those binaries into /usr/bin as well as soft linking but neither seems to satisfy the requirement.  Is there a reason the build references /usr/bin instead of /bin?  

Thanks,
-Rich
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes