Pandora FMS community forums

Full Version: Pandora FMS plugin server, Non initialised module
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
After installing Pandora FMS 5.0 SP3 on Ubuntu 12.0.1

i tried to add Memory Use(%) through SNMP walk with the wizard, But after i added the module i get the error: "Non initialised module"
Hi

What you'll have to do is run the plugin directly from a terminal of Pandora server to see which is the output.

You can see the implementation of the plugin in the module configuration.

The plugin is located in /usr/share/pandora_server/util/plugins
Hi,

I attached a picture with the outcome when i use the command in the terminal.

Hope you can help.

Thanks in advance.
Also after manualy installing net-snmp again i still get a error but a slightly diffrent one.

Atached a picture of the error


Thanks in advance.
Fixed it by installing Gawk (apt-get install gawk)



[12:29] <Bart___> sup
[12:31] <@pandorafms> hi
[13:57] <Bart___> Could you help us?
[14:25] <Bart___> I have a problem and made a topic about it http://forums.pandorafms.com/index.php/t...143.0.html
[14:31] <@pandorafms> This kind of problems are solved directly in forums to help other people. Be patient
[14:32] <@pandorafms> anyway, do you have gawk installed?
[14:32] <Bart___> Isnt Gawk inside perl?
[14:34] <@pandorafms> perl script is calling to a system command
[14:34] <@pandorafms> using gawk
[14:35] <Bart___> I see
[14:35] <Bart___> I installed it and that did fix it
[14:36] <Bart___> But i checked the installation guide / wiki
[14:36] <Bart___> It does not say i need to install gawk.
[14:37] <Bart___> Maybe you could add it to the wiki.