Pandora FMS community forums

Full Version: Email not sending
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I followed the instructions  @ "http://wiki.pandorafms.com/index.php?title=Pandora:Configuration_emails_alerts" but no go.  I checked the logs at /var/log/pandora and the logs are not showing it trying to send out mail.  If fact the logs are pretty bare except when I rebooted the server.  This build is the centos appliance,  pandorafms_console-5.0SP3-140419.tar.gz.  Please see the attachment to see the agent fired.
Hello

Check the configuration in your pandora_server.conf file to see if there is an email address configured for the server.

Regards
Ivo
mta_address localhost
#mta_port 25
#mta_user null
#mta_pass mypassword
#mta_auth LOGIN
mta_from Pandora FMS <[email protected]>

is what I have currently. I based this on the wiki page.

Thanks Smile
Hello

in mta_address put your mail server
discoment mta_user and put your email account.
discoment mta_pass and put your password (for the acount)
discoment mta_auth LOGIN

Restart the pandora_server process.

Regards
Ivo
I am able to get log messages now and they are saying error.  When I look at the maillog log I see postfix is trying to connect to my mail server via the outside ip address on my router, which will never work.  How can I force it to use the local IP adderss of my exchange box?
OK I had to reconfigure my firewall to allow postfix to send smtp through the firewall to connect to my outside ip address and now mail is flowing.
Hello

Yes the other solution was to check the connectivity and the firewall.

Regards
Ivo
Well for some reason email just stopped flowing.  The mailog has no entries.  The pandora_server.log has:

2014-04-30 13:32:02 fms.tbd.local [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert from agent AOC_AOCMAIL on module Exchange POP3

The pandora_server.error log is having issues as well.: Not sure if they are related but will paste the log.

2014-04-30 13:40:09 - fms.tbd.local Starting Pandora FMS Server. Error logging activated.
DBD::mysql:Confusedt execute failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 621.
DBD::mysql:Confusedt execute failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 597.
DBD::mysql:Confusedt execute failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 621.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
DBD::mysql:Confusedt execute failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 621.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
DBD::mysql::db do failed: MySQL server has gone away at /usr/lib/perl5/PandoraFMS/DB.pm line 811.
Perl exited with active threads:
11 running and unjoined
2 finished and unjoined
1 running and detached

if I run the command :  echo test |mail -s test [email protected]
the mail comes through instantly.

Hello

It seems mysql isn't running correctly. Can you try and execute the following command: /etc/init.d/mysqld start  and post here the result.

Regards
Ivo
The reply is [OK]
and I fired an alert and this is what I got in the server log

2014-05-06 16:19:59 fms.tbd.local [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert RECOVERED for CRITICAL status on AOC_AOCMAIL / Exchange tes Service

and nothing in the maillog
Pages: 1 2