Pandora FMS community forums

Full Version: Requires: perl-Encode-Locale
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Buenos días,

al tratar de actualizar el servidor CentOS mediante yum update:

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit, security
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* base: centos.mirror.xtratelecom.es
* extras: centos.mirror.xtratelecom.es
* updates: centos.mirror.xtratelecom.es
Setting up Update Process
Resolving Dependencies
Running transaction check
- Package pandorafms_agent_unix.noarch 0:5.1-1 will be updated
- Package pandorafms_agent_unix.noarch 0:5.1SP1RC3-1 will be an update
- Package pandorafms_console.noarch 0:5.1-1 will be updated
- Package pandorafms_console.noarch 0:5.1SP1RC3-1 will be an update
- Package pandorafms_server.noarch 0:5.1-1 will be updated
- Package pandorafms_server.noarch 0:5.1SP1RC3-1 will be an update
Processing Dependency: perl-Encode-Locale for package: pandorafms_server-5.1SP1RC3-1.noarch
Finished Dependency Resolution
Error: Package: pandorafms_server-5.1SP1RC3-1.noarch (Artica)
          Requires: perl-Encode-Locale
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Alguna idea ?

Saludos
Prueba a instalar el paquete perl-Encode-Locale. --- yum install perl-Encode-Locale.

Parece ser que es un problema de dependencias.

Saludos
A mi por ejemplo me pedía la misma dependencia porque estoy haciendo pruebas en un debian.

Si no lo encuentras con el yum, prueba a buscarlo por google y descargar el paquete .rpm.

Saludos
Por curiosidad, que versión tienes de Centos?

Lo he estado probando en otros Centos y sí que lo tengo

Saludos
Hola Sergio,

es un CentOS 6.5, y lo primero que intenté fue :

#yum install perl-Encode-Locale

y no hubo manera.

Saludos
Edit /etc/yum.repos.d/CentOS-Base.repo and enable EXTRAS, and UPDATES repos. Usually should be something like this:

[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

We're also going to add the EPEL repository:

[EPEL]
Name = EPEL
baseurl = http://dl.fedoraproject.org/pub/epel/6/$basearch/
enabled = 1
gpgcheck = 0

Hola buenas,

http://rpmfind.net/linux/rpm2html/search...ode-Locale

desde aquí podéis bajarlo.

Saludos
Buenos días Sergio,

muchas gracias.

Saludos