Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SNMP module not working
#1
I installed 1.3 from SVN onto a Debian etch fresh setup using the great quick guide on the Wiki, followed by the Install.php startup wizard (MYSQL: Ver 14.12 Distrib 5.0.32 Pandora: 1.3-dev Build PS070731).

I have lots of agents working but when I try to add a remote_snmp module with a hostname or IP address and click SNMP Walk I get this error:
--------
Warning: snmprealwalk() [function.snmprealwalk]: Error in packet: (noSuchName) There is no such variable name in this MIB. in /var/www/pandora_console/godmode/agentes/configurar_agente.php on line 555

Warning: snmprealwalk() [function.snmprealwalk]: This name does not exist: SNMPv2-MIB:ConfusednmpEnableAuthenTraps.0 in /var/www/pandora_console/godmode/agentes/configurar_agente.php on line 555

Cannot read from SNMP source
--------

If I try to add the remote_snmp module with hostname and OID then view the agent, the Data tab shows 'This agent doesn't have any module'. If I run snmpwalk -Os -c public -v 1 [IPAddress] .1.3.6.1.2.1.10.94.1.1.3.1.5 from the command line on the Pandora server then I see the correct value returned. Is there a configuration file in which I need to force SNMP v1 in Pandora, or maybe specify the path to the snmp binaries? I have the following PERL modules which have SNMP in their name (installed via CPAN) in case this is useful:

Net::SNMP v5.2.0
Net::SNMP:Big Grinispatcher v3.0.1
Net::SNMP::Message v2.0.3
Net::SNMP::MessageProcessing v2.0.1
Net::SNMP::PDU v2.1.1
Net::SNMP::Security v1.1.0
Net::SNMP::Security::Community v1.1.1
Net::SNMP::Security::USM v3.0.1
Net::SNMP::Transport v2.0.0
Net::SNMP::Transport::TCP v2.0.0
Net::SNMP::Transport::TCP6 v2.0.0
Net::SNMP::Transport::UDP v3.0.0
Net::SNMP::Transport::UDP6 v2.0.0
NetSNMP::ASN v5.0203
NetSNMP::OID v5.0203
NetSNMP::TrapReceiver v5.0203
NetSNMP::agent v5.0203
NetSNMP::agent::default_store v5.0203
NetSNMP::agent::netsnmp_request_infoPtr undef
NetSNMP::default_store v5.0203
SNMP v5.0203

Any suggestions to try or where to start would be appreciated!
 Reply
#2
Seems you don't have php-snmp installed.

Manuel
 Reply
#3
Many thanks for the response. I had the php5-snmp deb package installed but not php4-snmp. I installed php4-snmp too and rebooted but still get exactly the same error above, and the module is not shown when viewing the Agent. Maybe I should remove both and only install php4-snmp.. Any further suggestions would be gratefully received.
 Reply
#4
If you try to set up module with for instance hostname (setting the oid) and creating the module (with "add" and not using snmpawalk), is it created correctly and giving the right value in the Data tab?
 Reply
#5
Thanks again, but still the same. I tried to add the remote_snmp module using hostname and OID. When I view the agent, the Data tab shows 'This agent doesn't have any module'.
 Reply
#6
Check out you have installed all the necessary packages:

libdate-manip-perl snmp snmpd libsnmp-perl libtime-format-perl libxml-simple-perl libnetaddr-ip-perl libdbi-perl libxml-simple-perl libnetaddr-ip-perl

libapache2-mod-php5 apache2 mysql-server php5-gd php5-mysql php-pear php5-snmp
 Reply
#7
Indeed all of those packages are already installed and 'the newest version'. Thanks again
 Reply
#8
Let's see if you did this too:
http://www.openideas.info/wiki/index.php...MP_Console

Good luck!
 Reply
#9
Quote:I installed 1.3 from SVN onto a Debian etch fresh setup using the great quick guide on the Wiki, followed by the Install.php startup wizard (MYSQL: Ver 14.12 Distrib 5.0.32 Pandora: 1.3-dev Build PS070731).

I have lots of agents working but when I try to add a remote_snmp module with a hostname or IP address and click SNMP Walk I get this error:
--------
Warning: snmprealwalk() [function.snmprealwalk]: Error in packet: (noSuchName) There is no such variable name in this MIB. in /var/www/pandora_console/godmode/agentes/configurar_agente.php on line 555

Warning: snmprealwalk() [function.snmprealwalk]: This name does not exist: SNMPv2-MIB:ConfusednmpEnableAuthenTraps.0 in /var/www/pandora_console/godmode/agentes/configurar_agente.php on line 555

Cannot read from SNMP source

Are you making the snmpwalk on the CONSOLE that currently are giving you that error ?. Are you sure that IP that you use in console is correct and that server (system used for console) has a full SNMP utils installed.

This is a SNMP/PHP related problem, forget all issues with Perl.
 Reply
#10
If I run snmpwalk -Os -c public -v 1 [IPAddress] .1.3.6.1.2.1.10.94.1.1.3.1.5 from the command line on the Pandora server then I see the correct value returned..
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnol├│gicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes