Pandora FMS community forums
YAML error pandorafms agent 7.0NG.742 - Printable Version

+- Pandora FMS community forums (http://pandorafms.org/forum)
+-- Forum: Pandora FMS (http://pandorafms.org/forum/forum-3.html)
+--- Forum: Community support (English) (http://pandorafms.org/forum/forum-7.html)
+--- Thread: YAML error pandorafms agent 7.0NG.742 (/thread-14709.html)



YAML error pandorafms agent 7.0NG.742 - chathura - 01-09-2020

I've installed pandorafms agent 7.0NG.742 on Ubunutu 18.04LTS server. Agent reports data but in the agent log file, below error shows every 5 minutes.


Code:
[error] - Cannot use commands without YAML dependency, please install it.

I've installed all the required dependencies using "apt -f install".

How do i solve this error.


RE: YAML error pandorafms agent 7.0NG.742 - Diego.M - 01-13-2020

Hello Chathura,

I'm afraid that's not the right way to install YAML, try this, or check out how to do it.

sudo apt-get update -and
sudo apt-get install - and python-yaml

Greetings
Diego


RE: YAML error pandorafms agent 7.0NG.742 - chathura - 01-13-2020

(01-13-2020, 10:28 AM)Diego.M Wrote: Hello Chathura,

I'm afraid that's not the right way to install YAML, try this, or check out how to do it.

sudo apt-get update -and
sudo apt-get install - and python-yaml

Greetings
Diego

Hello Diego,

I installed YAML as instructed above. but i still get the error. Even i restarted the pandora agent. but still shows the above error on pandora agent log

when i type systemctl status pandora_agent_daemon.service , i get the following error also.


Code:
YAML::Tiny lib not found, commands feature won't be available at /usr/bin/pandora_agent


Thank You,
Chathura


RE: YAML error pandorafms agent 7.0NG.742 - Diego.M - 01-13-2020

Hello Chathura,

Now you are missing a YAML library, install whatever PandoraFMS mentions you need to have your agent working at full capacity.

Greetings
Diego


RE: YAML error pandorafms agent 7.0NG.742 - chathura - 01-14-2020

I solved this issue by installing libyaml-tiny-perl. no need to install python-yaml

Code:
apt install libyaml-tiny-perl