Pandora FMS community forums
I don't receive email alerts - Printable Version

+- Pandora FMS community forums (https://pandorafms.org/forum)
+-- Forum: Pandora FMS (https://pandorafms.org/forum/forum-3.html)
+--- Forum: Advanced troubleshooting and problems (https://pandorafms.org/forum/forum-11.html)
+--- Thread: I don't receive email alerts (/thread-3236.html)

Pages: 1 2


I don't receive email alerts - Daggda - 06-08-2011

Hi all,

I just don't know what more to do, configured the pandora_server.conf with the right parameters

mta_address mailxxx.tcxxx.com
mta_port: 25
mta_user: [email protected]
mta_pass: password
mta_auth: LOGIN
mta_from: [email protected]

Have put the right alerts to the modules and nothing, the alert jumps correctly, but the alert firing does not send me anything.

The log says me this

pandora [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert from agent xxx on module memused

Can anyone help me out ?


Re: I don't receive email alerts - Daggda - 06-08-2011

PD:

when i do a ping mailxxx.tcxxx.com

it says me this

ping: unknown host

So i think that it might be a dns problem but i cant find how to configure it

i use opensuse v11.1


Re: I don't receive email alerts - Daggda - 06-09-2011

Also i checked the log, and i have some issues one of them tells me:

"pandora [v10] processing alert 'Critical ljs' for agent 'ipbrickdemo': Do not execute the alert

              ------- the name of the alert is criticalljs ---------

and the other error is:

"pandora [v10] processing alert 'Critical condition' for agent 'ipbrickdemo': Do not execute the alert, but increment its internal counter.

I don't know what to do, i'm really out of ideas, can anyone help me out ¿


Re: I don't receive email alerts - tpalacios - 06-09-2011

Greetings Daggda,

Regarding your last post:

That's not a problem of eMail alerts, but a problem of the alert configuration, which does not execute because you defined a threshold in your template firing conditions. Please check it.

Regarding your first posts:

Being unable to ping your mail domain doesn't mean you have a problem in your network/DNS configuration... maybe this domain is configured to don't reply to ICMP packets... if this is not the case, change this configuration it until you can ping it...

How to do it?... Well... you have a huge list of examples in the web... search one of them.

Once you've fixed this problem...

It could be a problem of your pandora_server.conf configuration... you don't really need to uncomment and fill all the mta fields... if you have postfix or simillar in your Pandora Server machine, you don't need to provide any external mta... use your own in localhost... you could send mails from your own Pandora Server from the command shell...

Try:

Code:
echo "test" | mail -s "test subject" [email protected]

If this works and you receive the mail, comment all the mta fields except "mta_from":

Code:

Save it and restart your Pandora Server.

Code:
/etc/init.d/pandora_server restart

Regards.


Re: I don't receive email alerts - Daggda - 06-09-2011

Hi,

I tried to execute

echo "test" | mail -s "test subject" [email protected]

but it does not send anything ...


Re: I don't receive email alerts - Daggda - 06-09-2011

Sorry, i just made a test from another linux (ipbrick) and the mail command works perfectly, but ipbrick comes with an mail server already installed, and our pandora has no mail server, so my question is, which and how mail server packet i have to install, or if we could define a snmp route that mails from pandora go through ipbrick, that we have in the same LAN.


Re: I don't receive email alerts - tpalacios - 06-09-2011

Try this:

Code:
mta_address ipbrick

#mta_port is 25 by default... if you are using another one, change this

mta_port: 25

mta_user: [email protected]
mta_pass: password

#mta_auth... choose the auth system you have in ipbrick... if it doesn't work try another one.

mta_auth: LOGIN

mta_from: [email protected]

Regards.


Re: I don't receive email alerts - Daggda - 06-09-2011

Hi,

I don't know what's happening but it keeps telling me:

pandora [V10] Executing action 'eMail' for alert 'Critical ljs' agent 'ipbrickdemo'
pandora [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert from agent ipbrickdemo on modle memused

Best regards


Re: I don't receive email alerts - Daggda - 06-09-2011

I tried to install Postfix but i could not do it because it seems that i have Exim !! :-s

Is this one come with Pandora ?

You know something about it ? Can you tell me how to configure it ?

I did not found anything :-(

Or i uninstall exim and than install postfix ?


Re: I don't receive email alerts - tpalacios - 06-17-2011

Hi again Daggda!

It looks like this problem needs special attention... after all, there have been more people reporting about another problem of this kind, but all of them were fixed doing the previous steps we've tried already.

Since this looks like an auth/connection problem...

Give this a try and reply back with the result. Wink

Sending emails using EXPECT

Regards.