Pandora FMS community forums
Attemtping to get gmail email server working with pandora - Printable Version

+- Pandora FMS community forums (https://pandorafms.org/forum)
+-- Forum: Pandora FMS (https://pandorafms.org/forum/forum-3.html)
+--- Forum: Advanced troubleshooting and problems (https://pandorafms.org/forum/forum-11.html)
+--- Thread: Attemtping to get gmail email server working with pandora (/thread-3510.html)

Pages: 1 2


Attemtping to get gmail email server working with pandora - opike - 08-03-2011

I had originally opened a thread for this issue back in January:
http://openideas.info/smf/index.php/topic,2438.0.html
but it's been over 120 days since a reply has been made on that thread so the forum software suggested I open a new thread.  I was getting by with a different mail server since January but I no longer have access to that server so now I'm back to trying to use the gmail smtp server, with which I'm still having issues.

Regardless of what configuration I try, I get the following error message in /var/log/pandora/pandora_server.log:
2011-08-03 10:49:23 ubuntu [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert from agent ubuntu on module perl ping hpdekstop

Here is how I think the mail server settings should be set up in pandora_server.conf:
Code:
mta_address smtp.gmail.com

# mta_port: MTA port (default 25)
mta_port 587

# mta_user MTA User (if needed for auth, FQD or simple user, depending on your server)
mta_user hastapasta99

# mta_pass MTA Pass (if needed for auth)
mta_pass xxxxxxxx

# mta_auth MTA Auth system (if needed, support: LOGIN, PLAIN, CRAM-MD5, DIGEST-MD)
mta_auth LOGIN

I tried all of the Auth system options but I still get the same error.

I have a java program that successfully uses the same gmail server for sending emails. Here's part of the java code:

Code:
String username = "hastapasta99";
String password = "xxxxxxx";

Properties props = new Properties();
props.put("mail.smtp.port","587");
props.put("mail.smtp.host", "smtp.gmail.com");
props.put("mail.smtp.auth", "true");
props.put("mail.smtp.starttls.enable", "true");
props.put("mail.debug", "false");
          
/*
* Setting these timeout values since sending mail sometimes hangs.
*/
props.put("mail.smtp.timeout", 60000);
props.put("mail.smtp.connectiontimeout", 60000);


//Session session = Session.getInstance(props);
Session session = Session.getInstance(props,new MyPasswordAuthenticator(username, password));

I'm able to successfully telnet to smtp.gmail.com on port 587 from the box running pandora server so it's not a network connection or firewall issue (I have the firewall completely disabled).

I'm using pandora FMS version 3.2 on ubuntu.


Re: Attemtping to get gmail email server working with pandora - tpalacios - 08-04-2011

Greetings.

(08-03-2011, 07:00 PM)opike link Wrote: I had originally opened a thread for this issue back in January:
http://openideas.info/smf/index.php/topic,2438.0.html
but it's been over 120 days since a reply has been made on that thread so the forum software suggested I open a new thread.

My deepest regrets for that awful delay then. Wink

This kind of threads are starting to get on my nerves (not cause of you :P) because you're not the first one, and I doubt you'll be the last one who reports about this "external mta problem".

This is because I'm having a bad time trying to find out where's the problem in your case, because our team has already installed some Pandoras in our clients' machines using external mta configurations in pandora_server.conf without any problems.

I'll keep searching about it and will get back to you ASAP.


Re: Attemtping to get gmail email server working with pandora - alumbreras - 08-05-2011

Hi opike

you can try to create a new action implemented in java that the work of these .jar is to send an email alert. you can pass the subject and the body of the email by parameter in the jar.

sorry for my english Wink, i hope that you understand me.





Re: Attemtping to get gmail email server working with pandora - cwmoser - 08-20-2011


How do you enable SSL or TLS in Pandora?
All I can find that Pandora supports are LOGIN, PLAIN, CRAM-MD5, and DIGEST-MD.

SSL or TLS is required to use gmail.

Carl



Re: Attemtping to get gmail email server working with pandora - gbr - 09-05-2011

Hello,

This is how I have configured PandoraFMS to work with gmail (on Ubuntu):

Modify Pandora config file.
You can do this by executing the command:
sudo nano /etc/pandora/pandora_server.conf

Setup the mail settings:
Because we have installed a local SMTP server, we only need to set up the connection to this mail server:

# mta_address: External Mailer (MTA) IP Address to be used by Pandora FMS internal email capabilities
mta_address localhost

# mta_port: MTA port (default 25)
#mta_port

# mta_user MTA User (if needed for auth, FQD or simple user, depending on your server)
#mta_user

# mta_pass MTA Pass (if needed for auth)
#mta_pass

# mta_auth MTA Auth system (if needed, support: LOGIN, PLAIN, CRAM-MD5, DIGEST-MD)
#mta_auth

# mta_from Email address that sends the mail, by default is [email protected]
#          probably you need to change it to avoid problems with your antispam
mta_from Network Monitor Administrator <[email protected]>

Configure local mailserver EXIM4

http://wiki.debian.org/GmailAndExim4

Apply a filter, so the mails come from [email protected]
Create a file by executing the command:
sudo nano /etc/exim4/filter_reply_to
with the following content:
# Exim filter

# Rewrite my reply to for any mail sent to [email protected]

if
        $header_from: contains "Network Monitor Administrator"
then
        headers remove "Reply-To"
        headers add "Reply-To: [email protected]"
        headers add "From: [email protected]"
endif

# Forward any mail sent to root

if
        $header_to: contains "root"
then
        headers remove "Reply-To"
        headers add "Reply-To: [email protected]"
        headers remove "To"
        headers add "To: [email protected]"
        deliver "[email protected]"
endif

Adjust also the exim4 config file:
sudo nano /etc/exim4/exim4.conf.template
Add here the line
system_filter = /etc/exim4/filter_reply_to
And restart now the mail service:
sudo service exim4 restart

If you have problems with sending mails, you can check the logs:
sudo tail /var/log/mail.log

Greetings,

Geert


Re: Attemtping to get gmail email server working with pandora - manu - 09-09-2011

Hi,

What happens if you run: echo "body test" | mail -s "test" [email protected]

Do you get the email?


Re: Attemtping to get gmail email server working with pandora - rich.anderson - 10-11-2011

Thank you.  Following the gmail instructions for our local MTA fixed an issue we were having.


Re: Attemtping to get gmail email server working with pandora - fadosani - 10-18-2011

seems to be a very valuable information. thanks to all


Re: Attemtping to get gmail email server working with pandora - csandrews68 - 11-12-2012

If I am understanding this tread, Pandora does not support TLS for SMTP without third party intervention.

Is this correct? If so are there plans to correct this issue?

I like the system but email alerts are the heart of my effort.


Re: Attemtping to get gmail email server working with pandora - slerena - 01-30-2013

(11-12-2012, 11:04 PM)csandrews68 link Wrote: If I am understanding this tread, Pandora does not support TLS for SMTP without third party intervention.

Is this correct? If so are there plans to correct this issue?

I like the system but email alerts are the heart of my effort.

Pandora supports any kind of SMTP auth since 4.0, in 3.2.1 depends on sendmail library of your system, since 4.0 comes with its own library to avoid that problem. If doesnt work, just check your setup in pandora_server.conf.