Pandora FMS community forums
Tentacle service fail - Printable Version

+- Pandora FMS community forums (http://pandorafms.org/forum)
+-- Forum: Pandora FMS (http://pandorafms.org/forum/forum-3.html)
+--- Forum: Advanced troubleshooting and problems (http://pandorafms.org/forum/forum-11.html)
+--- Thread: Tentacle service fail (/thread-6579.html)



Tentacle service fail - iluizio - 09-18-2012

All,

I installed the Pandora FMS server (version 4.0.1) in a Open Suse version 11.4 machine and I can not to start the Tentacle service with a command "service tentacle_serverd start". The error message is:

Sorry, user root is not allowed to execute '/usr/bin/tentacle_server -a 0.0.0.0 -p 41121 -s /var/spool/pandora/data_in -i.*\.conf:conf;.*\.md5:md5;.*\.zip:collections -d' as pandora on brtsvisp073.
Tentacle Server could not be started.
Verify that port 41121 is not used.

Thanks,


Re: Tentacle service fail - Nacho1988 - 09-20-2012

Hi;

Could you attach the result of executing the command

ls -l  | grep tentacle

inside /usr/bin



(Otherwise you can try /etc/init.d/tentacle_serverd)

Regards





Re: Tentacle service fail - ronybigsoc - 01-19-2017

Any word on this?

I tried to run the command it is doesn't return anything.


Re: Tentacle service fail - ronybigsoc - 01-19-2017

I am correcting myself. Here is the results after i changed to the correct directory.


[email protected]:/usr/bin$ ls -l | grep tentacle
-rwxr-xr-x 1 root  root      22343 Nov  4 03:14 tentacle_client
-rwxr-xr-x 1 root  root      38242 Nov  4 03:14 tentacle_server



Re: Tentacle service fail - antonio - 01-19-2017

Hello ronybigsoc,

Try executing:

Code:
/etc/init.d/tentacle_serverd start

If it still doesn't work, you may need to run it as a different user (pandora or tentacle would work).

Kind regards,
Antonio.


Re: Tentacle service fail - luigli - 01-20-2017

I had the same problem.
My solution was edit file
Code:
/etc/init.d/tentacle_serverd
and remove option [-v] in TENTACLE_OPTS (about line 90)
-- original --
[tt]TENTACLE_OPTS="-a $TENTACLE_ADDR -p $TENTACLE_PORT -s $PANDORA_SERVER_PATH $TENTACLE_EXT_OPTS -d -l $TENTACLE_LOG_FILE -v"
[/tt]
-- change to --
[tt]TENTACLE_OPTS="-a $TENTACLE_ADDR -p $TENTACLE_PORT -s $PANDORA_SERVER_PATH $TENTACLE_EXT_OPTS -d -l $TENTACLE_LOG_FILE"[/tt]

When running in daemon mode, it seems that tentacle server doesn't admin verbose option



Re: Tentacle service fail - antonio - 01-20-2017

luigli,

That parameter shouldn't interfere anyway, but maybe you've found some kind on incompatibility. Are you using also Suse linux?

Kind regards,
Antonio.


Re: Tentacle service fail - ph - 01-20-2017

It breaks, because it tries to create a log file /var/log/pandora/tentacle_server.log as a pandora user.

You can do this as a workaround:
Code:
touch /var/log/pandora/tentacle_server.log
chown pandora:pandora /var/log/pandora/tentacle_server.log



Re: Tentacle service fail - luigli - 01-24-2017

I use Ubuntu 12.04 LTS
I applied solution posted by ph and it worked for me. So now i can use param [tt]-v[/tt] to log to
Code:
/var/log/pandora/tentacle_server.log