Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fallo al actualizar Pandora 7.0 NG
#5
(05-16-2019, 09:12 AM)eduardo.corral Wrote:
(05-14-2019, 10:24 AM)Jramongv Wrote:
(05-14-2019, 08:02 AM)eduardo.corral Wrote:
(05-13-2019, 10:59 AM)Jramongv Wrote: Hola buenos días,

Cuando intento actualizar mis Pandora 7.0NG me da el siguiente error:

La última versión del paquete instalado es:

170731
Fallo al actualizar al ultimo paquete

Al intentarlo desde el update manager, ¿hay forma de ver qué está fallando?

(05-13-2019, 10:59 AM)Jramongv Wrote: Hola buenos días,

Cuando intento actualizar mis Pandora 7.0NG me da el siguiente error:

La última versión del paquete instalado es:

170731
Fallo al actualizar al ultimo paquete

Al intentarlo desde el update manager, ¿hay forma de ver qué está fallando?

Sé que el sistema lo tengo bastante desactualizado, no sé si hay algún path de actualización progresivo.

Buenos días, Jramongv

Te facilito el enlace para que puedas descargar los paquetes de la última versión para el sistema en el que estés trabajando: 

https://sourceforge.net/projects/pandora...7.0NG/734/

Es la versión más actualizada, la 734, así que con esa última actualización es suficiente. 

También es importante recordar de cara a la actualización que primero es necesario actualizar la consola y después el servidor. 

Si surge cualquier otro inconveniente, por favor no dudes en contactarnos.

Un cordial saludo, 

Eduardo.
Gracias Eduardo,
¿Pero puedo actualizar directamente desde la 709 a la 734? ¿No tengo que pasar por todos los upgrades previos?
¿No hay que ejecutar las actualizaciones source /var/www/html/pandora_console/extras/mr/X.sql secuencialmente?
Mi centos es un 6.6 y php 5.3.3, ¿es necesario actualizar el SO y el php?.

Perdona tantas preguntas pero no me gustaría llevarme sorpresas en el upgrade.

Gracias de nuevo.

Buenos días, Jramongv

Vamos por partes: 

1- Sí puedes actualizar directamente desde la 709 a la 734. 

2- Los MR SÍ es necesario actualizarlos secuencialmente y sin saltarse ninguno. El proceso sería el siguiente: 

- Accede a la base de datos y ejecuta los siguientes comandos: 

Code:
use pandora;

Code:
source /var/www/html/pandora_console/extras/mr/XX.sql

XX representa el número de MR a actualizar, desde el 1 hasta el último (27). Es importante realizar este paso para todos los MR EN ORDEN y sin saltarse ninguno. 

- Una vez actualizado el MR sin errores, necesitarás acceder a la base de datos de nuevo y ejecutar los siguientes comandos. 

Code:
use pandora;

Code:
update tconfig set value='XX' where token='MR';

Es importante darse cuenta de que en la última sentencia hay que poner 'XX' como 27, que es el último MR disponible. 

3- Sí sería necesario actualizar el php, puesto que desde la versión 729 de Pandora FMS se utiliza la versión 7.2. Te facilito un enlace a la wiki por si existe alguna duda con el proceso de actualización: https://wiki.pandorafms.com/index.php?ti...%B3n_PHP_7

Haznos saber el resultado cuando realices este proceso. 

Un cordial saludo, 

Eduardo.

Gracias Eduardo,
Por supuesto, cuando  actualice todo os digo, de todas formas una pequeña duda, he visto que para actualizar php a la versión 7 se chequea primero con php -v si no hay versión previa instalada, en mi caso tengo php instalado, ¿tengo que desinstalarlo para instalar la versión 7?, ¿hay alguna forma de desinstalar el php?.

Gracias de nuevo.
 Reply
Messages In This Thread
fallo al actualizar Pandora 7.0 NG - by Jramongv - 05-13-2019, 10:59 AM
RE: fallo al actualizar Pandora 7.0 NG - by Jramongv - 05-16-2019, 11:08 AM


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes