Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ReadEventLog error 997 y Could not start service
#1
Hola,
    hace una semana conocí Pandora FMS y tras venir de Nagios durante unos años estoy sorprendido, todo lo que puedo hacer con este software.
    el problema que tengo es que al añadir un servicio en el conf de un agente para monitorearlo veo que me aparece en el log el error al iniciar el servicio de agente:
2010-02-02 11:23:21 Pandora agent started
2010-02-02 11:23:24 ReadEventLog error 997

    Y si el servicio que monitoreo cae aparece:
2010-02-04 05:19:43 Could not start service "servicio". (Error 997)

  ¿sabeis a que es debido?

saludos
 Reply
#2
Podrías ampliar los datos, que servicio, cómo lo has puesto en el conf, etc..

vendría muy bien si pusieras la configuración del monitor y el log del agente.
 Reply
#3
Hola el codigo en el conf es el siguiente:
module_begin
module_name MiServicio
module_type generic_proc
module_service MiServicio
module_description Control para MiServicio
module_async yes
module_watchdog yes
module_end

Y el log es el siguiente:
2010-02-03 23:00:01 Pandora agent started
2010-02-03 23:00:02 ReadEventLog error 997
2010-02-03 23:00:02 ReadEventLog error 997
2010-02-04 05:19:43 Could not start service "lpd". (Error 997)

saludos
 Reply
#4
Una pregunta si vas al panel de control / herramientas administrativas / servicios y dices "detener" / "iniciar" / "reiniciar"  da algún errror ?

Pregunta...
si pones "module_service MiServicio", cómo es que el error hace referencia a otro distinto "lpd", tendrían que ser el mismo.

Tema aparte, el error es que el servicio se para y pandora no puede levantarlo por algún error en concreto, has mirado el visor de eventos ?
En todo caso para el servicio e intenta levantarlo a mano desde la linea de comandos con "net start" y mira que error te da.
 Reply
#5
El servicio lpd y Miservicio es el mismo, lo que pasa es que no cambie lpd por Miservicio al colocarlo aui en el foro.
Este servicio lo puedo levantar perfectamente, pararlo, reiniciarlo o iniciarlo. Y cuando lo paro es cuando veo el error en log de pandora, logicamente no lo levanta. Sin embargo entro en los servicio, le doy a iniciar y lo levanta.
 Reply
#6
¿Has probado como dice chejov la línea de comando:

[tt]net start lpd[/tt]

?
 Reply
#7
Si lo he probado y levanta el servicio ok.
El servicio esta puesto para que se inicie sesion con un usuario y no como cuenta del sistema local, ¿podria ser eso?
 Reply
#8
Puede ser..., ¿ves algo en el visor de sucesos del Windows? Cuando un servicio no se inicia, deja rastro del error que no ha permitido el inicio...

Un saludo,

Raúl
 Reply
#9
Pues nada, al final es debido a que el servicio no estaba iniciado desde una cuenta local. gracias y saludos
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes