Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problema agente antiguo 1.3 para Solaris 8 con Servidor Pandora FMS 3.0
#1
Buenos días,

estoy tratando de utilizar un agente antiguo v1.3 en una maquina con Solaris 8 que no se puede actualizar (Intenté instalar la version del agente 3.0 pero se necesita instalar perl 5.8 y otras dependencias y de momento no se quiere actualizar la maquina)

En nuestro servidor tengo Pandora FMS 3.0 en Ubuntu que detecta agentes 3.0 sin problemas pero no soy capaz de que conecte con el agente1.3 de Solaris 8.

¿Es esto posible?
¿Son incompatibles?
¿Hay alguna solución para monitorizar la maquina de solaris 8 sin actualizarla?


Muchas gracias
 Reply
#2
-------------------------------------------------------------
English version
-------------------------------------------------------------

Good morning,

I'm trying to use an old agent v1.3 on a machine with Solaris 8 that can
not be upgraded (I tried installing the official version 3.0 but you
need to install perl 5.8 and other dependences and do not want to
upgrade the machine)

In our Server with Pandora FMS 3.0 on Ubuntu agents3.0 installed in
other machines with Solaris 10 are detected without problems but I am
unable to connect to the agente 1.3 in Solaris 8.

Is this possible?
Are they incompatible?
Is there a solution to monitor the machine solaris 8 without upgrade it?

-------------------------------------------------------------
English version - answer
-------------------------------------------------------------
I had some 1.3 agents running at solaris talking with my 3.0 server without problems.

Are you using tentacle? Try ssh. Tentacle was not available at 1.3 version.

I hope this helps. Regards.
 Reply
#3
Hi! thanks for your answer.

I tried with ftp and ssh but nothing. I think the problem is in my ssh key and in my ftp user and password file. Can you tell me how can I go through this?

port 22 and 21 are open.

Thanks!
 Reply
#4
Hi, this is what I get:
arce# ssh -v [email protected]_server
SSH Version 1.2.30 [sparc-sun-solaris2.6], protocol version 1.5.
Standard version.  Does not use RSAREF.
arce: Reading configuration data /etc/ssh_config
arce: ssh_connect: getuid 0 geteuid 0 anon 0
arce: Allocated local port 1023.
arce: Connecting to ip_server port 22.
arce: Connection established.
arce: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-3ubuntu1
arce: Waiting for server public key.
Local: Bad packet length 1349676916

So something is wrong with my key...

thanks
 Reply
#5
Is it worked at the old server? Have you copied the public key of the client to the .ssh/authorized_keys in the pandora server?

Let me know if you need further assistance.

Regards.
 Reply
#6
Yes,

I generate the key with "ssh-keygen -f dsa" in client, then I copied the file generated "dsa.pub" and I uploaded with ftp to my server at /home/pandora/.ssh/authorized_keys

And still does not work...

Do I have to do anything else?

Thanks!
 Reply
#7
I also tried with another agent installed in SOalris 9 and I can get connected to my server using ssh but always ask for password. If y put ssh_config with PubkeyAuthentication yes and PasswordAuthentication no it shows: "Unable to find an authentication method" so it can not get access to my server key I guess....
 Reply
#8
What user are you using to make the ssh connection? You have to generate the key with the user that runs the agent_client.

Check the permissions of the directory authorized_keys (I had problems with this once... ssh complained about too much permission):

640 for authorized_keys (-rw-r-----)

Remember that the key generated could not have a "pass phrase"


obs: The spanish post from Raul (http://openideas.info/smf/index.php/topi...tml#msg456) solved your problem?
 Reply
#9
Hi, I got connection using ssh with one machine tha uses Solaris 9 but still have problems with Solaris 8.

# ssh-keygen -t dsa
ssh-keygen: illegal option -- t
ssh-keygen version 1.2.30
Usage: ssh-keygen [-b bits] [-p] [-c] [-u] [-f file] [-P pass]
          [-N new-pass] [-C comment]

So I can not get dsa or rsa key...

Another machine with Solaris 8 has not ssh installed and I tried with FTP transfer protocol but Pandora FMS does not detect it. I can connect using ftp server_ip without using password because I used .netrc file but I don't know what else do I have to do....

Thanks for your help!


By the way I check the url you send me but I can not get access to
http://www.openideas.info/phpbb/viewtopic.php?p=647#647
 Reply
#10
Hi!

I realized that FTP is not implemented in Solaris Agent 1.3.


I added this to /usr/share/pandora_agent/pandora_agent file:

# Send packets to server and delete it
if [ "$TRANSFER_MODE" = "ssh" ]
      then
                scp -P $SERVER_PORT $PANDORA_FILES [email protected]$SERVER_IP:$SERVER_PATH > /dev/null 2>  $PANDORA_LOGFILE.err
        fi

        if [ "$TRANSFER_MODE" = "ftp" ]
        then
                #ftp $SERVER_IP > /dev/null 2> $PANDORA_LOGFILE.err
                ftp $SERVER_IP <<EOF
prompt
mput $PANDORA_FILES
quit
EOF

        Fi


bur it does not connect right...

Is there any option to do it???
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes