Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem installing from repositories in Ubuntu 18.04
#1
I'm trying to add debian/ubuntu repositories on a fresh ubuntu 18.04 installation.

Running apt-get update i obtain the following error:

Ign:5 https://firefly.artica.es/debian/jessie  InRelease                 
Err:6 https://firefly.artica.es/debian/jessie  Release
  404  Not Found [IP: 5.196.250.92 443]
Reading package lists... Done
E: The repository 'http://www.artica.es/debian/jessie  Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

this is the source.list entry:

deb http://www.artica.es/debian/jessie /

i tried also with stretch, wheezy and squeeze.

any suggestions?
many thanks
 Reply
#2
(02-21-2019, 03:07 PM)maxfranco Wrote: I'm trying to add debian/ubuntu repositories on a fresh ubuntu 18.04 installation.

Running apt-get update i obtain the following error:

Ign:5 https://firefly.artica.es/debian/jessie  InRelease                 
Err:6 https://firefly.artica.es/debian/jessie  Release
  404  Not Found [IP: 5.196.250.92 443]
Reading package lists... Done
E: The repository 'http://www.artica.es/debian/jessie  Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

this is the source.list entry:

deb http://www.artica.es/debian/jessie /

i tried also with stretch, wheezy and squeeze.

any suggestions?
many thanks

Good morning maxfranco,

Try with the steps describe in the link below:

https://wiki.pandorafms.com/index.php?ti...and_Ubuntu

Alberto
 Reply
#3
(02-22-2019, 12:41 PM)alberto.sanchez Wrote: Good morning maxfranco,

Try with the steps describe in the link below:

https://wiki.pandorafms.com/index.php?ti...and_Ubuntu

Alberto

Hi Alberto,

I followed the step described in the wiki, and the error reported rised after as result.
 Reply
#4
(02-25-2019, 02:18 PM)maxfranco Wrote:
(02-22-2019, 12:41 PM)alberto.sanchez Wrote: Good morning maxfranco,

Try with the steps describe in the link below:

https://wiki.pandorafms.com/index.php?ti...and_Ubuntu

Alberto

Hi Alberto,

I followed the step described in the wiki, and the error reported rised after as result.

Good morning maxfranco,

Will try to replicate your error and see what can be the problem, and its solution.

Alberto
 Reply
#5
Same happens to me with Ubuntu 18 and those repositories.

If I pre-install PHP (v7.2) and MYSQL and other dependencies and then install from PandoraFMS .DEB's,  there are many dependencies that "are not going to be installed":


Code:
Note, selecting 'xprobe' instead of 'xprobe2'
The following packages have unmet dependencies:
 graphviz : Depends: libann0 but it is not going to be installed
            Depends: libcdt5 but it is not going to be installed
            Depends: libcgraph6 but it is not going to be installed
            Depends: libgts-0.7-5 (>= 0.7.6) but it is not going to be installed
            Depends: libgvc6 but it is not going to be installed
            Depends: libgvpr2 but it is not going to be installed
            Depends: liblab-gamut1 but it is not going to be installed
 libdbd-mysql-perl : Depends: libmysqlclient20 (>= 5.7.11) but it is not going to be installed
 nmap : Depends: liblinear3 (>= 2.01+dfsg) but it is not going to be installed
 php-db : Depends: php-pear (>= 1.10.0) but it is not going to be installed
 php-gettext : Depends: php-php-gettext but it is not going to be installed
 php7.2-curl : Depends: libcurl4 (>= 7.44.0) but it is not going to be installed
 php7.2-xmlrpc : Depends: libxmlrpc-epi0 but it is not going to be installed
 php7.2-zip : Depends: libzip4 (>= 1.0) but it is not going to be installed
 snmp-mibs-downloader : Depends: smistrip but it is not going to be installed
 Reply
#6
(03-07-2019, 09:02 AM)jbaez Wrote: Same happens to me with Ubuntu 18 and those repositories.

If I pre-install PHP (v7.2) and MYSQL and other dependencies and then install from PandoraFMS .DEB's,  there are many dependencies that "are not going to be installed":


Code:
Note, selecting 'xprobe' instead of 'xprobe2'
The following packages have unmet dependencies:
 graphviz : Depends: libann0 but it is not going to be installed
            Depends: libcdt5 but it is not going to be installed
            Depends: libcgraph6 but it is not going to be installed
            Depends: libgts-0.7-5 (>= 0.7.6) but it is not going to be installed
            Depends: libgvc6 but it is not going to be installed
            Depends: libgvpr2 but it is not going to be installed
            Depends: liblab-gamut1 but it is not going to be installed
 libdbd-mysql-perl : Depends: libmysqlclient20 (>= 5.7.11) but it is not going to be installed
 nmap : Depends: liblinear3 (>= 2.01+dfsg) but it is not going to be installed
 php-db : Depends: php-pear (>= 1.10.0) but it is not going to be installed
 php-gettext : Depends: php-php-gettext but it is not going to be installed
 php7.2-curl : Depends: libcurl4 (>= 7.44.0) but it is not going to be installed
 php7.2-xmlrpc : Depends: libxmlrpc-epi0 but it is not going to be installed
 php7.2-zip : Depends: libzip4 (>= 1.0) but it is not going to be installed
 snmp-mibs-downloader : Depends: smistrip but it is not going to be installed

Greetings, jbaez

To help you solve that issue, please try to install all components together, as per shown in the wiki link posted previously and in the code below.

Code:
dpkg -i pandorafms-console_xxx.deb pandorafms-server_xxxx.deb

Once this command has been executed, you might notice that some dependencies might still be missing. If this happens, you can try to solve this by using the following command. 

Code:
apt-get -f install

That way you'll force the installation of any troublesome dependencies. Once the necessary packages have been installed, you'll need to continue with the installation of all PandoraFMS components. 

One thing you might want to take into consideration is that currently we strongly recommend to install Pandora FMS in its version 731, as it is the most stable. 

If you need anything else, please do not hesitate to contact us again. 

Regards, 

Eduardo.
 Reply
#7
Thanks, Eduardo. That worked.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes