Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unitialized "EventStormProtect" variable causing spamming of pandora_server.error log
#1
The /var/log/pandora/pandora_server.error log file is being spammed with the following two error message, at a rate of about one message per second:

Argument "" isn't numeric in numeric eq (==) at /usr/lib/perl5/PandoraFMS/Core.pm line 363.
Argument "" isn't numeric in numeric eq (==) at /usr/lib/perl5/PandoraFMS/Core.pm line 4259.

It is mostly the first error message that appears in the logs.

Those line numbers refer to the following line of code:
if ($EventStormProtection == 1) {

The line appears to relate to the "Event Storm protection" setting under Configuration->General.  I have never set nor changed that setting from it's default disabled state.  Nor should I have to, if I don't need the functionality.  I suspect that, because of this, the "EventStormProtection" variable has a null value.


Hope this is enough information for fixing this issue.

Thanks

Currently running: Pandora FMS 7.0NG.732-1 on CentOS
 Reply
#2
(03-15-2019, 03:36 AM)xyros Wrote: The /var/log/pandora/pandora_server.error log file is being spammed with the following two error message, at a rate of about one message per second:

Argument "" isn't numeric in numeric eq (==) at /usr/lib/perl5/PandoraFMS/Core.pm line 363.
Argument "" isn't numeric in numeric eq (==) at /usr/lib/perl5/PandoraFMS/Core.pm line 4259.

It is mostly the first error message that appears in the logs.

Those line numbers refer to the following line of code:
if ($EventStormProtection == 1) {

The line appears to relate to the "Event Storm protection" setting under Configuration->General.  I have never set nor changed that setting from it's default disabled state.  Nor should I have to, if I don't need the functionality.  I suspect that, because of this, the "EventStormProtection" variable has a null value.


Hope this is enough information for fixing this issue.

Thanks

Currently running: Pandora FMS 7.0NG.732-1 on CentOS

Greetings, xyros

If you enable Event Storm Protection it will prevent that flooding of events. However, it appears to be some kind of problem with the verbosity configuration in pandora_server.conf, its value might be too high. 

Could you please send us the configuration you have?

Kind regards, 

Eduardo.
 Reply
#3
I do not use Event Storm Protection. It is not enabled in my configuration. The only storm protection I use are the following:
snmp_storm_protection 6
snmp_storm_timeout 900

pandora_server.conf coming as PM...
 Reply
#4
(03-15-2019, 11:50 AM)xyros Wrote: I do not use Event Storm Protection.  It is not enabled in my configuration.  The only storm protection I use are the following:
snmp_storm_protection 6
snmp_storm_timeout 900

pandora_server.conf coming as PM...

Greetings, xyros

After taking a look at your .conf file, I don't see anything out of the ordinary. Please do try to enable "Event Storm Protection" in the console configuration, then save the changes and disable it again to initialize the parameter. 

Please let us know if this takes effect. 

One quick question, which MR do you have in your installation?

Kind regards, 

Eduardo.
 Reply
#5
Enabling and disabling Event Storm Protection actually does not work. After disabling it again, the error messages are back

I have MR 12
 Reply
#6
(03-18-2019, 01:58 PM)xyros Wrote: Enabling and disabling Event Storm Protection actually does not work.  After disabling it again, the error messages are back

I have MR 12

Greetings, xyros

Pandora is actually running MR 25, please try to update it as it follows: 

First of all check if you have MR 25 in /var/www/html/pandora_console/extras/mr

Then proceed to enter your database an execute the following commands (please do take extra care doing this, because Pandora's database is extremely important).


Code:
mysql > use pandora;
mysql > source /var/www/html/pandora-console/extras/mr/13.sql
mysql > source /var/www/html/pandora-console/extras/mr/14.sql
mysql > source /var/www/html/pandora-console/extras/mr/15.sql
[...]
mysql > source /var/www/html/pandora-console/extras/mr/25.sql
 

Keep doing this until you reach MR 25. DO NOT skip any MR, you'll have to apply them in order. 

After this, you'll have to update the console footer token. 


Code:
mysql > use pandora;
mysql > update tconfig set value=25 where token='MR';


Please be extra careful with this step. 

Let us know how this works. 

Kind regards, 

Eduardo.
 Reply
#7
I had already applied all of those .sql files, in order. The only step I had never done before is the "tconfig" step.

I have now done the "tconfig" step. Of course, I'm still getting those error messages.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes