Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bug en modulo Remote SNMP al usar puerto distinto al 161
#1
Estoy intentando crear modulos SNMP de una equipo que usa un puerto diferente al 161 y no funciona.

Son 2 equipos en verdad comunicados entre sí (equipo 1 y equipo 2) , las consultas se hacen a al equipo 1:

Para consultar las variables por SNMP del Equipo 1 se usa la IP del equipo 1 y el puerto 161

Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171


En sí los equipos responden perfectamente, lo corroboré tanto con el SW MIB browser e incluso con la herramienta "Navegador SNMP" del Pandora, en este caso para el equipo 2 use (IP de equipo1):171

El problema es que al crear un modulo remote SNMP para el equipo 2, este modulo queda como "no inicializado" probé tanto poniendo "171" en el campo "Puerto" como agregándolo en la IP (IP:171) en la configuración del modulo. De ninguna forma funciona.


.png   Captura.PNG (Size: 7.46 KB / Downloads: 5)

Pandora FMS v7.0NG.731 - Build 191231 - MR 24

Se agradece una ayuda!

Saludos!
 Reply
#2
(06-10-2019, 02:50 PM)yoluquitas Wrote: Estoy intentando crear modulos SNMP de una equipo que usa un puerto diferente al 161 y no funciona.

Son 2 equipos en verdad comunicados entre sí (equipo 1 y equipo 2) , las consultas se hacen a al equipo 1:

Para consultar las variables por SNMP del Equipo 1 se usa la IP del equipo 1 y el puerto 161

Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171


En sí los equipos responden perfectamente, lo corroboré tanto con el SW MIB browser e incluso con la herramienta "Navegador SNMP" del Pandora, en este caso para el equipo 2 use (IP de equipo1):171

El problema es que al crear un modulo remote SNMP para el equipo 2, este modulo queda como "no inicializado" probé tanto poniendo "171" en el campo "Puerto" como agregándolo en la IP (IP:171) en la configuración del modulo. De ninguna forma funciona.



Pandora FMS v7.0NG.731 - Build 191231 - MR 24

Se agradece una ayuda!

Saludos!

Buenos días, yoluquitas

Lo primero de todo es recomendarte que actualices tu instalación de Pandora FMS. Actualmente estamos funcionando bajo la versión 735 MR 28. 

Mantener Pandora FMS actualizado ayudará a prevenir posibles errores. 

Siguiendo con la duda que nos propones, ¿podrías indicarnos qué equipo es en el que está instalado el servidor? ¿Equipo 1 y Equipo 2 hacen referencia a switches? ¿Se trata de otros dispositivos?


Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

Un cordial saludo, 

Eduardo.
 Reply
#3
(06-11-2019, 09:14 AM)eduardo.corral Wrote:
(06-10-2019, 02:50 PM)yoluquitas Wrote: Estoy intentando crear modulos SNMP de una equipo que usa un puerto diferente al 161 y no funciona.

Son 2 equipos en verdad comunicados entre sí (equipo 1 y equipo 2) , las consultas se hacen a al equipo 1:

Para consultar las variables por SNMP del Equipo 1 se usa la IP del equipo 1 y el puerto 161

Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171


En sí los equipos responden perfectamente, lo corroboré tanto con el SW MIB browser e incluso con la herramienta "Navegador SNMP" del Pandora, en este caso para el equipo 2 use (IP de equipo1):171

El problema es que al crear un modulo remote SNMP para el equipo 2, este modulo queda como "no inicializado" probé tanto poniendo "171" en el campo "Puerto" como agregándolo en la IP (IP:171) en la configuración del modulo. De ninguna forma funciona.



Pandora FMS v7.0NG.731 - Build 191231 - MR 24

Se agradece una ayuda!

Saludos!

Buenos días, yoluquitas

Lo primero de todo es recomendarte que actualices tu instalación de Pandora FMS. Actualmente estamos funcionando bajo la versión 735 MR 28. 

Mantener Pandora FMS actualizado ayudará a prevenir posibles errores. 

Siguiendo con la duda que nos propones, ¿podrías indicarnos qué equipo es en el que está instalado el servidor? ¿Equipo 1 y Equipo 2 hacen referencia a switches? ¿Se trata de otros dispositivos?


Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

Un cordial saludo, 

Eduardo.

Hola Eduardo, cómo estas?

Gracias por tu pronta respuesta!

Entiendo tu sugerencia de actualizar Pandora, pero quisiera hacerlo si se que va a resolver ese error, ya que podría llegar a surgir otro inconveniente tras la actualización.

En caso de los equipos 1 y 2 son parte de un transmisor dvb-t2 uno procesa la señal y el otro la modula básicamente los equipos son un apliance de R&S.

Pandora FMS corre en una VM VMware dentro de un server IBM System x M3.

El error parecería ser que Pandora no usa el puerto que se le indica en el campo "puerto" en la configuración del modulo.

El modulo queda como no inicializado, con valor 0 en caso de elegir tipo "numeric data"
Si en cambio elijo "alphanumeric data"muestra estado normal con valor: No Such Object available on this agent at this OID

Sin embargo como mencioné anteriormente, la herramienta navegador SNMP de Pandora muestra un valor correcto


Quote:
Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

No es posible hacer eso, al equipo 2 se accede mediante el equipo 1 ya que hay comunicación entre ellos.

Saludos!
 Reply
#4
(06-11-2019, 11:49 AM)yoluquitas Wrote:
(06-11-2019, 09:14 AM)eduardo.corral Wrote:
(06-10-2019, 02:50 PM)yoluquitas Wrote: Estoy intentando crear modulos SNMP de una equipo que usa un puerto diferente al 161 y no funciona.

Son 2 equipos en verdad comunicados entre sí (equipo 1 y equipo 2) , las consultas se hacen a al equipo 1:

Para consultar las variables por SNMP del Equipo 1 se usa la IP del equipo 1 y el puerto 161

Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171


En sí los equipos responden perfectamente, lo corroboré tanto con el SW MIB browser e incluso con la herramienta "Navegador SNMP" del Pandora, en este caso para el equipo 2 use (IP de equipo1):171

El problema es que al crear un modulo remote SNMP para el equipo 2, este modulo queda como "no inicializado" probé tanto poniendo "171" en el campo "Puerto" como agregándolo en la IP (IP:171) en la configuración del modulo. De ninguna forma funciona.



Pandora FMS v7.0NG.731 - Build 191231 - MR 24

Se agradece una ayuda!

Saludos!

Buenos días, yoluquitas

Lo primero de todo es recomendarte que actualices tu instalación de Pandora FMS. Actualmente estamos funcionando bajo la versión 735 MR 28. 

Mantener Pandora FMS actualizado ayudará a prevenir posibles errores. 

Siguiendo con la duda que nos propones, ¿podrías indicarnos qué equipo es en el que está instalado el servidor? ¿Equipo 1 y Equipo 2 hacen referencia a switches? ¿Se trata de otros dispositivos?


Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

Un cordial saludo, 

Eduardo.

Hola Eduardo, cómo estas?

Gracias por tu pronta respuesta!

Entiendo tu sugerencia de actualizar Pandora, pero quisiera hacerlo si se que va a resolver ese error, ya que podría llegar a surgir otro inconveniente tras la actualización.

En caso de los equipos 1 y 2 son parte de un transmisor dvb-t2 uno procesa la señal y el otro la modula básicamente los equipos son un apliance de R&S.

Pandora FMS corre en una VM VMware dentro de un server IBM System x M3.

El error parecería ser que Pandora no usa el puerto que se le indica en el campo "puerto" en la configuración del modulo.

El modulo queda como no inicializado, con valor 0 en caso de elegir tipo "numeric data"
Si en cambio elijo "alphanumeric data"muestra estado normal con valor: No Such Object available on this agent at this OID

Sin embargo como mencioné anteriormente, la herramienta navegador SNMP de Pandora muestra un valor correcto


Quote:
Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

No es posible hacer eso, al equipo 2 se accede mediante el equipo 1 ya que hay comunicación entre ellos.

Saludos!

Buenos días, yoluquitas

¿Puedes enviarnos capturas de cómo se está estableciendo la configuración del módulo SNMP? Sería conveniente conocer los datos completos de la sección de configuración de dicho módulo. 

Como comprobación adicional, ¿cuál es el resultado que devuelve la creación del módulo a través del SNMP Wizard?

Un cordial saludo, 

Eduardo.
 Reply
#5
(06-12-2019, 09:25 AM)eduardo.corral Wrote:
(06-11-2019, 11:49 AM)yoluquitas Wrote:
(06-11-2019, 09:14 AM)eduardo.corral Wrote:
(06-10-2019, 02:50 PM)yoluquitas Wrote: Estoy intentando crear modulos SNMP de una equipo que usa un puerto diferente al 161 y no funciona.

Son 2 equipos en verdad comunicados entre sí (equipo 1 y equipo 2) , las consultas se hacen a al equipo 1:

Para consultar las variables por SNMP del Equipo 1 se usa la IP del equipo 1 y el puerto 161

Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171


En sí los equipos responden perfectamente, lo corroboré tanto con el SW MIB browser e incluso con la herramienta "Navegador SNMP" del Pandora, en este caso para el equipo 2 use (IP de equipo1):171

El problema es que al crear un modulo remote SNMP para el equipo 2, este modulo queda como "no inicializado" probé tanto poniendo "171" en el campo "Puerto" como agregándolo en la IP (IP:171) en la configuración del modulo. De ninguna forma funciona.



Pandora FMS v7.0NG.731 - Build 191231 - MR 24

Se agradece una ayuda!

Saludos!

Buenos días, yoluquitas

Lo primero de todo es recomendarte que actualices tu instalación de Pandora FMS. Actualmente estamos funcionando bajo la versión 735 MR 28. 

Mantener Pandora FMS actualizado ayudará a prevenir posibles errores. 

Siguiendo con la duda que nos propones, ¿podrías indicarnos qué equipo es en el que está instalado el servidor? ¿Equipo 1 y Equipo 2 hacen referencia a switches? ¿Se trata de otros dispositivos?


Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

Un cordial saludo, 

Eduardo.

Hola Eduardo, cómo estas?

Gracias por tu pronta respuesta!

Entiendo tu sugerencia de actualizar Pandora, pero quisiera hacerlo si se que va a resolver ese error, ya que podría llegar a surgir otro inconveniente tras la actualización.

En caso de los equipos 1 y 2 son parte de un transmisor dvb-t2 uno procesa la señal y el otro la modula básicamente los equipos son un apliance de R&S.

Pandora FMS corre en una VM VMware dentro de un server IBM System x M3.

El error parecería ser que Pandora no usa el puerto que se le indica en el campo "puerto" en la configuración del modulo.

El modulo queda como no inicializado, con valor 0 en caso de elegir tipo "numeric data"
Si en cambio elijo "alphanumeric data"muestra estado normal con valor: No Such Object available on this agent at this OID

Sin embargo como mencioné anteriormente, la herramienta navegador SNMP de Pandora muestra un valor correcto


Quote:
Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

No es posible hacer eso, al equipo 2 se accede mediante el equipo 1 ya que hay comunicación entre ellos.

Saludos!

Buenos días, yoluquitas

¿Puedes enviarnos capturas de cómo se está estableciendo la configuración del módulo SNMP? Sería conveniente conocer los datos completos de la sección de configuración de dicho módulo. 

Como comprobación adicional, ¿cuál es el resultado que devuelve la creación del módulo a través del SNMP Wizard?

Un cordial saludo, 

Eduardo.
Hola Eduardo,

SNMP Wizzard no encuentra nada, pero me pasó siempre con este tipo de dispositivos, solo encuentra objetos por ejemplo en servidores con linux.

SNMP Interface Wizzard encuentra interfaces con el puerto 161 (por defecto) que correspondería en este caso al equipo 1. En cambio si uso el puerto 171 da error "No se pudo realizar el SNMP walk" en caso de usar v1, si uso v2c no encuentra nada.

Creo haber encontrado donde esta el problema, aunque no se a que se debe:

Probé consultar directamente por comando snmpget desde la consola de CentOS del server Pandora y me encontré que efectivamente devuelve No Such Object available on this agent at this OID

[[email protected] ~]# snmpget -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13

SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13 = No Such Object available on this agent at this OID


Sin embargo si en vez de snmpget uso snmpwalk devuelve el valor esperado:

[[email protected] ~]# snmpwalk -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13

SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13.1 = STRING: "599.2"



Entiendo que en los modulos remote SNMP Pandora debe usar el comando snmpget internamente y allí el problema. La pregunta sería porque snmpget retorna "No Such Object available on this agent at this OID" al consultar por un puerto distinto al 161.

Alguna idea de como solucionarlo?

Adjunto la captura de la configuración del modulo solicitada

.png   Captura_SNMP_port_171.PNG (Size: 28.66 KB / Downloads: 2)

Saludos!!
 Reply
#6
(06-12-2019, 02:50 PM)yoluquitas Wrote:
(06-12-2019, 09:25 AM)eduardo.corral Wrote:
(06-11-2019, 11:49 AM)yoluquitas Wrote:
(06-11-2019, 09:14 AM)eduardo.corral Wrote:
(06-10-2019, 02:50 PM)yoluquitas Wrote: Estoy intentando crear modulos SNMP de una equipo que usa un puerto diferente al 161 y no funciona.

Son 2 equipos en verdad comunicados entre sí (equipo 1 y equipo 2) , las consultas se hacen a al equipo 1:

Para consultar las variables por SNMP del Equipo 1 se usa la IP del equipo 1 y el puerto 161

Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171


En sí los equipos responden perfectamente, lo corroboré tanto con el SW MIB browser e incluso con la herramienta "Navegador SNMP" del Pandora, en este caso para el equipo 2 use (IP de equipo1):171

El problema es que al crear un modulo remote SNMP para el equipo 2, este modulo queda como "no inicializado" probé tanto poniendo "171" en el campo "Puerto" como agregándolo en la IP (IP:171) en la configuración del modulo. De ninguna forma funciona.



Pandora FMS v7.0NG.731 - Build 191231 - MR 24

Se agradece una ayuda!

Saludos!

Buenos días, yoluquitas

Lo primero de todo es recomendarte que actualices tu instalación de Pandora FMS. Actualmente estamos funcionando bajo la versión 735 MR 28. 

Mantener Pandora FMS actualizado ayudará a prevenir posibles errores. 

Siguiendo con la duda que nos propones, ¿podrías indicarnos qué equipo es en el que está instalado el servidor? ¿Equipo 1 y Equipo 2 hacen referencia a switches? ¿Se trata de otros dispositivos?


Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

Un cordial saludo, 

Eduardo.

Hola Eduardo, cómo estas?

Gracias por tu pronta respuesta!

Entiendo tu sugerencia de actualizar Pandora, pero quisiera hacerlo si se que va a resolver ese error, ya que podría llegar a surgir otro inconveniente tras la actualización.

En caso de los equipos 1 y 2 son parte de un transmisor dvb-t2 uno procesa la señal y el otro la modula básicamente los equipos son un apliance de R&S.

Pandora FMS corre en una VM VMware dentro de un server IBM System x M3.

El error parecería ser que Pandora no usa el puerto que se le indica en el campo "puerto" en la configuración del modulo.

El modulo queda como no inicializado, con valor 0 en caso de elegir tipo "numeric data"
Si en cambio elijo "alphanumeric data"muestra estado normal con valor: No Such Object available on this agent at this OID

Sin embargo como mencioné anteriormente, la herramienta navegador SNMP de Pandora muestra un valor correcto


Quote:
Quote:Para consultar las variables por SNMP del Equipo 2 se usa también la IP del equipo 1 y el puerto 171

¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

No es posible hacer eso, al equipo 2 se accede mediante el equipo 1 ya que hay comunicación entre ellos.

Saludos!

Buenos días, yoluquitas

¿Puedes enviarnos capturas de cómo se está estableciendo la configuración del módulo SNMP? Sería conveniente conocer los datos completos de la sección de configuración de dicho módulo. 

Como comprobación adicional, ¿cuál es el resultado que devuelve la creación del módulo a través del SNMP Wizard?

Un cordial saludo, 

Eduardo.
Hola Eduardo,

SNMP Wizzard no encuentra nada, pero me pasó siempre con este tipo de dispositivos, solo encuentra objetos por ejemplo en servidores con linux.

SNMP Interface Wizzard encuentra interfaces con el puerto 161 (por defecto) que correspondería en este caso al equipo 1. En cambio si uso el puerto 171 da error "No se pudo realizar el SNMP walk" en caso de usar v1, si uso v2c no encuentra nada.

Creo haber encontrado donde esta el problema, aunque no se a que se debe:

Probé consultar directamente por comando snmpget desde la consola de CentOS del server Pandora y me encontré que efectivamente devuelve No Such Object available on this agent at this OID

[[email protected] ~]# snmpget -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13

SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13 = No Such Object available on this agent at this OID


Sin embargo si en vez de snmpget uso snmpwalk devuelve el valor esperado:

[[email protected] ~]# snmpwalk -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13

SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13.1 = STRING: "599.2"



Entiendo que en los modulos remote SNMP Pandora debe usar el comando snmpget internamente y allí el problema. La pregunta sería porque snmpget retorna "No Such Object available on this agent at this OID" al consultar por un puerto distinto al 161.

Alguna idea de como solucionarlo?

Adjunto la captura de la configuración del modulo solicitada


Saludos!!

Hola yoluquitas,

Según tu snmpwalk veo que te devuelve este valor:
SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13.1 = STRING: "599.2"

Sin embargo para introducir el get te está faltando el último .1 del OID, para el get necesitas introducir el OID completo, el walk devuelve todo el polling que vaya coincidiendo con las líneas del OID introducido, sin necesidad de introducir ninguno exacto.

¿Puedes probar en el CentOS del server este comando?

snmpget -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13.1

A ver si así te devuelve valor. Si te devuelve pon en el OID del módulo también el último .1

Un saludo.
 Reply
#7
(06-12-2019, 03:12 PM)jose.almendros Wrote:
(06-12-2019, 02:50 PM)yoluquitas Wrote:
(06-12-2019, 09:25 AM)eduardo.corral Wrote:
(06-11-2019, 11:49 AM)yoluquitas Wrote:
(06-11-2019, 09:14 AM)eduardo.corral Wrote: Buenos días, yoluquitas

Lo primero de todo es recomendarte que actualices tu instalación de Pandora FMS. Actualmente estamos funcionando bajo la versión 735 MR 28. 

Mantener Pandora FMS actualizado ayudará a prevenir posibles errores. 

Siguiendo con la duda que nos propones, ¿podrías indicarnos qué equipo es en el que está instalado el servidor? ¿Equipo 1 y Equipo 2 hacen referencia a switches? ¿Se trata de otros dispositivos?



¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

Un cordial saludo, 

Eduardo.

Hola Eduardo, cómo estas?

Gracias por tu pronta respuesta!

Entiendo tu sugerencia de actualizar Pandora, pero quisiera hacerlo si se que va a resolver ese error, ya que podría llegar a surgir otro inconveniente tras la actualización.

En caso de los equipos 1 y 2 son parte de un transmisor dvb-t2 uno procesa la señal y el otro la modula básicamente los equipos son un apliance de R&S.

Pandora FMS corre en una VM VMware dentro de un server IBM System x M3.

El error parecería ser que Pandora no usa el puerto que se le indica en el campo "puerto" en la configuración del modulo.

El modulo queda como no inicializado, con valor 0 en caso de elegir tipo "numeric data"
Si en cambio elijo "alphanumeric data"muestra estado normal con valor: No Such Object available on this agent at this OID

Sin embargo como mencioné anteriormente, la herramienta navegador SNMP de Pandora muestra un valor correcto


Quote:¿Qué valores obtienes a la hora de consultar las variables del Equipo 2 si introduces como datos la IP propia de ese equipo con su puerto correspondiente?

No es posible hacer eso, al equipo 2 se accede mediante el equipo 1 ya que hay comunicación entre ellos.

Saludos!

Buenos días, yoluquitas

¿Puedes enviarnos capturas de cómo se está estableciendo la configuración del módulo SNMP? Sería conveniente conocer los datos completos de la sección de configuración de dicho módulo. 

Como comprobación adicional, ¿cuál es el resultado que devuelve la creación del módulo a través del SNMP Wizard?

Un cordial saludo, 

Eduardo.
Hola Eduardo,

SNMP Wizzard no encuentra nada, pero me pasó siempre con este tipo de dispositivos, solo encuentra objetos por ejemplo en servidores con linux.

SNMP Interface Wizzard encuentra interfaces con el puerto 161 (por defecto) que correspondería en este caso al equipo 1. En cambio si uso el puerto 171 da error "No se pudo realizar el SNMP walk" en caso de usar v1, si uso v2c no encuentra nada.

Creo haber encontrado donde esta el problema, aunque no se a que se debe:

Probé consultar directamente por comando snmpget desde la consola de CentOS del server Pandora y me encontré que efectivamente devuelve No Such Object available on this agent at this OID

[[email protected] ~]# snmpget -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13

SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13 = No Such Object available on this agent at this OID


Sin embargo si en vez de snmpget uso snmpwalk devuelve el valor esperado:

[[email protected] ~]# snmpwalk -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13

SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13.1 = STRING: "599.2"



Entiendo que en los modulos remote SNMP Pandora debe usar el comando snmpget internamente y allí el problema. La pregunta sería porque snmpget retorna "No Such Object available on this agent at this OID" al consultar por un puerto distinto al 161.

Alguna idea de como solucionarlo?

Adjunto la captura de la configuración del modulo solicitada


Saludos!!

Hola yoluquitas,

Según tu snmpwalk veo que te devuelve este valor:
SNMPv2-SMI::enterprises.2566.127.1.2.167.201.1.2.1.13.1 = STRING: "599.2"

Sin embargo para introducir el get te está faltando el último .1 del OID, para el get necesitas introducir el OID completo, el walk devuelve todo el polling que vaya coincidiendo con las líneas del OID introducido, sin necesidad de introducir ninguno exacto.

¿Puedes probar en el CentOS del server este comando?

snmpget -c public -v 2c 192.168.53.31:171 .1.3.6.1.4.1.2566.127.1.2.167.201.1.2.1.13.1

A ver si así te devuelve valor. Si te devuelve pon en el OID del módulo también el último .1

Un saludo.

Hola Eduardo, 
Tenes razón, como no me di cuenta... jejej
Gracias! ese era el problema, ahora funciona tanto con el comando desde consola como en el modulo de Pandora.

Saludos!!
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes