Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble updating from 724 to 735
#11
(07-02-2019, 02:54 PM)eduardo.corral Wrote:
(07-02-2019, 02:16 PM)nmsadmin Wrote: Why are you deleting my and your own posts?!


Greetings nmsadmin

There must be some kind of mistake, because I can see every post in the thread. Please try to go to the first page of the thread to see the initial messages. 

Kind regards, 

Eduardo.

Hi Eduardo,

Sorry for the wrong accusation...

turns out there must be some bug with the forums engine! When logged in as nmsadmin, I can see posts #1 -5 on the first page and then two deleted entries, then posts #11 -12 on the second site, which are the #9 and #10 in reality (see forum.pdf attached).

Tested on newest Firefox and Chrome, tried clearing cache as well.

I will make a new upgrade attempt with the info you provided today and will post the results! 


Best, Tim


Attached Files


.pdf   forum.pdf (Size: 252.34 KB / Downloads: 1)
 Reply
#12
Hi,

I have done a new approach from scratch, with your latest instructions:

1.# systemctl stop httpd

2.# /etc/init.d/pandora_server stop

3.# /etc/init.d/tentacle_serverd stop

4.# nano /etc/yum.repos.d/maria10-3.repo
Code:
# MariaDB 10.3 CentOS repository list - created 2018-11-19 23:14 UTC
# http://downloads.mariadb.org/mariadb/repositories/
[mariadb]
name = MariaDB
baseurl = http://yum.mariadb.org/10.3/centos7-amd64
gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
gpgcheck=1

5.# yum -y upgrade maria*
6.# systemctl restart mariadb
7.# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
8.# yum -y install epel-release
9.# rpm -Uvh http://rpms.remirepo.net/enterprise/remi-release-7.rpm
10.# yum -y install yum-utils
11.# yum update
12.# yum-config-manager --enable remi-php72
13.# yum remove php-common
14.# yum -y install php php-opcache php-gd php-ldap php-snmp php-mysqlnd php-mbstring php-zip php-pecl-zip perl-Geo-IP
15.# rpm -U --force pandorafms_console-7.0NG.736-1.noarch.rpm
16.# rpm -U --force pandorafms_server-7.0NG.736-1.noarch.rpm
17.# systemctl start httpd
18.# /etc/init.d/pandora_server start
19.# /etc/init.d/tentacle_serverd start

20.# cd /var/www/html/pandora_console/extras/mr
21.# nano run.sh
Code:
#/bin/bash
for i in `ls | sort -n;`
do
mysql -u root -pPASSWORD pandora -e "source $i"
done

22.# chmod +x run.sh
23.# ./run.sh

Code:
WHAT FAILED:

ERROR 1364 (HY000) at line 28 in file: '1.sql': Field 'description' doesn't have a default value



ERROR 1406 (22001) at line 10 in file: '8.sql': Data too long for column 'description' at row 1



ERROR 1064 (42000) at line 50 in file: '14.sql': You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the                                                                                                                                                       right syntax to use near '0' at line 1
ERROR 1243 (HY000) at line 51 in file: '14.sql': Unknown prepared statement handler (pr_oum721) given to EXECUTE
ERROR 1243 (HY000) at line 52 in file: '14.sql': Unknown prepared statement handler (pr_oum721) given to DEALLOCATE PREPARE



ERROR 1091 (42000) at line 3 in file: '15.sql': Can't DROP FOREIGN KEY `tcluster_ibfk_1`; check that it exists                  
ERROR 1091 (42000) at line 7 in file: '15.sql': Can't DROP FOREIGN KEY `tcluster_agent_ibfk_2`; check that it exists



ERROR 1146 (42S02) at line 14 in file: '27.sql': Table 'pandora.tuser_task' doesn't exist



But now the service pandora_server starts and keeps running!

However, no agents are able to connect to the server, no data is incoming.

From pandora error log on startup:

DBD::mysql::db do failed: Incorrect double value: '' for column `pandora`.`tevento`.`data` at row 1 at /usr/lib/perl5/PandoraFMS/DB.pm line 875.

25 at /usr/lib/perl5/PandoraFMS/DB.pm line 885.
Perl exited with active threads:
        57 running and unjoined
        0 finished and unjoined
        0 running and detached

I think the perl issue is the main problem but I have no idea what's causing it.


Best regards,

Tim
 Reply
#13
Any ideas?
 Reply
#14
(07-18-2019, 09:43 AM)nmsadmin Wrote: Any ideas?

Greetings, nmsadmin

Please check the status of MySQL to see if it's up. 

Try to restart the server and send us if you can the configuration files from both the agent and the server. 

Kind regards, 

Eduardo.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes