Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problema actualización de Pandora 7
#1
Buenas, actualmente estoy teniendo dificultades para conseguir que funcione la última versión de Pandora, intentando actualizar desde la 728 a la 735.

Escenario actual:

Me encuentro con Ubuntu 14, PHP 5.6, MySQL 5.5 y Pandora FMS 7-728 todo funcionando.
En el momento de actualizar a Ubuntu 16 Pandora deja de funcionar y salta el siguiente error en los logs:

2019-06-27 10:36:33 - pandora Starting Pandora FMS Server. Error logging activated.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/PandoraFMS/Core.pm line 4830.
DBD::mysql::db do failed: Data truncated for column 'data' at row 1 at /usr/lib/perl5/PandoraFMS/DB.pm line 1136.
24 at /usr/lib/perl5/PandoraFMS/DB.pm line 1144.

Si intento actualizar a la 735 con PHP 7.2 me los saca igual.

Cabe destacar que al pasar a Ubuntu 16 me actualiza a MySQL 5.7 y le hace un upgrade a la base de datos de pandora.



Gracias de antemano.
 Reply
#2
(06-27-2019, 09:33 AM)Rodry Wrote: Buenas, actualmente estoy teniendo dificultades para conseguir que funcione la última versión de Pandora, intentando actualizar desde la 728 a la 735.

Escenario actual:

Me encuentro con Ubuntu 14, PHP 5.6, MySQL 5.5 y Pandora FMS 7-728 todo funcionando.
En el momento de actualizar a Ubuntu 16 Pandora deja de funcionar y salta el siguiente error en los logs:

2019-06-27 10:36:33 - pandora Starting Pandora FMS Server. Error logging activated.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/PandoraFMS/Core.pm line 4830.
DBD::mysql::db do failed: Data truncated for column 'data' at row 1 at /usr/lib/perl5/PandoraFMS/DB.pm line 1136.
24 at /usr/lib/perl5/PandoraFMS/DB.pm line 1144.

Si intento actualizar a la 735 con PHP 7.2 me los saca igual.

Cabe destacar que al pasar a Ubuntu 16 me actualiza a MySQL 5.7 y le hace un upgrade a la base de datos de pandora.



Gracias de antemano.

Buenas tardes Rodry,


En Ubuntu puede suceder que tengas PHP 5.6 y PHP 7.2 los dos instalados y funcionando, por favor comprueba que Pandora realmente este utilizando el PHP 7.2.

En caso de que sea así comprueba que tengas todas las dependencias de PHP 7.2 necesarias, ya que necesita más paquetes, no únicamente php7.2.


En cuanto al cambio de versión de MySQL, no es un problema pues las nuevas versiones de Pandora FMS son compatibles con la versión 5.7.


Si todo esto es correcto, comprueba que tengas levantados los servicios de apache, MySQL y tentacle antes de iniciar la consola. Una vez inicies la consola y accedas a ella, prueba a iniciar el pandora_serverd.

Muchas gracias.

Un cordial saludo, 

Eduardo.
 Reply
#3
(06-27-2019, 03:38 PM)eduardo.corral Wrote: Buenas tardes Rodry,


En Ubuntu puede suceder que tengas PHP 5.6 y PHP 7.2 los dos instalados y funcionando, por favor comprueba que Pandora realmente este utilizando el PHP 7.2.

En caso de que sea así comprueba que tengas todas las dependencias de PHP 7.2 necesarias, ya que necesita más paquetes, no únicamente php7.2.


En cuanto al cambio de versión de MySQL, no es un problema pues las nuevas versiones de Pandora FMS son compatibles con la versión 5.7.


Si todo esto es correcto, comprueba que tengas levantados los servicios de apache, MySQL y tentacle antes de iniciar la consola. Una vez inicies la consola y accedas a ella, prueba a iniciar el pandora_serverd.

Muchas gracias.

Un cordial saludo, 

Eduardo.

Buenas noches Eduardo,

Antes que nada, muchas gracias por tu anterior respuesta, efectivamente revisando las dependencias y asegurandome de que solo existía php 7.2 he conseguido que al arrancar no me de ningún error y me diga que revise los logs.

Ahora el problema viene cuando entro en la web (adjunto imagen) y veo que todos los componentes han crasheado, como la base de datos, el servidor de red, el servidor wmi, etc... y además me dice que no encuentra un servidor maestro, pero en la configuración tiene master el valor 1.

Además en los logs puedo ver lo siguiente al iniciar el servicio:
2019-06-27 21:46:38 pandora [V1] Launching 7.0NG.735 190530
2019-06-27 21:46:38 pandora [V1] Config options: Logfile at /var/log/pandora/pandora_server.log, Basepath is /etc/pandora/pandora_server.conf, Checksum is 0, Master is 1, SNMP Console is 0, Server Threshold at 5 sec, verbosity at 3, Alert Threshold at 60, ServerName is 'pandora'
2019-06-27 21:46:38 pandora [V1] Pandora FMS Enterprise module not available.                                     
2019-06-27 21:46:39 pandora [V1] Netflow daemon disabled.                                                         
2019-06-27 21:46:39 pandora [V3] Warmup mode for unknown modules started.                                              

2019-06-27 21:46:39 pandora [V1] [E] 'pandora': DBD::mysql::db do failed: Data truncated for column 'data' at row 1 at /usr/lib/perl5/PandoraFMS/DB.pm line 875.                                                                                                                                                                                           
2019-06-27 21:46:39 pandora [V1] Pandora FMS Server 'pandora' unhandled error.                                         

2019-06-27 21:46:39 pandora [V1] [E] 'pandora': 25 at /usr/lib/perl5/PandoraFMS/DB.pm line 885.                                                                                                                                                

2019-06-27 21:46:39 pandora [V1] Pandora FMS Server 'pandora' unhandled error.        
[*]

Gracias de antemano.

Un saludo.


Attached Files


.png   Error web.PNG (Size: 25.59 KB / Downloads: 4)
 Reply
#4
(06-27-2019, 07:56 PM)Rodry Wrote:
(06-27-2019, 03:38 PM)eduardo.corral Wrote: Buenas tardes Rodry,


En Ubuntu puede suceder que tengas PHP 5.6 y PHP 7.2 los dos instalados y funcionando, por favor comprueba que Pandora realmente este utilizando el PHP 7.2.

En caso de que sea así comprueba que tengas todas las dependencias de PHP 7.2 necesarias, ya que necesita más paquetes, no únicamente php7.2.


En cuanto al cambio de versión de MySQL, no es un problema pues las nuevas versiones de Pandora FMS son compatibles con la versión 5.7.


Si todo esto es correcto, comprueba que tengas levantados los servicios de apache, MySQL y tentacle antes de iniciar la consola. Una vez inicies la consola y accedas a ella, prueba a iniciar el pandora_serverd.

Muchas gracias.

Un cordial saludo, 

Eduardo.

Buenas noches Eduardo,

Antes que nada, muchas gracias por tu anterior respuesta, efectivamente revisando las dependencias y asegurandome de que solo existía php 7.2 he conseguido que al arrancar no me de ningún error y me diga que revise los logs.

Ahora el problema viene cuando entro en la web (adjunto imagen) y veo que todos los componentes han crasheado, como la base de datos, el servidor de red, el servidor wmi, etc... y además me dice que no encuentra un servidor maestro, pero en la configuración tiene master el valor 1.

Además en los logs puedo ver lo siguiente al iniciar el servicio:
2019-06-27 21:46:38 pandora [V1] Launching 7.0NG.735 190530
2019-06-27 21:46:38 pandora [V1] Config options: Logfile at /var/log/pandora/pandora_server.log, Basepath is /etc/pandora/pandora_server.conf, Checksum is 0, Master is 1, SNMP Console is 0, Server Threshold at 5 sec, verbosity at 3, Alert Threshold at 60, ServerName is 'pandora'
2019-06-27 21:46:38 pandora [V1] Pandora FMS Enterprise module not available.                                     
2019-06-27 21:46:39 pandora [V1] Netflow daemon disabled.                                                         
2019-06-27 21:46:39 pandora [V3] Warmup mode for unknown modules started.                                              

2019-06-27 21:46:39 pandora [V1] [E] 'pandora': DBD::mysql::db do failed: Data truncated for column 'data' at row 1 at /usr/lib/perl5/PandoraFMS/DB.pm line 875.                                                                                                                                                                                           
2019-06-27 21:46:39 pandora [V1] Pandora FMS Server 'pandora' unhandled error.                                         

2019-06-27 21:46:39 pandora [V1] [E] 'pandora': 25 at /usr/lib/perl5/PandoraFMS/DB.pm line 885.                                                                                                                                                

2019-06-27 21:46:39 pandora [V1] Pandora FMS Server 'pandora' unhandled error.        
[*]

Gracias de antemano.

Un saludo.
[*]

Buenas tardes Rodry

¿Podrías indicarnos qué MR tienes instalado? En caso de que se encuentre desactualizado será necesario ejecutar el siguiente comando desde /extras/mr/

Code:
for i in `ls | sort -n`; do mysql -u root -ppandora pandora -e "source $i"; done
[*]

De igual forma, ¿podrías enviarnos por favor la configuración del archivo pandora_server.conf? Lo encontrarás en /etc/pandora/

Un cordial saludo, 

Eduardo.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes