Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error al ingresar a Pandora por la Web luego de recuperar un backup en CentOS 7
#1
Estimados, 

Luego de que el disco duro del servidor de Pandora se dañara, instalé nuevamente el Sistema operativo y recuperé la base de datos de respaldo, pero al ingresar con cualquiera de los usuarios anteriormente creados, aunque lo permitiese, sale toda la pantalla en blanco a excepción de una franja negra con un borde verde, que es en donde se sitúan, en una vista normal, los íconos, la barra de búsqueda, el nombre de usuario, etc. La verdad ya he intentado muchas cosas y no encuentro la solución. Agradecería bastante puedan ayudarme. Adjunto print de pantalla con el error dado.


Attached Files


.png   Error.png (Size: 24.78 KB / Downloads: 2)
 Reply
#2
Buenas ifxsoporte,

Ese error puede darse en versiones antiguas de PHP, comprueba que tienes las dependecias de PHP7 o superior, puedes ver los comandos necesarios en el siguiente link.
https://pandorafms.com/docs/index.php?ti...nstalacion

En caso de persistir el error manda los logs de Apache y del servidor de Pandora FMS.

Log Apache: /var/log/apache2/error.log
Log Servidor: /var/log/pandora/pandora_server.error & pandora_server.log

Saludos, Diego.
 Reply
#3
Muchas gracias Sr. Diego, la verdad es que logré solucionarlo de otra manera, y es que estaba colocando la ISO v736, y con la que lo instalé, fue la ISO v723. 

Ahora bien, aprovechando la oportunidad, tengo una duda con respecto a las actualizaciones, me gustaría realizar el upgrade a esta última versión, más sin embargo en actualizaciones menores, el asistente siempre dice que no se pudo aplicar la actualización de la base de datos, y cuando la aplico a través de comandos en el servidor, aveces indica que hay tablas duplicadas no aplica el paquete. Cómo podría actuar para que se actualice correctamente, y que pasos debería seguir para llevar de manera correcta, mi versión 723, a la 736.
 Reply
#4
Buenas ifxsoporte,

Para solucionar el problema de las actualizaciones menores, te recomendamos que descargues la v736 de la pagina: https://sourceforge.net/projects/pandora...7.0NG/736/ alli puedes encontrar  los paquetes de PandoraFMS para el SO del que dispongas.

Una vez hecho esto puedes seguir los pasos de la siguiente web https://pandorafms.com/docs/index.php?ti...nstalacion para actualizar por paquetes PandoraFMS, una vez actualizado a la ultima version deberas tomar todos los mr que falten y finalmente en mysql realizar los cambios de mr mediante la siguiente sentencia:


source /var/www/html/pandora_console/extras/mr/XX.sql;
update tconfig set value=29 where token="29";

En el comnado source deberas introducir uno a uno los MR que no tengas aplicados, dado que partias de la v732 deberas introducir desde el 25.sql hasta el 29.sql.

Con todo esto tendras PandoraFMS actualizado a su ultima version.

Saludos
Diego
 Reply
#5
(07-23-2019, 09:42 AM)DiegoM Wrote: Buenas ifxsoporte,

Para solucionar el problema de las actualizaciones menores, te recomendamos que descargues la v736 de la pagina: https://sourceforge.net/projects/pandora...7.0NG/736/ alli puedes encontrar  los paquetes de PandoraFMS para el SO del que dispongas.

Una vez hecho esto puedes seguir los pasos de la siguiente web https://pandorafms.com/docs/index.php?ti...nstalacion para actualizar por paquetes PandoraFMS, una vez actualizado a la ultima version deberas tomar todos los mr que falten y finalmente en mysql realizar los cambios de mr mediante la siguiente sentencia:


source /var/www/html/pandora_console/extras/mr/XX.sql;
update tconfig set value=29 where token="29";

En el comnado source deberas introducir uno a uno los MR que no tengas aplicados, dado que partias de la v732 deberas introducir desde el 25.sql hasta el 29.sql.

Con todo esto tendras PandoraFMS actualizado a su ultima version.

Saludos
Diego
Buenas tardes Diego, muchas gracias por la información, tengo una duda, colocas que partía de la v732 y es de la v723, fue un error de dedo o cómo?, para saber si introduzco desde la 25.sql o no.

Por otra parte existen dos dudas más, por los momentos solo haré una ya que al realizar la actualización, espero pueda arreglarse la segunda, de no ser así efectuaré la consulta por aquí nuevamente. Cuando hice la recuperación del respaldo varios de los anteriores módulos del servidor me salían en gris y luego se creaban nuevamente en verde de manera automática (Anexo la imagen en donde se muestra lo indicado) y todo funcionaba perfecto, sin embargo, al eliminar los de color gris, todos los módulos de monitoreo de los clientes dejaban de funcionar. Cómo podría hacer yo para retirarlos sin que esto no pase o hacer que vuelvan a funcionar los que están en gris y retirar los que se encuentran en verde?-


Attached Files


.png   Print.png (Size: 44.6 KB / Downloads: 2)
 Reply
#6
(07-26-2019, 07:16 PM)ifxsoporte Wrote:
(07-23-2019, 09:42 AM)DiegoM Wrote: Buenas ifxsoporte,

Para solucionar el problema de las actualizaciones menores, te recomendamos que descargues la v736 de la pagina: https://sourceforge.net/projects/pandora...7.0NG/736/ alli puedes encontrar  los paquetes de PandoraFMS para el SO del que dispongas.

Una vez hecho esto puedes seguir los pasos de la siguiente web https://pandorafms.com/docs/index.php?ti...nstalacion para actualizar por paquetes PandoraFMS, una vez actualizado a la ultima version deberas tomar todos los mr que falten y finalmente en mysql realizar los cambios de mr mediante la siguiente sentencia:


source /var/www/html/pandora_console/extras/mr/XX.sql;
update tconfig set value=29 where token="29";

En el comnado source deberas introducir uno a uno los MR que no tengas aplicados, dado que partias de la v732 deberas introducir desde el 25.sql hasta el 29.sql.

Con todo esto tendras PandoraFMS actualizado a su ultima version.

Saludos
Diego
Buenas tardes Diego, muchas gracias por la información, tengo una duda, colocas que partía de la v732 y es de la v723, fue un error de dedo o cómo?, para saber si introduzco desde la 25.sql o no.

Por otra parte existen dos dudas más, por los momentos solo haré una ya que al realizar la actualización, espero pueda arreglarse la segunda, de no ser así efectuaré la consulta por aquí nuevamente. Cuando hice la recuperación del respaldo varios de los anteriores módulos del servidor me salían en gris y luego se creaban nuevamente en verde de manera automática (Anexo la imagen en donde se muestra lo indicado) y todo funcionaba perfecto, sin embargo, al eliminar los de color gris, todos los módulos de monitoreo de los clientes dejaban de funcionar. Cómo podría hacer yo para retirarlos sin que esto no pase o hacer que vuelvan a funcionar los que están en gris y retirar los que se encuentran en verde?-

Buenas ifxsoporte,

Perdona por el error, efectivamente me bailaron los numeros de la version, deberias probar a aplicar los .sql desde el 25 en adelante.

Respecto a tu segunda duda, esto suele ocurrir cuando el nombre de la maquina varia, probablemente antes del backup se llamaba Pandora-FMS y ahora la llamaste Pandora, el problema de esto es que los agentes se suelen relacionar con el nombre de la maquina que hace de servidor, por lo que al borrar los servidores llamandos Pandora-FMS todos los modulos comienzan a fallar. La solución esta en cambiar el servidor de los agentes afectados ( Esto se puede realizar mediante bulk operations )

Espero haber resuelto tus dudas!
Diego
 Reply
#7
(07-29-2019, 07:52 AM)DiegoM Wrote:
(07-26-2019, 07:16 PM)ifxsoporte Wrote:
(07-23-2019, 09:42 AM)DiegoM Wrote: Buenas ifxsoporte,

Para solucionar el problema de las actualizaciones menores, te recomendamos que descargues la v736 de la pagina: https://sourceforge.net/projects/pandora...7.0NG/736/ alli puedes encontrar  los paquetes de PandoraFMS para el SO del que dispongas.

Una vez hecho esto puedes seguir los pasos de la siguiente web https://pandorafms.com/docs/index.php?ti...nstalacion para actualizar por paquetes PandoraFMS, una vez actualizado a la ultima version deberas tomar todos los mr que falten y finalmente en mysql realizar los cambios de mr mediante la siguiente sentencia:


source /var/www/html/pandora_console/extras/mr/XX.sql;
update tconfig set value=29 where token="29";

En el comnado source deberas introducir uno a uno los MR que no tengas aplicados, dado que partias de la v732 deberas introducir desde el 25.sql hasta el 29.sql.

Con todo esto tendras PandoraFMS actualizado a su ultima version.

Saludos
Diego
Buenas tardes Diego, muchas gracias por la información, tengo una duda, colocas que partía de la v732 y es de la v723, fue un error de dedo o cómo?, para saber si introduzco desde la 25.sql o no.

Por otra parte existen dos dudas más, por los momentos solo haré una ya que al realizar la actualización, espero pueda arreglarse la segunda, de no ser así efectuaré la consulta por aquí nuevamente. Cuando hice la recuperación del respaldo varios de los anteriores módulos del servidor me salían en gris y luego se creaban nuevamente en verde de manera automática (Anexo la imagen en donde se muestra lo indicado) y todo funcionaba perfecto, sin embargo, al eliminar los de color gris, todos los módulos de monitoreo de los clientes dejaban de funcionar. Cómo podría hacer yo para retirarlos sin que esto no pase o hacer que vuelvan a funcionar los que están en gris y retirar los que se encuentran en verde?-

Buenas ifxsoporte,

Perdona por el error, efectivamente me bailaron los numeros de la version, deberias probar a aplicar los .sql desde el 25 en adelante.

Respecto a tu segunda duda, esto suele ocurrir cuando el nombre de la maquina varia, probablemente antes del backup se llamaba Pandora-FMS y ahora la llamaste Pandora, el problema de esto es que los agentes se suelen relacionar con el nombre de la maquina que hace de servidor, por lo que al borrar los servidores llamandos Pandora-FMS todos los modulos comienzan a fallar. La solución esta en cambiar el servidor de los agentes afectados ( Esto se puede realizar mediante bulk operations )

Espero haber resuelto tus dudas!
Diego
Muchas gracias Diego, he estado haciendo pruebas y con el tema de la actualización de la BD no ha habido mayor inconveniente excepto que a veces dicen los querys que hay algunas filas duplicadas o algunas primary keys ya existentes, hago caso omiso de ese mensaje?. Por otra parte la página que me indicaste no señala como actualizar el Pandora sino como hacer una instalación nueva. Debo entonces instalar los archivos de la última versión encima de la existente o cómo?.
 Reply
#8
(08-19-2019, 01:20 PM)ifxsoporte Wrote:
(07-29-2019, 07:52 AM)DiegoM Wrote:
(07-26-2019, 07:16 PM)ifxsoporte Wrote:
(07-23-2019, 09:42 AM)DiegoM Wrote: Buenas ifxsoporte,

Para solucionar el problema de las actualizaciones menores, te recomendamos que descargues la v736 de la pagina: https://sourceforge.net/projects/pandora...7.0NG/736/ alli puedes encontrar  los paquetes de PandoraFMS para el SO del que dispongas.

Una vez hecho esto puedes seguir los pasos de la siguiente web https://pandorafms.com/docs/index.php?ti...nstalacion para actualizar por paquetes PandoraFMS, una vez actualizado a la ultima version deberas tomar todos los mr que falten y finalmente en mysql realizar los cambios de mr mediante la siguiente sentencia:


source /var/www/html/pandora_console/extras/mr/XX.sql;
update tconfig set value=29 where token="29";

En el comnado source deberas introducir uno a uno los MR que no tengas aplicados, dado que partias de la v732 deberas introducir desde el 25.sql hasta el 29.sql.

Con todo esto tendras PandoraFMS actualizado a su ultima version.

Saludos
Diego
Buenas tardes Diego, muchas gracias por la información, tengo una duda, colocas que partía de la v732 y es de la v723, fue un error de dedo o cómo?, para saber si introduzco desde la 25.sql o no.

Por otra parte existen dos dudas más, por los momentos solo haré una ya que al realizar la actualización, espero pueda arreglarse la segunda, de no ser así efectuaré la consulta por aquí nuevamente. Cuando hice la recuperación del respaldo varios de los anteriores módulos del servidor me salían en gris y luego se creaban nuevamente en verde de manera automática (Anexo la imagen en donde se muestra lo indicado) y todo funcionaba perfecto, sin embargo, al eliminar los de color gris, todos los módulos de monitoreo de los clientes dejaban de funcionar. Cómo podría hacer yo para retirarlos sin que esto no pase o hacer que vuelvan a funcionar los que están en gris y retirar los que se encuentran en verde?-

Buenas ifxsoporte,

Perdona por el error, efectivamente me bailaron los numeros de la version, deberias probar a aplicar los .sql desde el 25 en adelante.

Respecto a tu segunda duda, esto suele ocurrir cuando el nombre de la maquina varia, probablemente antes del backup se llamaba Pandora-FMS y ahora la llamaste Pandora, el problema de esto es que los agentes se suelen relacionar con el nombre de la maquina que hace de servidor, por lo que al borrar los servidores llamandos Pandora-FMS todos los modulos comienzan a fallar. La solución esta en cambiar el servidor de los agentes afectados ( Esto se puede realizar mediante bulk operations )

Espero haber resuelto tus dudas!
Diego
Muchas gracias Diego, he estado haciendo pruebas y con el tema de la actualización de la BD no ha habido mayor inconveniente excepto que a veces dicen los querys que hay algunas filas duplicadas o algunas primary keys ya existentes, hago caso omiso de ese mensaje?. Por otra parte la página que me indicaste no señala como actualizar el Pandora sino como hacer una instalación nueva. Debo entonces instalar los archivos de la última versión encima de la existente o cómo?.

Adicionalmente estoy instalando manualmente el paquete y me aparece este error:

Error: Package: pandorafms_server-7.0NG.736-1.noarch.rpm

           Requires: perl(Geo::IP)

Instalé todas las dependencias que dice con el comando yum install geoip geoip-devel -y y aún así da el error.
 Reply
#9
Buenos días ifxsoporte,

Ten en cuenta que la dependencia que PandoraFMS necesita es una dependencia de Perl, me temo que estas instalando otras dependencias relacionadas (si no me equivoco) con PHP, por lo que no deberia de funcionarte. A continuación te adjunto un comando para ver si realmente el paquete de perl se ha instalado correctamente.

rpm -qa | grep Geo

Si está instalado correctamente, te debería salir un output como este:

[[email protected] ~]# rpm -qa | grep Geo
perl-Geo-IP-1.43-3.el7.x86_64
GeoIP-1.5.0-13.el7.x86_64

Si la salida de dicho comando está vacia, o no muestra estos paquetes, prueba con el siguiente comando:

yum install perl-Geo-IP

Si con este no sirve, te dejo un enlace para el rpm

https://pkgs.org/download/perl(Geo::IP)

Si tienes dudas en el proceso, no dudes en ponerte en contacto conmigo.

Un saludo,

Diego
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes