Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FMS installation on docker is not starting tentacle.
#1
Hello everyone.
Recently i've installed a docker image on an EC2 server.
The fms server is running, but the only ports the server is listening are these.

If I mannualy start the tentacle_serverd it starts to listen, but the clients are not being able to transfer it's data to them.

Any info or help i would appreciate it.


Code:
[[email protected] ~]$ docker exec -it pandorafms /bin/bash
[[email protected] /]# netstat -tulnup
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 0.0.0.0:80                  0.0.0.0:*                   LISTEN      187/httpd
tcp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      -
[[email protected] /]#
 Reply
#2
Hello Fgodoy,

From what I see in the command you have entered, you are missing some things such as redirecting ports from the real machine to the docker port. Also you must link your Pandora FMS with yu MySQL, below is an example of how this command should be.

docker run -p XXXXX:YYYYY --link pandora-mysql:mysql -d pandorafms/pandorafms-server:latest

Where XXXXX is your real machine port and YYYYY is the Pandora FMS port (In this case, tentacle port by default is 41121). Also make sure that the ports are free to use, for this you can use the next command.

netstat -lptaua

Best regards
Diego
 Reply
#3
(10-25-2019, 09:23 AM)DiegoM Wrote: Hello Fgodoy,

From what I see in the command you have entered, you are missing some things such as redirecting ports from the real machine to the docker port. Also you must link your Pandora FMS with yu MySQL, below is an example of how this command should be.

docker run -p XXXXX:YYYYY --link pandora-mysql:mysql -d pandorafms/pandorafms-server:latest

Where XXXXX is your real machine port and YYYYY is the Pandora FMS port (In this case, tentacle port by default is 41121). Also make sure that the ports are free to use, for this you can use the next command.

netstat -lptaua

Best regards
Diego

Hi Diego, may I ask you some help regarding the startup configuration procedure?

My ec2 machine has all ports open.
First i've installed the docker engine.
Then, curled this.
Code:
curl -sSL http://pandorafms.org/getpandora  | sh

Then the fms mysql  server.
Code:
docker run --name pandora-mysql -e MYSQL_ROOT_PASSWORD=AVeryStrongRootPassword -e MYSQL_DATABASE=pandora -e MYSQL_USER=pandora -e MYSQL_PASSWORD=pandora -d pandorafms/pandorafms-mysql:latest

(I dont remember if i've ran the latest or the 6 version)

Next the console
Code:
docker run -p 80:80 -p 8022:8022 -p 8023:8023 --link pandora-mysql:mysql -d pandorafms/pandorafms-console:latest


and
Code:
docker run -p 41121:41121 --link pandora-mysql:mysql -d pandorafms/pandorafms-server:6

Finally this:

[[email protected] ~]$ docker run --name pandorafms pandorafms/pandorafms:7
Starting mysqld:  [  OK  ]
Starting httpd: [  OK  ]
Starting crond: [  OK  ]
Pandora FMS Agent is now running with PID 233

Pandora FMS Server 7.0NG.739 Build 191025 Copyright © 2004-2018 Artica ST
This program is OpenSource, licensed under the terms of GPL License version 2.
You can download latest versions and documentation at official web page.

 
[*]Backgrounding Pandora FMS Server process.

Pandora FMS Server is now running with PID 338
2019-10-25 20:30:55 660d0a32a78e [V1] Launching 7.0NG.739 191025
2019-10-25 20:30:55 660d0a32a78e [V1] Config options: Logfile at /var/log/pandora/pandora_server.log, Basepath is /etc/pandora/pandora_server.conf, Checksum is 0, Master is 1, SNMP Console is 0, Server Threshold at 5 sec, verbosity at 3, Alert Threshold at 60, ServerName is '660d0a32a78e'
2019-10-25 20:30:55 660d0a32a78e [V1] 
[*]Pandora FMS Enterprise module not available.
2019-10-25 20:30:55 ** pandora_server **: 660d0a32a78e [V1] 
[*]Netflow daemon disabled.
2019-10-25 20:30:56 660d0a32a78e [V3] Warmup mode for unknown modules started.
2019-10-25 20:30:56 ** pandora_server **: 660d0a32a78e [V1] Server 660d0a32a78e is the current master.


After that i have these containers running:
Code:
[[email protected] ~]$ docker container ls -a
CONTAINER ID        IMAGE                                  COMMAND                  CREATED             STATUS              PORTS                                                                      NAMES
660d0a32a78e        pandorafms/pandorafms:7                "/bin/bash /entrypoi…"   38 minutes ago      Up 38 minutes       80/tcp, 3306/tcp, 41121/tcp, 162/udp                                       pandorafms
b106f90a5b8b        pandorafms/pandorafms-server:6         "/entrypoint.sh"         39 minutes ago      Up 39 minutes       0.0.0.0:41121->41121/tcp                                                   gallant_montalcini
c7b79601ad6a        pandorafms/pandorafms-console:latest   "/entrypoint.sh"         39 minutes ago      Up 39 minutes       0.0.0.0:80->80/tcp, 0.0.0.0:8022-8023->8022-8023/tcp, 162/udp, 41121/tcp   flamboyant_lamport
8e1d61148ee5        pandorafms/pandorafms-mysql:6          "/entrypoint.sh mysq…"   About an hour ago   Up About an hour    3306/tcp                                                                   pandora-mysql
[*]


The problem i have is that i cant access to the pandora_console.

Have i made some mistakes?

Sure did I. Where? I don't know.

Can you give me a little help?

Thanks!!!!
 Reply
#4
Hello Fgodoy,

If you have problems to connect to Pandora FMS console, check first that you connect to the correct ip, to do so access the docker and check the ip assigned to it.

docker exec -it id_container_console /bin/bash

ip a
ifconfig
nmtui
(I give you 3 options to use the correct one depending on your installation)

If your docker's IP is the correct one and you were accessing it (it should be a public ip when working with ec2), if it is not a conflict with the IP it could be the firewall, check in this case the following commands.

systemctl firewalld status = should be disabled.
getenforced = should be disabled.

In case the first command is active it uses:

systemctl firewalld stop

In case the second command is active use it:

vim /etc/selinux/config

SELINUX=disabled (check this option and exit the configuration file)

setenforce 0

getenforced

With this you should be able to access your docker console correctly. If something continues to fail tell us again and we will try to solve the problem as soon as possible.

Best regards
Diego
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes