Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Map can not be generated... Is attachments readable or issue with twopi
#1
Hi everyone. I hope this is the correct location to post this questions and that it's not too basic.

Anyways, I have the console, server & agent all up and running on a Centos 5.5 installation. I'm running Apache 2.2.3
php 5.3
mysql 5.0.77

with the latest Pandora FMS.

I can login to my console and see a couple agents that I have setup on different machines. Linux & windows both...

My issue is when I try to view the map I get the following error

Code:
Map could not be generated
Apparently something went wrong reading the output.

Is /var/www/php/pandora_console/attachment readable by the webserver process?

Is twopi (usually part of GraphViz) and echo installed and able to be executed by the webserver process?

For troubleshooting purposes I changed the permissions of the attachments folder and all sub-directories to 777. When that didn't resolve anything I changed the permissions of my entire webfolder to 777. Still no dice...

I have graphviz installed, graphviz-php and webdot. If I type twopi (which I don't really know exactly what it does just a general idea since it's related to graphviz and the map can't generate without it haha). Like i said if I type in twopi -v into the console I get the following

Code:
twopi - graphviz version 2.26.3 (20100126.1600)
Activated plugin library: libgvplugin_neato_layout.so.6
Using layout: twopi:neato_layout
Activated plugin library: libgvplugin_core.so.6
Using render: dot:core
Using device: dot:dot:core
The plugin configuration file:
        /usr/local/lib/graphviz/config6
                was successfully loaded.
    render      :  dot fig gd map ps svg tk vml xdot
    layout      :  circo dot fdp neato nop nop1 nop2 osage patchwork sfdp twopi
    textlayout  :
    device      :  canon cmap cmapx cmapx_np dot eps fig gd gd2 gif gv imap imap_np ismap jpe jpeg jpg plain plain-ext ps ps2 svg svgz tk vml vmlz wbmp xdot
    loadimage   :  (lib) eps gd gd2 gif jpe jpeg jpg png ps svg

Does anyone know what I can do to fix this issue or if it means I did something wrong during the installation?

Thanks a lot for your time.
 Reply
#2
Ok.

Could you check where is installed the Pandora Console?

Bye, thanks.
 Reply
#3
Pandora Console is located under /var/www/php/pandora_console

I changed the DocumentRoot to /var/www/php in my httpd.conf

Everything appears to be working fine except for generating the map.

Thanks for the reply.
 Reply
#4
I've setup another install...

And I still have the same issue.

This time I'm running from the normal web-root

/var/www/html/

When I ran the console installation it showed that I had all the dependencies installed. I have no idea what I could be doing wrong.
 Reply
#5
Well... I just installed Graphviz from RPM and it now works.

So just figured I would post that I had solved the issue.

I don't understand why it didn't work from source. During the ./configure it said that Twopi was installed by default and that the php module was being installed. It did a make and make install without an error. However, I guess something was wrong.

Thanks for taking the time earlier though. Just don't want you to spend anymore time on it sinc ei have it working now.

Thanks a lot and thanks so much for the amazing product!!!
 Reply
#6
today i had the same issue and i found that under pandora Administration/ setup was set a wrong path to "Attachment store"
 Reply
#7
Hi.

What is the version of Pandora?

Bye.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes