Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Módulo nuevo, sobre un agente viejo.
#1
Estimados.

Estoy con la versión 3.1.1 para agente y servidor.
Quise agregar un nuevo módulo, para medir la temperatura del disco del servidor, cambié a modo de aprendizaje, pero no ha pasado nada, ni siquiera se marcó como módulo no iniciado. No veo nada en el log tampoco.
Intenté crear el módulo en la parte web, pero nada.

Pero si ejecuto el comando, me entrega un número correcto.

Hice algo mal, hay que tener una nueva configuración, metí mal algo..

Saludos.
 Reply
#2
Algo más de detalle, por ejemplo, el código del módulo, sobre qué sistema corre el agente, la salida del comando que utilizas, para ver que funciona...
 Reply
#3
Actualicé la versión del agente, sin resultados.

el módulo es el siguiente:

module_begin
module_name TemperatureHDD
module_type generic_data
module_exec nc localhost 7634 | awk -F'|' '{print $4}'
module_description Disk Temperature
module_end

Estoy corriendo hddtemp.

Saludos.
 Reply
#4
Buenas, he probado el módulo sobre Ubuntu 10.10 y funciona correctamente tal y como está escrito.

Mira a ver si el usuario pandora puede ejecutar el comando. Si te da error, sobre Ubuntu/debian, prueba [tt]dpkg-reconfigure hddtemp[/tt] para activar el SUID de forma que usuarios normales puedan usar el comando, no sólo root.

Raul
 Reply
#5
El usuario pandora, ejecuta bien el comando.

Creo que para reinstalaré desde 0, cuando salga pandora 3.2, he tenido un par de problemas en la actualización (por ejemplo si pongo el agente de modo debug, puedo ver que el dato efectivamente va en el xml).
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes