Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pandora FMS 3.2 en Centos 5.5
#1
Buenas,

al intentar instalar siguiendo el manual las dependecias de paquetes mediante el comando:

rpm -i *.rpm

rpm -i *.rpm

advertencia:wmic-4.0.0SVN-2.1.el5.centos.noarch.rpm: CabeceraV3 DSA signature: NOKEY, key ID 155987ef
error: Error de dependencias:
        perl(IO::Interface) >= 0.94 se necesita para perl-IO-Socket-Multicast-1.12-1.i386
        perl(XML::NamespaceSupport) >= 1.04 se necesita para perl-XML-Simple-2.18-1.noarch
        perl(XML::SAX) se necesita para perl-XML-Simple-2.18-1.noarch
        php-pear se necesita para php-pear-db-1.7.14RC1-0.noarch
        php-pear se necesita para php-pear-xml_rpc-1.5.3-0.noarch
        libpopt.so.0 se necesita para wmic-4.0.0SVN-2.1.noarch

Qué es lo que falta ?

Muchas gracias.

Baxajaun
 Reply
#2
Buenas baxajaun,

¿Has instalado las dependencias previas a la instalación de los paquetes?

Code:
yum install php php-gd graphviz php-mysql php-pear-DB  php-mbstring php-ldap php-snmp php-ldap php-common

yum install perl-HTML-Tree perl-DBI perl-DBD-mysql perl-XML-Simple perl-XML-SAX perl-NetAddr-IP net-snmp net-tools nmap wmic sudo xprobe

Espero que te sirva. Saludos.
 Reply
#3
Hola Luismi,

en primer lugar muchas gracias por contestar.

Ahora queda así:

rpm -i *.rpm
advertencia:wmic-4.0.0SVN-2.1.el5.centos.noarch.rpm: CabeceraV3 DSA signature: NOKEY, key ID 155987ef
error: Error de dependencias:
        perl(IO::Interface) >= 0.94 se necesita para perl-IO-Socket-Multicast-1.12-1.i386
        libpopt.so.0 se necesita para wmic-4.0.0SVN-2.1.noarch


Saludos,
 Reply
#4
Hola baxajaun,

Prueba así:

Code:
rpm -i --nodeps *.rpm

Con esto debería funcionar.

Un saludo.
 Reply
#5
Hola Luismi,

muchas gracias, pero sigo teniendo problemas:

rpm -i --nodeps *.rpm
advertencia:wmic-4.0.0SVN-2.1.el5.centos.noarch.rpm: CabeceraV3 DSA signature: NOKEY, key ID 155987ef
        el archivo /usr/lib/perl5/vendor_perl/5.8.8/XML/Simple.pm de la instalación de perl-XML-Simple-2.18-1.noarch entra en conflicto con el archivo del paquete perl-XML-Simple-2.14-4.fc6.noarch
        el archivo /usr/share/man/man3/XML::Simple.3pm.gz de la instalación de perl-XML-Simple-2.18-1.noarch entra en conflicto con el archivo del paquete perl-XML-Simple-2.14-4.fc6.noarch
        el archivo /usr/share/man/man3/XML::Simple::FAQ.3pm.gz de la instalación de perl-XML-Simple-2.18-1.noarch entra en conflicto con el archivo del paquete perl-XML-Simple-2.14-4.fc6.noarch
        el archivo /usr/share/pear/DB.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/common.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/dbase.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/fbsql.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/ibase.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/ifx.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/msql.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/mssql.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/mysql.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/mysqli.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/oci8.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/odbc.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/pgsql.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/sqlite.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/storage.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/DB/sybase.php de la instalación de php-pear-db-1.7.14RC1-0.noarch entra en conflicto con el archivo del paquete php-pear-DB-1.7.13-1.el5.centos.noarch
        el archivo /usr/share/pear/XML/RPC.php de la instalación de php-pear-xml_rpc-1.5.3-0.noarch entra en conflicto con el archivo del paquete php-pear-1.4.9-6.el5.noarch
        el archivo /usr/share/pear/XML/RPC/Dump.php de la instalación de php-pear-xml_rpc-1.5.3-0.noarch entra en conflicto con el archivo del paquete php-pear-1.4.9-6.el5.noarch
        el archivo /usr/share/pear/XML/RPC/Server.php de la instalación de php-pear-xml_rpc-1.5.3-0.noarch entra en conflicto con el archivo del paquete php-pear-1.4.9-6.el5.noarch


Muchas gracias por tu ayuda.

Saludos,
 Reply
#6
Buenas,

El problema está en que la librería php-pear-db ya está instalada, pero por lo que he visto, esa librería es de Suse.

Busca el paquete:

Code:
rpm -qa | grep php-pear-db

Y desinstalalo con:

Code:
rpm -e nombrepaquete

Prueba a hacer la instalación de los paquetes de nuevo. Esperemos que no de más problemas.

Saludos.
 Reply
#7
Hola Luismi,

[[email protected] ~]# rpm -qa | grep php-pear-db
[[email protected] ~]# rpm -e  php-pear-db
error: el paquete php-pear-db no está instalado

Muchas gracias.

Saludos,
 Reply
#8
Hola baxajaun,

Podrías ponerme la salida de este comando:

Code:
rpm -qa | grep php

Gracias y un saludo.
 Reply
#9
Hola Luismi,

aquí la tienes:

[[email protected] ~]# rpm -qa | grep php
php-cli-5.1.6-27.el5_5.3
php-ldap-5.1.6-27.el5_5.3
php-mbstring-5.1.6-27.el5_5.3
php-devel-5.1.6-27.el5_5.3
php-common-5.1.6-27.el5_5.3
php-5.1.6-27.el5_5.3
php-pdo-5.1.6-27.el5_5.3
php-mysql-5.1.6-27.el5_5.3
php-gd-5.1.6-27.el5_5.3
php-pear-1.4.9-6.el5
php-snmp-5.1.6-27.el5_5.3
php-pear-DB-1.7.13-1.el5.centos

Muchas gracias.

Saludos,
 Reply
#10
Ok baxajaun, ahí tenemos el paquete que está dando el problema en la instalación php-pear-DB-1.7.13-1.el5.centos. También me he dado cuenta que está dando error el paquete perl-XML-Simple-2.14-4.fc6.noarch.

Prueba ejecutando así:

Code:
rpm -e php-pear-DB-1.7.13-1.el5.centos
rpm -e perl-XML-Simple-2.14-4.fc6.noarch

Y vuelve a intentar instalar las dependencias:

Code:
rpm -i --nodeps *.rpm

Esperemos que no siga dando más errores y se instale sin problemas. Saludos.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes