Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
None of the network modules initialize
#1
I recently installed Pandora FMS and for the most part it is working quite nicely. The master server is on Ubuntu 10.04.1 and the agents are on Windows XP and Red Hat Enterprise Linux 5.5.

I have also agent running in the monitoring machine to check if the other agents are alive via ICMP echoing. I set these alive checks via web console already a while back, but they are still in 'Not init' state. Same thing with one other Red Hat's network module, it's not initializing at all.

To my knowledge, the master server is running network server as it is shown with green status in the tactical view - however with 0% load.

What could I try to get the pings & latency checks working?

Thank you in advance!

-Pasi
 Reply
#2
Hi tiainpa,

Have you tried to reset pandora server? If it not works, then you should try doing it from the server, in the terminal to be sure that the monitorized machine is really accesible from pandora server.

Be sure too that the machines that doesn't report, has its firewall disable.

Cheers.
 Reply
#3
Pandora server reset was one of the first things I tried, but it doesn't help.

I logged in to the machines which should do the ping testing with network modules in Pandora, and they can send and receive ping packets just fine against the tested machines.

I cannot disable any firewalls because of the company policy, but I don't see it would make any difference.

BTW, this is the only error I see in the pandora_server.error:
Use of uninitialized value in string ne at /usr/lib/perl5/PandoraFMS/Core.pm line 793.
 Reply
#4
Hi tiainpa,

It seems to be an error in the Core.pm file. I'm going to find the what is the problem and I'll notice you.

Regards.
 Reply
#5
Hello,

Can you try replacing your Core.pm by this one? Before that, search where is this file and then make a backup of your current Core.pm, rename it for example:

Code:
# find / -name Core.pm
# mv Core.pm Core.pm.bk

Put the file attached in the same path before and test it.

Cheers.

 Reply
#6
Thanks, but the file attached seems to be empty?

-Pasi
 Reply
#7
Sorry tiainpa,

I attached the file again.

Regards.


Attached Files


.pm   Core.pm (Size: 84.6 KB / Downloads: 79)
 Reply
#8
Hi Luis,

Thanks, now there was something in the file Smile

However, now the Pandora server doesn't start at all, here's the info it prints out:
Subroutine pandora_ping redefined at /usr/lib/perl5/PandoraFMS/Core.pm line 1355.
Subroutine pandora_ping_latency redefined at /usr/lib/perl5/PandoraFMS/Core.pm line 1371.
Not enough arguments for PandoraFMS::Core::pandora_create_agent at /usr/lib/perl5/PandoraFMS/ReconServer.pm line 225, near "$dbh)"
Not enough arguments for PandoraFMS::Core::pandora_create_agent at /usr/lib/perl5/PandoraFMS/ReconServer.pm line 234, near "$dbh)"
Compilation failed in require at /usr/bin/pandora_server line 35.
BEGIN failed--compilation aborted at /usr/bin/pandora_server line 35.
Cannot start Pandora FMS Server. Aborted.
Check Pandora FMS log files at '/var/log/pandora/pandora_server.error & pandora_server.log'


There's nothing in the server.log and server.error files.

-Pasi
 Reply
#9
Ok tiainpa,

Then, restore your backup Core.pm and attached it here to test it, please.

Thanks.
 Reply
#10
Here you go, my original Core.pm file attached.


Attached Files


.pm   Core.pm (Size: 90.44 KB / Downloads: 74)
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnol├│gicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes