Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with text in images built with GD
#11
Perfect guys, I'm gonna upload this to the FAQ :-)
Well done
 Reply
#12
Quote:It was a font_path problem.
I have studied the fgraph.php code concerning the odo_tactic graph building type.
This function loads the font from the path specified in the variable $config_fontpath wrongly specified in the config.php file. I have corrected it specifing the correct path (the absolute path is /var/www/html/pandora_console/include) and now it works!

I hope to have helped you too!

Robb.

The variable in the config.php is

[code:1]$config_fontpath = $config_homedir."/reporting/FreeSans.ttf";[/code]

Where

[code:1]$config_homedir[/code] is set in the installation process.

The pandora_console file has the FreeSans.ttf in both places:

[code:1]/pandora_console/reporting/FreeSans.ttf
/pandora_console/include/FreeSans.ttf[/code]

So, I don't know why you have this problem and you have solved it by changing the path to another place where it's the same file!

Raúl
 Reply
#13
Oh! Yes, you are in right! I have seen that the font is in both the two directories.
Sorry, I have to correct myself.
The problem was in the construction of the $config_fontpath, but recursively, I found the mistake in the $config_homedir. During the setup process I left if as default (/var/www/pandora_console/) while it should be /var/www/html/pandora_console.

Well, surely it is not a software bug, but probably other persons could find this error. So that, it could be useful to check it before gonig mad with probably uninstalled dependencies as happened to me.
 Reply
#14
Great. This fixed it for me too.

Thx!
 Reply
#15
Quote:Oh! Yes, you are in right! I have seen that the font is in both the two directories.
Sorry, I have to correct myself.
The problem was in the construction of the $config_fontpath, but recursively, I found the mistake in the $config_homedir. During the setup process I left if as default (/var/www/pandora_console/) while it should be /var/www/html/pandora_console.

Well, surely it is not a software bug, but probably other persons could find this error. So that, it could be useful to check it before gonig mad with probably uninstalled dependencies as happened to me.

:-D Sure, a lot of people doesn't read the instructions :-D.
I quote the text included in the install.php file:
[code:1]
Full path to HTTP publication directory
For example /var/www/pandora_console/. Needed for graphs and attachments.[/code]

Raúl
 Reply
#16
Yes, you are in right. By the way, it seemed to have auto-detected the path. I did not see the missing '/html/' in the middle. Big Grin
Btw, I am glad to have helped someone!
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes