Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Last Contract time
#1
Pandora FMS
View Agents -> Tactical View
Here is a screen shot:
http://www.cerant.com/Pandora.jpeg

My remote Agent sends alert that PrintSpooler has stopped but I get no sound alert and it shows a 2 hour timestamp.

I set up an Alert Action called "Bell" to sound an alarm but it does not work.

I am in USA - timezone is EST.

I tried to set the Time Zone on the Pandora Linux appliance to EST but then the console shows negative time stamps.  I then reinstalled the Pandora FMS Linux appliance and started all over again.  Still cannot get the Alerts to really work -- all I can get it that they will show on the console screen.  Cannot get the Alert to sound, cannot get the Alert to send email.

So, how do you:
1- Make the Alerts work
2- set the Time Zone properly for Pandora?

Carl
 Reply
#2
Ahhh but that was the problem.

No sound alert will work if the alert fired or the module entered in warning or critical status hours ago.

Check the section Administration->Setup:

Quote:
Time source

What source to use for the time. This can be (for now) either the local system (System) or database (Database).

This is useful when your database is not on the same system as your webserver or your Pandora FMS servers. In that case any time difference will miscalculate the time differences and timestamps. You should use NTP to sync all your pandora servers and your MySQL server. By using these preferences you don't have to sync your webserver but it's still recommended.

Feel free to implement more sources (eg: ntp, ldap, $_SERVER...).

Note: The database query will be cached the first time it's called so the time will always be the same on a page load throughout, while System time is returned whenever the function is called, which might differ slightly (especially near the ending of a second).

In resume, make sure your system/DB/browser are synchronized.

That means using a ntp server or placing all of them in the same time zone and hour.

Check how to do it here:

Changing Linux Timezone

Regards.
 Reply
#3
I attempted to change the Pandora FMS Linux appliance time zone to EST5EDT - I'm on the East Coast in the USA.  When I did that, I got a lot of negative times posted on the console website.

I'll go and re look at the Time Zone again.

Carl
 Reply
#4

OK, I got the timezone adjusted for EST.

But still cannot get the Alerts to fire off when a critical condition occurs.

Any insights on how to enable Alerts would be helpful.

Thanks

Carl
 Reply
#5
Still cannot get the Alarm to sound.

Below shows the alarm condition being reported to Pandora:
[Image: Pandora1.jpeg]

Below shows that I have setup the Bell sound:
[Image: Pandora2.jpeg]


What am I doing wrong????

Thanks

Carl
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes