Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Actualización 3.2 a 4.0
#1
He visto que ya está disponible la actualización de pandora a la 4.0 y me gustaria saber si es recomendable realizar la instalación o si seria mejor esperarse un poco a resolver los problemillas que estoy viendo que están saliendo de los demás usuarios de pandora.

En caso de que ya se pudiera actualizar sin problemas me gustaria que me dijeran como hacerlo paso por paso para no cometer ningún error y así evitar problemas ya que va a ser la primera vez que vaya a actualizar pandora.

Estoy utilizando en la máquina donde tengo pandora_server la version 3.2 de pandora (la misma que para la consola y los agentes)  en una distribución de red hat linux 5.

Un Saludo.
 Reply
#2
Hola:

En la documentacion viene explicado como hacerlo, tanto para redhat, que es tu distribucion, como para otras distribuciones.

http://www.openideas.info/wiki/index.php...umentation

Saludos.
 Reply
#3
Gracias por el documento, no me había dado cuenta de que estaba.

Otro tema sería si es posible actualizarlo directamente o tengo que pasar primero por la versión 3.2.1 antes de pasar a la 4.0.

Y en caso de que sea necerario pasar por la 3.2.1, Después ¿Tengo que actualizar a la versión 4.0RC1 y después a la 4.0RC2 ó directamente a la 4.0RC2?. Eso en la documentación no viene y me gustaría estar seguro de que estoy haciendo bien las cosas.

Un Saludo.
 Reply
#4
Yo te recomendaria primero pasar a la 3.2.1.
Despues directamente a 4.0,s in pasar por RC1 ni RC2.

RC significa "release candidate", vamos que no es una version estable, y que es candidata a ello.

De todas formas, espera unos dias hasta que la veamos que se solucionan los problemillas que estan surgiendo con esta version. Yo he tenido que echar para atras por unos problemillas, pero lo poco que he visto tenia muy buena pinta.


 Reply
#5
Tengo un problema a la hora de actualizar a la version 3.2.1 y es que me faltan muchas dependencias que no las encuentro por ningún lado. Esto es lo que me sale cuando intento instalarlo

Code:
[[email protected] Pandora_3.2.1]# rpm -i pandorafms_*rpm
error: Error de dependencias:
        rpmlib(PayloadIsLzma) <= 4.4.6-1 se necesita para pandorafms_agent_unix-3.2.1-1.noarch
        apache2 se necesita para pandorafms_console-3.2.1-1.noarch
        apache2-mod_php5 se necesita para pandorafms_console-3.2.1-1.noarch
        php >= 4.3.0 se necesita para pandorafms_console-3.2.1-1.noarch
        php5-gd se necesita para pandorafms_console-3.2.1-1.noarch
        php5-snmp se necesita para pandorafms_console-3.2.1-1.noarch
        php5-json se necesita para pandorafms_console-3.2.1-1.noarch
        php5-gettext se necesita para pandorafms_console-3.2.1-1.noarch
        php5-mysql se necesita para pandorafms_console-3.2.1-1.noarch
        php5-ldap se necesita para pandorafms_console-3.2.1-1.noarch
        php5-mbstring se necesita para pandorafms_console-3.2.1-1.noarch
        php5 se necesita para pandorafms_console-3.2.1-1.noarch
        xorg-x11-fonts-core se necesita para pandorafms_console-3.2.1-1.noarch
        graphviz-gd se necesita para pandorafms_console-3.2.1-1.noarch
        php5-zip se necesita para pandorafms_console-3.2.1-1.noarch
        rpmlib(PayloadIsLzma) <= 4.4.6-1 se necesita para pandorafms_console-3.2.1-1.noarch
        perl-HTML-Tree se necesita para pandorafms_server-3.2.1-1.noarch
        rpmlib(PayloadIsLzma) <= 4.4.6-1 se necesita para pandorafms_server-3.2.1-1.noarch
[[email protected] Pandora_3.2.1]#

Parece que cuando intento buscar la mayoria de ellos que son los de php5, no encuentro nada, solo la pagina oficial de red hat encuentro unos paquetes que son php53... pero he probado con esos y aún asi sigue saliéndome el error de dependencias. ¿Alguien que utilice red hat ha tenido el mismo problema con las dependencias? ¿Sabeis donde puedo encontrarlos exactamente?.

Un Saludo.
 Reply
#6
A ver a ver vayamos por partes:

Los .rpm de instalación no son los mismos para SUSE que para Red Hat / Fedora / CentOS.

Llegados a este punto, siempre puedes forzar la instalación del paquete y resolver las dependencias después.

Para las dependencias de Red Hat / Fedora / CentOS, revisa esta parte de la documentación:

Instalación en Red Hat Enterprise Linux / CentOS / Fedora

Para actualizar de 3.2.1 a 4.0 esto otro:

Actualización desde 3.x a 4

Actualizar consola web desde la versión 3.2.1 a la 4.0

Para actualizar la base de datos de 3.2 a 4.0 esto otro:

Actualización de la base de datos (Versiones mayores)

Actualizar el esquema de la base de datos a una versión mayor

Saludos.
 Reply
#7
Estoy intentando instalar la versión 4.0 pero cuando lo intento me salen unos problemas que son exactamente de dependencias y me guastaría que me ayudaras a resolverlo porque en la documentación que me das no viene nada del problema que tengo. Es el siguiente

Code:
[[email protected]hor Pandora_4.0]# rpm -i --force pandorafms_*rpm
error: Error de dependencias:
        /usr/bin/sed se necesita para pandorafms_agent_unix-4.0-1.noarch
        /usr/bin/grep se necesita para pandorafms_agent_unix-4.0-1.noarch
        rpmlib(FileDigests) <= 4.6.0-1 se necesita para pandorafms_agent_unix-4.0-1.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 se necesita para pandorafms_agent_unix-4.0-1.noarch
        rpmlib(FileDigests) <= 4.6.0-1 se necesita para pandorafms_console-4.0-1.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 se necesita para pandorafms_console-4.0-1.noarch
        perl-SNMP se necesita para pandorafms_server-4.0-1.noarch
        rpmlib(FileDigests) <= 4.6.0-1 se necesita para pandorafms_server-4.0-1.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 se necesita para pandorafms_server-4.0-1.noarch
[[email protected] Pandora_4.0]# rpm -i --nodeps pandorafms_server-4.0-1.noarch.rpm
useradd: el usuario pandora existe

Alguna idea de como solucinarlo??

Un Saludo
 Reply
#8
No puedo resolver los errores que me salen del post anterior y quiero poder actualizar pandora a la version 4.0. Alguna idea de como avanzar?? Empezar desde 0 o alguna manera de evitar los errores que me salen??

Estoy atascado en este tema y ya no se que hacer para solucionarlo!

Cualquier pista que me podais dar para resolverlo lo agradecería mucho.

P.D. Tiene algo que ver con que no este registrado en RHN o que tenga que pagar alguna cosa de red hat para resolver los problemas de lo que parece que son librerias?

Un Saludo
 Reply
#9
Las herramientas sed y grep deberías tenerlas en tu máquina... trata de obtenerlas o si ya las tienes comprueba en qué ruta se encuentran.

Con perl-SNMP parece que hay un problema encontrándolo en ningún repositorio, así que puedes probar a instalarlo vía CPAN con "cpan install SNMP" e ignorar la comprobación de esa dependencia o bien buscarlo en internet, descargarlo e instalarlo manualmente.

Los errores de rpmlib me parecen bastante extraños... básicamente porque nunca se había dado ese fallo que yo recuerde... si no puedes resolver esa dependencia por ningún lado te aconsejo lo mismo, que busques por internet como obtenerlo e instálalo manualmente.

De todos modos esos paquetes están hechos para RHEL 6, no para RHEL 5 que por no tener no tiene ni el php 5.2, así que te aconsejo que instales mediante tarball directamente.

Saludos.
 Reply
#10
Parece ser que estás de suerte hoy. Wink

Hace apenas 2 horas se han publicado los paquetes .rpm de Pandora para CentOS5 y equivalentes. Puedes encontrarlos siguiendo este link:
Paquetes RPM CentOS / RHEL / Fedora

Si te siguiera fallando, te recomiendo hacer lo que te he dicho anteriormente.

Saludos.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes