Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pandorafms 4.0 y CentOS 6
#1
Buenos días,

soy incapaz de resolver la dependencia siguiente:

[[email protected] ~]# rpm -i pandorafms_server-4.0-1.noarch.rpm
error: Error de dependencias:
        perl-SNMP se necesita para pandorafms_server-4.0-1.noarch

Alguna idea ?

Muchas gracias.

Saludos,

Felix
 Reply
#2
Si no te aparece en ningun repositorio ni de los tuyos ni de los que se especifican en la documentación, puedes probar a instalarlo con un CPAN install SNMP y/o forzar la instalación del rpm.

Saludos.
 Reply
#3
Buenos días,

no hay manera de instalar esa dependencia en CentOS 6, por lo menos en nuestra instalación.

Alguna otra sugerencia ?

Muchas gracias.

Saludos,

Felix
 Reply
#4
Buenos días,

sigo sin poder instalar la dependecia perl-SNMP:

[[email protected] ~]# rpm -i pandorafms_server-4.0-1.noarch.rpm
error: Error de dependencias:
        perl-SNMP se necesita para pandorafms_server-4.0-1.noarch
[[email protected] ~]# yum install perl-SNMP
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.opendoc.net
* extras: mirror.opendoc.net
* updates: centos.bio.lmu.de
Setting up Install Process
No package perl-SNMP available.
Error: Nothing to do
[[email protected] ~]# yum search perl-SNMP
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.opendoc.net
* extras: mirror.opendoc.net
* updates: centos.bio.lmu.de
============================== Matched: perl-SNMP ==============================
perl-SNMP_Session.noarch : SNMP support for Perl 5

[[email protected] ~]# yum install perl-SNMP_Session.noarch
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.opendoc.net
* extras: mirror.opendoc.net
* updates: centos.bio.lmu.de
Setting up Install Process
Package perl-SNMP_Session-1.12-4.el6.noarch already installed and latest version
Nothing to do

Alguna idea ?

Muchas gracias.

Saludos,

Félix


 Reply
#5
Buenas,

jejeje, por fín he conseguido instalar Pandorafms 4.

Uno que es un poco cenutrio, vamos que lo tenía instalado:

[[email protected] ~]# yum install net-snmp-perl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.opendoc.net
* extras: mirror.opendoc.net
* updates: centos.bio.lmu.de
Setting up Install Process
Package 1:net-snmp-perl-5.5-27.el6_0.1.x86_64 already installed and latest versi                                                                            on
Nothing to do

Después he forzado la instalación del servidor:

[[email protected] ~]# rpm -i --nodeps pandorafms_server-4.0-1.noarch.rpm
Pandora FMS Server configuration is /etc/pandora/pandora_server.conf
Pandora FMS Server main directory is /usr/share/pandora_server/
The manual can be reached at: man pandora or man pandora_server
Pandora FMS Documentation is in: http://pandorafms.org

Don't forget to start Tentacle Server daemon if you want to receive
data using tentacle

Muchas gracias.

Saludos,

Félix
 Reply
#6
No te preocupes. Wink

Ha sido añadido al FAQ hace poco además este problema... para la siguiente actualización la referencia a esta dependencia habrá sido corregida para CentOS, RHEL y Fedora.

No se encuentra la dependencia perl-SNMP en RHEL /CentOS / Fedora.

Saludos.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes