Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con Agentes en 1.3
#31
Me ha llegado el correo. Acabo de mirar tu authorized_keys y pasa al menos un par de cosas: Como me ha llegado en el cuerpo no veo si el final del fichero es el correcto, pero no debes separar con retorno de carro las dos claves y deben estar en una misma línea, es decir, debemos tener:
[code:1][inicio fichero authorized_keys]
ssh-dss AAAAB.... [email protected]
ssh-dss AAAAB.... dsa-key-20071121
[fin fichero authorized_keys][/code]

En resumen:
- Cada clave en SOLO una línea
- Cada línea una clave (no dejes dos retornos de carro seguidos)
- No debe haber un retorno de carro al final del fichero.

Raúl
 Reply
#32
Quote:Me ha llegado el correo. Acabo de mirar tu authorized_keys y pasa al menos un par de cosas: Como me ha llegado en el cuerpo no veo si el final del fichero es el correcto, pero no debes separar con retorno de carro las dos claves y deben estar en una misma línea, es decir, debemos tener:
[code:1][inicio fichero authorized_keys]
ssh-dss AAAAB.... [email protected]
ssh-dss AAAAB.... dsa-key-20071121
[fin fichero authorized_keys][/code]

En resumen:
- Cada clave en SOLO una línea
- Cada línea una clave (no dejes dos retornos de carro seguidos)
- No debe haber un retorno de carro al final del fichero.

Raúl

Esa parte ya la tengo solucionada, ahora lo único que no me conecta, aunque hace el test de conexión con éxito es la conexión del agente del propio servidor, en linux
 Reply
#33
Ves algún error con la orden que te dije que probases? Debe estar al final del todo seguramente.
 Reply
#34
He estado revisando y aparece esto:

++ grep '^module_interval'
+ '[' '!' -z '' ']'
+ '[' 1 -eq 1 ']'
+ '[' 0 -eq 0 ']'
+ cat /var/spool/pandora/data_out/localhost.localdomain.1196066268.data_temp
+ rm -Rf /var/spool/pandora/data_out/localhost.localdomain.1196066268.data_temp
++ expr 0 + 1
+ CONTADOR=1
+ '[' 1 -eq 100 ']'
+ '[' -f /usr/share/pandora_agent//pandora_user.conf ']'
+ /bin/bash /usr/share/pandora_agent//pandora_user.conf
+ '[' 0 == 1 ']'
+ CHECKSUM_DATA='No valid checksum'
+ echo 'No valid checksum'
+ echo '</agent_data>'

Mi duda es la línea que aparece lo de /usr/share/pandora_agent//pandora_user.conf por lo de las dos barras (//)... es lo único extraño que veo
 Reply
#35
Lo de las barras es normal.

No hay nada más después de eso que has pegado? Tienes algo en el pandora_user.conf?
 Reply
#36
Parece que ya está solucionado. El problema, era que al arrancar los agentes los hacía de la siguiente forma '/opt/pandora_agent/pandora_agent_daemon start', cuando lo que debía hacer era 'service pandora_agent_daemon start'... Después de lanzarlo así, parece que funciona.

Gracias por todo y un saludo


VICTOR
 Reply
#37
Me alegro entonces, enhorabuena.
Pero...¿usaste el instalador para instalar el agente? Porque /opt es el path de la versión 1.2
 Reply
#38
Sí, usé el instalador, pero por defecto los archivos los ubicaba en /opt para luego desde ahí hacer la instalación, tal y como lo veía en la 1.2, así que fallo mío... pero por lo menos he aprendido como va esto... todavía tengo más dudas que más adelante postearé, como el servidor Recon, las gráficas, el servidor snmp, etc

Lo dicho, muchas gracias a todos por la ayuda

Un saludo,


VICTOR
 Reply
#39
Ummm...eso es bastante raro, el instalador de los agentes deja los ficheros en /usr/share/pandora_agent y hace los links de /etc/pandora/pandora_agent.conf y pandora_user.conf

Me temo que no nos estamos entendiendo :-(
Pero al menos ya todo parece ir bien
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes