Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Módulo no inicializado
#1
Buenas,

he creado un módulo para ver si el servico de IBM Cognos 8 está cooriendo a través de WMI con la siguiente consulta:

SELECT State FROM Win32_Service WHERE Caption='IBM Cognos 8'

Con su IP de destino, Usuario y Contraseña. El tipo es Generic String.

Pero aparece sin inicializar y no sé como hacerlo.

Muchas gracias.

Saludos,

Félix
 Reply
#2
Yo esto lo hago, con el siguiente codigo en el pandora_agent.conf del agente que tengo instalado en un controlador de dominio. en este caso es el servicio DNS, cambialo por el de IBM cognos.

Comprobar ejecucion de DNS
module_begin
module_name DNS
module_type generic_proc
module_service DNS
module_description Comprobar Ejecucion DNS
module_end

Si está ejecutandose devuelve 1, sino 0.

Espero que te sirva.

Saludos.
 Reply
#3
Aitor,

simple y perfecto. Muchas gracias. En Windows 2003 Server funciona perfecto, en XP no me está funcionando. Alguna idea ?

Saludos,

Félix
 Reply
#4
Buenas tardes:

En principio no deberia haber problemas, ya que es un modulo del agente de pandora.
Puedes asegurarte de que allas escrito bien el nombre del servicio?

Lo digo porque es un fallo tonto, pero a la vez muy tipico. ;-)

 Reply
#5
Aitor,

jejejejeje, tienes más razón que un santo. Estaba poniendo el nombre para mostrar y no el nombre del servicio.

Muchísimas gracias.

Saludos,

Félix
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes