Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Proxy mode agent
#1
Hello all,

I'm trying to set up a (non-Enterprise) Pandora agent in proxy mode, but I'm having trouble getting it to listen for connections.  My setup is on a Debian Squeeze host with a Pandora 4.0 agent, installed from .deb. I've edited /etc/pandora/pandora_agent.conf where I've changed the following:
  • Set server_ip (to pandora_server host)
  • Set agent-name (something other than hostname, not an issue afaik)
  • uncommented proxy_mode 1

After starting the agent I get the following line in /var/log/pandora/pandora_agent.log:
  • [error] - Proxy mode can not be launched as root

I did some research and concluded that perhaps I needed to set the proxy_user variable, which I set to "pandora".  However, same result.  If I instead change the pandora_user variable to "pandora", the agent won't start at all. 

Alas, this is where my Google-Fu falters.  I am not sure as to what other settings I could look at.  Would anyone please be so kind as to either help me out directly or point me towards the appropriate documentation?

Regards...
 Reply
#2
Hi cwspry,

First of all, just to let you know, Pandora agent it is 100% open, there is no an enterprise version for the agent.

About proxy mode, the appropriate documentation is in here:
http://www.openideas.info/wiki/index.php?title=Pandora_3.0:Documentation_en:Configuration#Proxy_Mode


You will find in there information about the user who has to execute Pandora agent, it cannot be root.

I hope this will be helpful for you.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes