Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Fallo dependencias( actualizacion 4.0 a 4.0-1111115)
#1
Tengo un problema de dependencias que me sale cuando intento actualizar a la nueva versión

Code:
[[email protected] versiones]# rpm -U pandorafms_server-4.0-111115.noarch.rpm
error: Error de dependencias:
       fillup se necesita para pandorafms_server-4.0-111115.noarch
       insserv se necesita para pandorafms_server-4.0-111115.noarch
       /usr/bin/sed se necesita para pandorafms_server-4.0-111115.noarch
       /usr/bin/grep se necesita para pandorafms_server-4.0-111115.noarch
       snmp-mibs se necesita para pandorafms_server-4.0-111115.noarch
       rpmlib(PayloadIsLzma) <= 4.4.6-1 se necesita para pandorafms_server-4.0-111115.noarch
[[email protected] versiones]#

/usr/bin/sed y /usr/bin/grep no se porque me sale porque si que esos ficheros. snmp-mibs no tengo ni idea de donde ha salido pero tampoco lo encuentro por ningún sitio y rpmlib(PayloadIsLzma) no se ni lo que es. Smile

Alguna sugerencia de como arreglarlo???

Un Saludo
 Reply
#2
Hola jartal,

Yo he actualizado también desde la 4.0 y no he tenido ningún error.
Si estás utilizando Suse utiliza zypper search <nombrepaquete> para averiguar si tienes instalados los paquetes 'fillup', 'insserv'm 'snmp-mibs'. Yo sí tengo instalados ambos.

Busca de nuevo en zypper por 'lzma' y busca un paquete llamado 'liblzma5', a ver si instalando ese te funciona.

Es un error extraño, si no lo consigues, prueba si quieres a descargarte el último paquete nightly.

Ya nos vas contando.

Un saludo
 Reply
#3
Hola.

Utilizo RHEL5 y he intentado instalar lo que me falta con yum pero sin ningún resultado, creo recordar que me salio algo parecido cuando tuve que actualizar de la version 3.2 a la 4.0, qeu al final tuve que borrar todo pandora y instalarlo de nuevas a la 4.0, en principio no tuve ningún problema porque estamos en pruebas y aun no tenemos nada serio ni operativo, pero me gustaría poder solucionarlo si volverlo a instalar de nuevas porque si no no podré actualizar hasta que no salga la versión definitiva en la cual no halla ningún bug ni nada, Smile. ¿Alguna idea de que es lo que puede pasar?

También me gustaría saber, si es posible el porque de esos errores, si son críticos o si hay alguna forma de evitarlos, o si no que me puedan hacer referencia a algun sitio donde se explique la solución del error.

Un Saludo
 Reply
#4
Hola jartal,

Los paquetes nightly .rpm son para Suse, no tenemos paquetes nightly para Red Hat.
Es por eso por lo que te está fallando la actualización, y supongo que sería por este mismo motivo por el que te falló en su momento cuando actualizaste de la 3.2 a la 4.0.
Es probable que más adelante se generen también los paquetes nightly para Red Hat, pero por el momento no los tenemos.

Te sugeriría que actualices desde los tarball, es realmente sencillo.
https://sourceforge.net/projects/pandora/files/Nightly/Tarball/


El orden recomendado para hacer la instalación/actualización es: Agente, Consola y Server.

Para el agente utiliza ./pandora_agent_installer --install

Para la consola utiliza ./pandora_console_upgrade -p <console_path>

Para el server utiliza ./poandora_server_upgrade --upgrade

Ya nos cuentas cómo te ha ido.

Un saludo
 Reply
#5
Gracias!!

Parece que ya he conseguido actualizarlo a la 4.0-111124 (que cada día hay mas!!Smile)

Un Saludo
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes