Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agentes se quedan en estado "Agent Down"
#1
Buenas a todos.
Ya llevo un tiempo peleandome con Pandora y aun no he conseguido que me funcione bien. He creado un agente que esta en la misma máquina que el server y aparece el monitor en estado DOWN.

Alguien me puede decir como se inicia un MONITOR ? haga lo que haga siempre me aparece el monitor en estado DOWN pero lo mas curiosos es que a veces si que llegan datos pero el monitor sigue en ese estado.

Otra cosa que me sucede es que el servidor de datos Data_Server, parece que se parece cada 20 minutos ...

Si alguien me puede echar un cable lo agradecere muchisimo ...
GRacias.
 Reply
#2
Buenas,

antes de nada, ¿puedes indicar más detalles como de qué versión hablamos, en qué distribución, si hay algún detalle en los logs, si has puesto en modo debug los agentes y similar?

Gracias, espero que podamos echarte una mano Wink

Raul
 Reply
#3
ok, sorry, que no indique nada.
La version de Pandora es 1.3 Build PC071012 y los servidores estan corriendo en una Kubuntu 7.10. Un agente esta en la misma maquina que los servidores y otro en ua Red Hat.

La cosa es que haga lo que haga los agentes siempre me devuelven el mismo estado y solo recibo datos de un modulo aunque tengan asignados unos cuantos.

El tema de ssh y snmp funciona ok, ya que he realizado pruebas y las maquinas responden y los permisos tb estan ok.

Mirando los logs no encuentro nada intesesante. Reporto los resultados de agente_log de ayer:

2008/03/27 10:40:14 - [SETUP] - Server IP Address is 127.0.0.1
2008/03/27 10:40:14 - [SETUP] - Server Path is /opt/pandora/pandora_server/data_in
2008/03/27 10:40:14 - [SETUP] - Temporal Path is /var/spool/pandora/data_out
2008/03/27 10:40:14 - [SETUP] - Pandora Logfile is /var/log/pandora/pandora_agent.log
2008/03/27 10:40:14 - [SETUP] - Interval is 30 seconds
2008/03/27 10:40:14 - [SETUP] - Debug mode is 0
2008/03/27 10:40:14 - [SETUP] - Agent name is avalon_agent
2008/03/27 10:40:14 - [SETUP] - Server Port is 22
2008/03/27 10:40:14 - [SETUP] - Transfer Mode is local
2008/03/27 10:40:14 - [SETUP] - DELAYED_STARTUP is 0

Haga lo que haga los agentes siempre mantienen ese estado, aunque envien datos al servidor y en modo debug el resultado es el mismo.

Otra cosa que me pasa es que soy incapaz de iniciar los monitores. No se si hay que hacer algo en especial o que pero desde que me instale pandora y los agentes que no he podido iniciar ningun monitor. Siempre aparecen como si fallara.

ale,
 Reply
#4
De dónde has bajado la versión? Es la versión del trunk? del branches? de la web de sourceforge? del repositorio de tarballs?
 Reply
#5
Cuando dices que en modo debug el resultado es el mismo, ¿podrías detallar algo más? Se supone que en modo debug el agente te crea los ficheros en tu directorio temporal, no los envía al servidor.

En ese caso puedes consultar el contenido de los datos (es un xml), para ver si está enviando los datos correctamente.

Hace tiempo definimos .dtd y .xsl para poder ver los datos en un navegador cuando estuvieses en modo debug (consulta http://www.openideas.info/wiki/index.php...n_Problems en inglés...)

Vamos a empezar por aquí, a ver que sale...

Un saludo,

Raúl
 Reply
#6
Ok, Pandora la descargue del sourceforge.

Los paquetes de datos me llegan al directorio data_in del servidor de datos pero no parece que la consola los lea pq el estado de los agentes no cambia ni se actualiza los datos que llegan.

Ademas me he encontrado con el problema que si activo el checksum en el fichero de configuracion del pandora_server.conf, pandora_server arranca sin problemas pero los paquetes de datos no me llegan y si no lo activo entonces puedo ver los paquetes que me llegan sin problemas pero entonces el servidor de datos no arranca.

Lo que veo es que no es problema de conectividad con los agentes ya que la informacion me llega bien y el log no me devuelve errores pero no veo como arrancar el servidor de datos sin que tenga que activar el checksum.

De todas maneras gracias por la ayuda ... Lo seguire intentando. :P
 Reply
#7
Al llegar los paquetes, ¿se borran o se quedan en el directorio de entrada?
Puede que la ruta de entrada de datos en el servidor no esté bien configurada, revísala para ver que es correcta.
Verifica igualmente que todos los procesos de Pandora Server están activos (ps -ef |grep pandora), deberías tener al menos pandora_server y pandora_network.

Revisa igualmente que has creado el agente en la consola con el mismo nombre que tiene en la máquina a monitorizar.

Espero que te sirva,

Un saludo,

Raúl
 Reply
#8
Buenas de nuevo y gracias por la ayuda.

Paso a comentarte.
Los paquetes del agente llegan al directorio data_in correctamente.

En modo Ckecksum se borran al cabo de unos momentos y cuando NO es modo Ckecksum los paquetes se quedan en el directorio.

En cualquier caso no parece que lea los ficheros de datos ya que no se actualizan los datos del agente.

Ademas he podido comprobar que con CHECKSUM activado SIEMPRE me da el mismo mensaje de error:

[ERROR] MD5 Checksum failed! for /var/spool/pandora/data_in/gimli_agent.1209542693.data
Hace falta alguna libreria o algun paquete adicional a los que se hace referencia en el manual de instalacion ?? es suficiente con el modulo de perl Digest::MD5 ???

He verificado como me indicas que todos los procesos de pandora esten corriendo y que el agente en la consola tenga el mismo nombre que en la maquina que monitoriza. Esto esta Ok.
 Reply
#9
Desactiva el modo checksum (http://www.openideas.info/phpbb/viewtopi...77fd4aa503)

Si se quedan los paquetes es que el servidor no los está procesando, ya que debe borrarlos una vez procesados. Aparte del checksum, ¿hay algo en el log del servidor?

Raúl
 Reply
#10
¿Puedes poner la salida del comando ps aux |grep pandora?
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes