Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problema actualizar plantillas (Mensaje "no se pudo actualizar" en rojo)
#1
Buenas tardes.

Tengo el presente problema con Pandora FMS v4.0 - Revisión PC110923

Cuando intento modificar cualquier plantilla ya existente (solo modificar, pues crear una nueva sí puedo) me aparece siempre el mensaje de error siguiente (escrito en rojo también).
NO SE PUDO ACTUALIZAR
Este problema me ocurre con cualquier plantilla y no solo con una en concreto, no importando ni el paso (paso 1, paso 2 o paso 3) ni el valor que se intente modificar.
Cualquier otra área de la gestión de alertas que quiera modificar no me da ningún error (acciones, comandos y correlación funcionan correctamente).
Sin embargo, lo que sí he podido hacer es modificar el campo en concreto que quería cambiar de la plantilla pero atacando a la BBDD de mysql, haciéndolo con el usuario root. Posteriormente cuando compruebo la plantilla el valor ya aparece modificado.
El problema está en que quisiera poder modificar las plantillas que ya tengo desde la consola web de Pandora sin tener que tocar por detrás en la BBDD de mysql.
Este problema no me ocurría con versiones anteriores de Pandora.
De hecho, la versión actual en mi servidor de Pandora procede de migraciones de versiones anteriores. Desconozco si esta circunstancia tendría algo que ver.
Agradecería ayuda al respecto.
Un saludo,

Juan Alberto Morales Pineda.
 Reply
#2
Hola Juan Alberto.

No se exactamente porque puede pasar pero por lo que dices tienes una versión antigua respecto a la que están actualmente.

Es muy posible que ese error ya halla sido solucionado en versiones posteriores.

Seguramente los desarrolladores te dirán que actualices a la ultima versión posible ya que seguramente ya se halla resuelto el error (lo digo porque me suena de haber leído por el foro un error de ese tipo).

Yo tengo la versión Pandora FMS v4.0.1 - Revisión PC120205 (que es la de la semana pasada) y a mi eso no me pasa (comprobado).

Te recomiendo que actualices a la ultima versión:

https://sourceforge.net/projects/pandora...y_Updates/

Un Saludo.

 Reply
#3
Hola,

Yo tengo la última versión (4.0.1 - Revisión PC111220) y también me pasa.
¡No puedo cambiar ningún módulo!

Y me pasa desde la versión 4.0.


¿Alguien sabe algo sobre esto?
 Reply
#4
Aquí tenéis la solución:
http://openideas.info/smf/index.php/topic,4567.0.html
 Reply
#5
Muchas gracias por la información facilitada.
Voy a leer el contenido de la URL que me envías y ver si encuentro la solución así al problema.
Disculpad si no os he contestado antes pero una operación quirúrgica me ha impedido atender vuestra solución antes.
Os informaré al respecto.

Juan Alberto.
 Reply
#6
Buenos días.

He revisado la solución indicada en el enlace "http://openideas.info/smf/index.php/topic,4567.0.html" que me habéis facilitado y veo que hace referencia a los módulos. He buscado, según se indica los campos "str_warning" y "str_critical" para ver si existen en la tabla "talert_templates" y no aparecen (mi problema estaba en la actualización de las plantillas).

Podría alguien, que no tenga problemas a la hora de actualizar las plantillas, describir cuál es la estructura de campos de la tabla "talert_templates" para poder comprobarla con la mía. Lo comento porque es posible que falte algún campo similar a str_warning y str_critical y que sea ésta la razón por la que no se puede realizar la actualización por la consola web de Pandora.

Un saludo,

Juan Alberto.
 Reply
#7
Hola buenas.

Parece que la comprobación que tienes que hacer es ver si están en la tabla "tnetwork_component" no en "talerts_templates" que pones ya que en la de las alertas no existen tales módulos, comprueba en la tabla "tnetwork_component" haber si tienes los campos.

Te lo comento porque a mi no me da ningún fallo a la hora de actualizar plantillas tal y como comento en el post al que haces referencia.

Te pongo un pantallazo para que veas los campos que tengo yo en la tabla "tnetwork_component"

Un Saludo.


Attached Files


.jpg   BD tnetwork-component.JPG (Size: 162.95 KB / Downloads: 81)
 Reply
#8
Buenas tardes.
Efectivamente en la tabla "tnetwork_component" no existían los campos str_warning ni str_critical.
Los he agregado mediante comandos de mysql y ahora ya dispongo de ellos en la tabla indicada.
Sin embargo, sigo teniendo el mismo problema en la consola web, pues sigo sin poder realizar ninguna actualización de las plantillas (incluso sin tocar nada, solamente entrar y pinchar en "siguiente" y ya me sale el error de que no es posible actualizar en rojo -ver imagen adjunta-).
Es cierto que no he reiniciado la BBDD, por lo que es posible que el error que tengo se solucione en cuanto que lo haga.
No obstante, me gustaría saber si realmente el error que me ocurre está relacionado con la tabla tnetwork_component que indicáis.
Muchas gracias.
Juan Alberto.


Attached Files


.jpg   ErrorNoSePudoActualizar.jpg (Size: 181.71 KB / Downloads: 107)
 Reply
#9
Hola de nuevo.
He comprobado que el problema que tengo a la hora de actualizar cualquier plantilla me ocurre solamente cuando realizo cualquier modificación en la primera pestaña, pero no en las otras dos. Me explico:
Si modifico algo en la pestaña "paso 1, condiciones" me aparece el error "No se pudo actualizar"
Si modifico algo en la pestaña "paso 2, disparado" o en la pestaña "paso 3, recuperación" no tengo ningún problema (mensaje: "actualizado correctamente" en verde).
Luego, analizando más en profundidad la situación, lo que he observado más en detalle es lo siguiente:
- Pestaña "paso 1, condiciones", al pinchar en el icono "siguiente" ocurre lo siguiente:
    * Si no he modificado nada en dicha pestaña me sale el mensaje de no se pudo actualizar en rojo.
    * Si he modificado el campo "descripción", "prioridad", "grupo" o "tipo de condición" vuelve a salir el mensaje de no se pudo actualizar en rojo.
    * Si he modificado el campo "nombre" puedo guardar sin problemas, aunque también modifique el resto de campos.
- Pestaña "paso 2, disparado": No importa el campo que modifique pues siempre se guardan los cambios.
- Pestaña "paso 3, recuperación": No importa el campo que modifique pues siempre se guardan los cambios.

Según este comportamiento, parece ser que para poder modificar algo de la primera pestaña (paso 1) en una plantilla ya existente tengo que modificar a la fuerza el campo "nombre", lo cual creo que es un comportamiento un poco anómalo, aunque por ahora me sirve como truco para resolver mi problemática.

¿A alguien le está ocurriendo algo parecido?

Muchas gracias.

Juan Alberto.
 Reply
#10
Hola juanalbertomp,

¿Actualizaste a la última versión de la 4.0.1 como indico jartal?

Puedes encontrar los paquetes aquí:

https://sourceforge.net/projects/pandora...y_Updates/

Yo estoy provando la última versión de desarrollo y funciona, y según comenta jartal el bug se solucionó en la versión  Pandora FMS v4.0.1 - Revisión PC120205

Es importante que actualices ya que sacamos versiones todas las semanas para solucionar estos pequeños bugs.

Ya nos contaras que tal.

Un saludo.

Darío.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes