Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SNMP V2 traps from 0.0.0.0
#1
Hola:

Estamos probando PandoraFMS ver 4.0.1

Instalamos la versión de Ubuntu y hemos probado también la imagen VMWARE (ambas bajo VirtualBox).

Nos gustaría poder monitorizar algunos switches y balanceadores, pero parece que los traps enviados a la consola SNMP no son interpretados correctamente.  En el log vemos lo siguiente

Quote:2012-03-18[**]03:26:06[**]0.0.0.0[**].[**]0[**]Cold Start[**]0[**].1.3.6.1.2.1.1.3.0 = Timeticks: (49019257) 5 days, 16:09:52.57 .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.5205.2.32.1.20.1 .1.3.6.1.4.1.5205.2.32.1.21.1 = STRING: "admin"

Nos sucede en ambas versiones y con equipos de fabricantes distintos.

Hemos leído el tópico : http://openideas.info/smf/index.php?topic=1411.0  , pero no hemos encontrado solución porque hace referencia a una versión anterior.

Gracias

 Reply
#2
Buenos dias;

¿Podrías hacer una captura de la información de algunos de los traps creados?

Un saludo.
 Reply
#3
Hola

Gracias Nacho.  Dime si quieres algún tipo especifico de log.

Te adjunto el log del demonio snmp (pandora_snmptrap.log):

2012-03-20[**]16:49:37[**]0.0.0.0[**].[**]0[**]Cold Start[**]0[**].1.3.6.1.2.1.1.3.0 = Timeticks: (7618361) 21:09:43.61 .1.3.6.1.6.3.1.1.4.1.0 = OID: .1.3.6.1.4.1.5205.2.32.1.20.1 .1.3.6.1.4.1.5205.2.32.1.21.1 = STRING: "admin"

Esto es un login correcto en el switch.  A continuación tienes una captura hecha con tcpdump:

16:49:37.562313 IP 192.168.0.240.1056 > 192.168.0.16.162:  V2Trap(90)  .1.3.6.1.2.1.1.3[|snmp]

Y también te adjunto una captura de pantalla en un anexo

Gracias y un saludo


Attached Files


.png   Captura de pantalla 2012-03-20 a la(s) 16.54.57.png (Size: 89.87 KB / Downloads: 82)
 Reply
#4
Más información:

Creo que se donde está el problema, he observado que los traps que vienen en SNMP V1 se muestran correctamente. (ver imagen).  Los traps V2 no tienen el campo agent-addr .

He visto este link y parece que es necesaro parchear el sistema ¿ como puedo saber si en mi caso es necesario ó es un problema de configuración ?

http://openideas.info/smf/index.php/topi...l#msg11821

Gracias y un saludo


Attached Files


.png   Captura de pantalla 2012-03-20 a la(s) 19.17.58.png (Size: 72.85 KB / Downloads: 83)
.png   Captura de pantalla 2012-03-20 a la(s) 19.18.17.png (Size: 76.85 KB / Downloads: 86)
 Reply
#5
Hola:

Ya hemos encontrado el motivo y la solución.  Como comentamos en el mensaje anterior, SNMPv1 incluye en el trap un campo obligatorio agent-addr que no esta presente en SNMPv2.

La pista nos la dió este post:

http://openideas.info/smf/index.php?topic=5385.0

Hemos parcheado a la última versión 4.1 (dev-120320.deb en nuestro caso porque usamos Ubuntu 10.04) y funciona correctamente, ¡¡gracias por el parche!!
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes