•  Previous
  • 1
  • ...
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 9
  • Next 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Actualizar desde versión 3.2 a 4.x
#51
Buenas Argie;

Aquí se explica como hacer para que mysql tome la hora de sistema (habiendo corregido previamente la hora del sistema):

http://dev.mysql.com/doc/refman/5.1/en/t...pport.html
 Reply
#52
Gracias, pero x lo que veo, el mysql de pandora ya usa la zona del sistema:

mysql> SELECT @@global.time_zone, @@session.time_zone;
+--------------------+---------------------+
| @@global.time_zone | @@session.time_zone |
+--------------------+---------------------+
| SYSTEM                | SYSTEM              |
+--------------------+---------------------+

Así que el problema no está ahí. O al contrario, el mysql y la hora del sistema está bien, pero pandora está adelantado 2 horas respecto a la hora del sistema. Creo que el problema está en la configuración horaria de Pandora.

Por otro lado, dado que migré la bbdd de la versión 3.2 a la 4.0.2, ahora en el update manager me aparece como ruta del server para actualizar esta:

/pandoraupdate32/server.php

que creo está mal. ¿Puedes por favor darme la ruta correcta?

Gracias.

UPDATE: he solucionado el problema poniendo la hora del linux correctamente (estaba 2 horas atrasada), y luego configurando pandora para que use la hora de Buenos Aires (UTC-4). Como yo estoy en Spain, ahora la hora en la columna de "ultimo contacto" se muestra bien.
Eso si, habrá que ver como saca informes de SLA, o de caída de servidores... probablemente lo haga con 4 horas de error...
 Reply
#53
Hola,

La nueva ruta es:

Code:
/pandoraupdate4/server.php

En cuanto a los problemas de hora, has comprobado este enlace del FAQ:

http://openideas.info/wiki/index.php?tit...e_problems

Puedes probar a modificar la zona horaria, forzándolo en la consola, como se explica en este otro enlace:

http://openideas.info/wiki/index.php?tit...he_console

Espero que te sirva de ayuda y resuelva el problema. Un saludo.
 Reply
#54
Gracias. Hice el chequeo de en que parte la hora difería de la hora del sistema, y me dio que en perl y en php.

Así que modifiqué el php.ini para cambiar la hora de Berlin, y poner por defecto la de Madrid. Pero no funcionó: ahora todos los agentes Windows mostraban un retraso de 2 horas, y todos los linux de solo media hora, lo cual es delirante...

También probé volver a configurar en consola la zona horario a Europe/Madrid, al mismo tiempo con las otras modificaciones que comento arriba, pero seguia con el mismo error.

Al final opté por quitar la línea del timezone del php.ini, y volver a poner la conf. horaria en consola apuntando a America/Buenos Aires, y ahora todo va bien con la hora Smile

Entonces ahora solo me quedan 2 problemas:

1. este es el que se refiere a mi pregunta anterior, del path correcto para el update manager
2. como comenté algunos posts más arriba, al migrar algunos modulos de "host alive" dejaron de funcionar. La única solución que encontré fue borrarlos y volverlos a crear, y funcionó en todos, menos en 1 Windows (desde el cual me puedo conectar perfectamente por telnet al server de pandora).

Agradeceré ayuda sobre ambos temas.

Gracias.
 Reply
#55
(07-19-2012, 02:57 PM)argie01 link Wrote: Gracias. Hice el chequeo de en que parte la hora difería de la hora del sistema, y me dio que en perl y en php.

Así que modifiqué el php.ini para cambiar la hora de Berlin, y poner por defecto la de Madrid. Pero no funcionó: ahora todos los agentes Windows mostraban un retraso de 2 horas, y todos los linux de solo media hora, lo cual es delirante...

También probé volver a configurar en consola la zona horario a Europe/Madrid, al mismo tiempo con las otras modificaciones que comento arriba, pero seguia con el mismo error.

Al final opté por quitar la línea del timezone del php.ini, y volver a poner la conf. horaria en consola apuntando a America/Buenos Aires, y ahora todo va bien con la hora Smile

Entonces ahora solo me quedan 2 problemas:

1. este es el que se refiere a mi pregunta anterior, del path correcto para el update manager
2. como comenté algunos posts más arriba, al migrar algunos modulos de "host alive" dejaron de funcionar. La única solución que encontré fue borrarlos y volverlos a crear, y funcionó en todos, menos en 1 Windows (desde el cual me puedo conectar perfectamente por telnet al server de pandora).

Agradeceré ayuda sobre ambos temas.

Gracias.


Como te dijo Luismi el nuevo path es: /pandoraupdate4/server.php


¿Puedes adjuntar la configuración del modulo host alive que te esta dando problemas?

Un saludo
 Reply
#56
Gracias por el dato.

La configuración del host alive que no me funciona es esta:

[Image: FdGDb.jpg]
 Reply
#57
Buenos días;

Comprueba que al hacer ping a la máquina en cuestión no se produce la perdida del primer paquete enviado.

Un saludo.
 Reply
#58
No, no se pierde ni el primero, ni ningún otro.

Pero curiosamente por más que agregue el módulo "host alive" a ese server no me aparece en la lista de monitores del mismo, y por eso el server en sí me aparece todo en verde.
Vi en alguna parte que el módulo está como "no inicializado", que supongo significa que no ha recibido ningún dato nunca...
 Reply
#59
Hola;

Si no se inicializa,ni aún reiniciando el servidor significa que el modulo ha quedado registrado ya en la base de datos de Pandora ,por el contrario algún parámetro de la configuración esta fallando ya que debería inicializarse automáticamente.

Un saludo
 Reply
#60
Si, pero ahora me he dado cuenta de que en el caso de los 3 servers Windows 2008 que me daban problema con el módulo "host alive", en realidad en ninguno de los tres casos se ha terminado asignando el modulo.

En los tres casos he ido a "Configuración de agentes - Plantillas", seleccionado y asignado "basic monitoring" (lo cual les agrega el modulo "host alive").
Aunque en ese momento me dice que el módulo fue añadido correctamente, en el listado de módulos del server me aparece siempre como se ve en esta imagen (y se ve que al cabo de un tiempo desaparece de este listado por sí mismo, sin llegar a activarse nunca):

[Image: L29ee.jpg]

¿Se supone que este módulo debería figurar de alguna forma en´el archivo de configuración del agente pandora en el propio server?

Gracias.
 Reply
  •  Previous
  • 1
  • ...
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 9
  • Next 


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes