Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
tactical view page loading problem
#1
hi,
I'm using pandora fms 4.0.2. And I have 1650 total agents now. For each agent there are 5 modules. It gets 20 Sec to load tactical view page.when add more agents it takes more time and also few operators works in pandora console same time takes more time to load that tactical page.

I tuned up pandora_server.conf 's network_threads = 4 to 30. Then the lag gone to 9 seconds / 1195 (before that was very high value 4min 20 sec/2300). How could I reduce the time that takes to load tactical view page.(other pages are normal).

*There is a long query running when loading tactical view page. It take lot of time and processor capacity.(see attached file)

* Server mem is 1979/7884MB,core i7 processor , using 12.04 ubuntu server , 7628mb swp memory.

help me.


Attached Files


.   pandora_tactical_ page_query (Size: 3.08 KB / Downloads: 78)
.   pandora_tactical_ page_query (Size: 3.08 KB / Downloads: 70)
 Reply
#2
Hello;

Try optimizing mysql service by following the next steps:

http://openideas.info/wiki/index.php?tit...timization

Regards

 Reply
#3
hi, 
ok thanks for your help.i'll check with that documentation.
thankyou.
 Reply
#4
(01-04-2013, 05:02 AM)thusitha link Wrote: hi, 
ok thanks for your help.i'll check with that documentation.
thankyou.

Any improvement ?

Consider use percona instead mysql, its a huge difference.
 Reply
#5
hi,
sorry for the delay. i did some changes in Pandora_server.conf file
    -#network_threads 4 to network_threads 80
    -#verbosity 1 to verbosity 10
then it is pretty good. and also i changed setup/performance /Use realtime statistics as "no"
now its manageable.

thankyou
 Reply
#6
(02-06-2013, 04:05 AM)thusitha link Wrote: hi,
sorry for the delay. i did some changes in Pandora_server.conf file
    -#network_threads 4 to network_threads 80
    -#verbosity 1 to verbosity 10
then it is pretty good. and also i changed setup/performance /Use realtime statistics as "no"
now its manageable.

thankyou

Another tip:

1. Disable agent access graphs.
2. Change purge date of events to 7 instead 15 (default).

You can optimize a lot the install from a "default", its needed when you're above 1500 agents. Depending on hardware, you can get 2500~3000 agents in the same server.
 Reply
#7
hi,
thank you very much for the tip. I will try it.

thank you.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes