Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NON Initialized Module
#1
Hello,

I created a module using Nagios compatibility and was able to get it working fine on one agent. I now created a second Agent, with the exact configuration and it shows "NON-INITIALIZED" next to the module. I have triple checked the configuration for both modules on both agents and they are exactly the same except for the IP Address. The only thing I see in the log file is "[V0] [ERROR] Undefined value returned by Plugin query. Is the server out of memory?" but im not sure if that is related to this module as it does not appear when I create the module.

As for the settings:

I have the script located in:
/usr/share/pandora_server/util/plugin/check_esxi_hardware.py

Plugin Type: Nagios
IP Option: -H

In the module settings under Agent:
Module Component: Manual Setup
Name: Check ESXi Hardware
Type: Generic String
Warning Status: Str.: WARNING
Critical Status: Str: CRITICAL
Target IP: 192.168.1.10
Username: root
Password: XXXX
Plugin parameters: -V dell
Module Group: Networking (tried others just in case)
Interval: 1 Hour


Please advise.

Thanks

 Reply
#2
Hello

Try to reconfigure IPAdress and click again in Update, its possible that this field is not saved correctly in the database.

Regards
 Reply
#3
I tried that, I also tried deleting the module and agent and re-creating both, same problem Sad
 Reply
#4
I also enabled verbose logging, I can see the command being run in the log:

[V9] Executing AM # 153 plugin command '/usr/share/pandora_server/util/plugin/check_esxi_hardware.py -H X.X.X.X -U pandora -P Password1 -V dell'

If I run that command, it works perfect, I can see the output that is expected. It takes about 80 seconds to run the command, so I made sure under the plugin configuration that Max. Timeout is set to 300. Is there any other place where the timeout needs to be configured?
 Reply
#5
OK,  I figured it out. In the pandora_server.cfg, changing the following paramter:
plugin_timeout

to 300 resolved the issue.
Not sure what time Timeout setting in the plugin settings is for then. What is the difference?
 Reply
#6
Ok

When plugin has a less value than plugin_timeout, use plugin value.
If a plugin has a higher value, the value used is this (plugin_tiemeout in pandora_server.conf) , instead the plugin value.

Regards
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes