Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
All Agent unknown
#1
Hi
i've just install pandora 4.1 version to try it.
I have exported a lot of network agents from my pandora 4.0.2 version and import it the new version, i set up all my alerts and now i have a little problem that i don't understand.
Sometimes in the Monitoring > Group view panel all my network agents become unknowns without a real reason.
After some minute they return to the real status.
I attach some pics for explain the (visual) problem

thanks


Attached Files


.jpg   IMM1.jpg (Size: 153.91 KB / Downloads: 77)
.jpg   IMM2.jpg (Size: 185.86 KB / Downloads: 77)
.jpg   IMM3.jpg (Size: 179.53 KB / Downloads: 82)
 Reply
#2
Hi

Have you check your network server lag?

It's possible that you need up the server threads, to reduce network server lag.

Regards
 Reply
#3
I attach the server lag panel

this is my pandora_server.conf network threads: configuration

# Network threads: Do not set too high (~40). Each threads make a network module check.

network_threads 15


Attached Files


.jpg   IMM1.jpg (Size: 126.49 KB / Downloads: 96)
 Reply
#4
10 hours? :0

This lag is excessive and the number of threads too if you haven't a powerfull computer.

I think that you need to down the number of thread or check if you have setting in pandora_server.conf a high network_timeout or icmp_checks, tcp_checks or snmp_check > 1.

 Reply
#5
this is my pandora_server.conf

i have 1061 monitor check in a 2 cpu server with 6 GB RAM

....
# Network timeout (in seconds) for timeout in network connections for Network agents

network_timeout 10

# Server keepalive (in seconds)

server_keepalive 45

# Server Threshold: defines number of seconds of main loop (in sec)

server_threshold 1

# Network threads: Do not set too high (~40). Each threads make a network module check.

network_threads 15

# icmp_checks x : defines number of pings for each icmp_proc module type. at least one of
# that ping should be 1 to report 1

icmp_checks 5

# tcp specific options :
# tcp_checks: number of tcp retries if first attempt fails.
# tcp_timeout: specific timeout for tcp connections

tcp_checks 3
tcp_timeout 30

# snmp specific options :
# snmp_checks: number of snmp request retries if first attempt fails.
# snmp_timeout: specific timeout for snmp request.

snmp_checks 2
snmp_timeout 15

# snmp_proc_deadresponse 1 (default): Return DOWN if cannot contact
# or receive NULL from a SNMP PROC module.

snmp_proc_deadresponse 1

# plugin_threads: Specify number of plugin server threads for processing plugin calls

plugin_threads 3

# plugin_timeout: Specify number of seconds calling plugin exec waiting for response
# after this time, call is aborted and result is "unknown".

plugin_timeout 30

# wmi_timeout : specific timeout for wmi request.

wmi_timeout 15

# wmi_threads: Specify number of WMI server threads for processing WMI remote calls

wmi_threads 2

# recon_threads. Each thread will scan a different scantask.

recon_threads 1

# dataserver_threads: Number of threads for data server (XML processing threads)

dataserver_threads 2
...
 Reply
#6
ok, you have 1061 network modules.

icmp_checks 5
tcp_checks 3
snmp_checks 2

Assuming that 1/2 of these modules are icmp, 530 x 5 = 2650
1/4 are tcp = 265 x 3 = 795
and 1/4 are snmp =  265 x 2 = 530
Total (Real)---- 3975 Network Modules

You need to down the number of these checks because your system is full.  You can't have this lag on your network server...
Other solution is upload interval of these modules...

Network timeout 2 is recommended



 Reply
#7
Hi Mario, i've tried your suggestions and had correct the pandora_server value
Now my Lag is 1 sec but i have the same problem!


Attached Files


.jpg   IMM1.jpg (Size: 160.75 KB / Downloads: 78)
.jpg   IMM2.jpg (Size: 117.18 KB / Downloads: 78)
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes