Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agente no puede enviar fichero a servidor: Error sending file.Conexión rehusada.
#1
Buenos días,

Necesito vuestra ayuda.

He instalado la parte servidora de PandoraFMS en un CentOS 6.5 y se ha conseguido instalar correctamente. Puedo acceder a la consola y el servidor está ejecutándose (se puede ver la información del propio servidor).

Sin embargo, cuando instalo un agente en otra máquina CentOS, no puede enviar el fichero .data al servidor. Este es el log del agente en el equipo cliente:
Code:
2014/03/10 14:28:31 - [log] - Running as user root
2014/03/10 14:28:31 - [setup] - server_ip is 172.31.106.59
2014/03/10 14:28:31 - [setup] - server_path is /var/spool/pandora/data_in
2014/03/10 14:28:31 - [setup] - temporal is /tmp
2014/03/10 14:28:31 - [setup] - logfile is /var/log/pandora/pandora_agent.log
2014/03/10 14:28:31 - [setup] - interval is 300
2014/03/10 14:28:31 - [setup] - debug is 0
2014/03/10 14:28:31 - [setup] - udp_server is 1
2014/03/10 14:28:31 - [setup] - udp_server_port is 41122
2014/03/10 14:28:31 - [setup] - udp_server_auth_address is 172.31.106.59
2014/03/10 14:28:31 - [setup] - address is auto
2014/03/10 14:28:31 - [setup] - server_port is 41121
2014/03/10 14:28:31 - [setup] - transfer_mode is tentacle
2014/03/10 14:28:31 - [setup] - server_pwd is hicsphfg
2014/03/10 14:28:31 - [setup] - remote_config is 0
2014/03/10 14:28:31 - [log] - Thread is disabled.
2014/03/10 14:28:32 - [error] - Error sending file '/tmp/MACHINE02.1394458112.data': [err] Cannot connect to 172.31.106.59 on port 41121: Conexión rehusada.

He mantenido prácticamente todo el fichero de configuración.

Las dos máquinas se pueden ver y tienen todos los puertos abiertos. Un 'nmap 172.31.106.59 -p 41121' desde la máquina cliente me indica que el puerto 41121 del servidor está abierto.


¿Alguna idea?

Muchas gracias.
 Reply
#2
Hola

Parece ser un problema que puede estar ocasionado por cuatro factores:
1. El servicio tentacle no esta corriendo. Prueba a teclear service tentacle_serverd status  en un terminal. Si no está activo teclea service tentacle_serverd start.
2. El firewall de linux tiene bloqueado el puerto. Teclea  sudo /etc/init.d/iptables stop
3. Selinux está activo. Teclea sudo setenforce 0  en la terminal. Despues con el vim abre el fichero de configuracion de selinux para deshabilitarlo. Teclea sudo vi /etc/selinux/config y cambiale el estado a deshabilitado.
4. Comprueba el firewall de la otra maquina, el estado de selinux y si el servicio tentacle esta corriendo.

Saludos
Ivo
 Reply
#3

Solucionado!

Al final ha funcionado deshabilitando el SELinux en ambas máquinas.

Además, ahora el tentacle se inicia al encender el servidor (antes tenía que hacerlo manualmente).

Muchas gracias Ivo!
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes