Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error actualización a 6.0
#21
Hola a todos,

Empiezo a perderme un poco con el tema, permanezcamos en este tema los cuatro intentando solucionarlo, pues al ser varios hilos (jbarba incluso lo hace también en inglés xD) acabo liándome y no me aclaro bien (fallo mío).

Habéis instalado todos el Encode::Locale a través de cpan y os da fallo en la línea 1062 del fichero Core.pm...
A algunos de vosotros os peta cuando hacéis uso de las alertas. Lo he replicado en un equipo Ubuntu (por eso de daros problema con Debian y siendo más o menos lo mismo) y no he tenido ninguno de los problemas (he probado alertas con acción de envío de correo y plantilla Critical, recibiendo el correo sin problema).

Resumiendo, confirmadme que estos son vuestros sistemas:
- Sergio:
Debian 7.9 (64 bits).
Perl v5.14.2.
Actualizado mediante paquetes (¿verdad?)

-jbarba:
Debian 8.
Perl v5.20.2.
Actualizado mediante "debs".

-Gutiall:
Especifica tu sistema.

Un saludo a todos,
Emilio.

EDIT: He realizado todo el proceso, esta vez sobre un Debian que he instalado de cero, y todo me ha funcionado tal y como debería, os dejo las dependencias que son necesarias y que he ido instalando:
CONSOLE
php5 php5-snmp php5-gd php5-mysql php-db php5-xmlrpc php-gettext php5-curl graphviz dbconfig-common php5-ldap unzip mysql-client

SERVER
libtime-format-perl libnetaddr-ip-perl libtime-format-perl libxml-simple-perl libxml-twig-perl snmp snmpd xprobe2 nmap sudo libio-socket-inet6-perl snmp-mibs-downloader libjson-perl libnet-telnet-perl snmp-mibs-downloader

Recordad tener instalado el mysql server y habilitado el "non-free".

Espero que os sea de ayuda.

Un saludo,
Emilio.
 Reply
#22
Efectivamente, en mi caso es ese mi entorno. Debian 8 (64 bits).
 Reply
#23
Los datos de mi sistema son correctos, y actualizado mediante paquetes.

Al igual que jbarba, he instalado (en este orden) libencode-locale-perl, reinicio y el error persiste. También he instalado Encode::Locale mediante cpan, y lo mismo.
He comprobado los paquetes que comentabas al final, y tengo todos instalados. He añadido las repos non-free, actualizo, reinicio y el error persiste.

Como última opción se puede hacer una instalación limpia de cero e importar la base de datos y archivos de configuración (collections, plugins, etc...), pero prefiero resolver cuál es el problema en concreto.

Un saludo, sigo cacharreando
 Reply
#24
Hola Antonio, mi sistema operativo es Centos 6.6. He probado a instalar desde cero con el cd y importar los ficheros y la base de datos y me pasa lo mismo.

Saludos
 Reply
#25
Perdona Emilio, ya te he cambiado hasta el nombre, me olvidado comentarte que a mi ya no me manda ni las alertas al correo, si es através de la consola SNMP y me las envía.

Saludos
 Reply
#26
Simplemente por información, la instalación que hago es mediante los paquetes deb de forma separada, ¿hay diferencia a instalarlo mediante iso?
 Reply
#27
Hola a todos,

No, Sergio, no debería ser problema.
Como os digo, repliqué todo el proceso en mi propia máquina y no me dio ningún problema. La solución sería reinstalar y migrar, como apuntó Sergio.
No llego a entender por qué os falla a vosotros, la verdad. Porque Gutiall informa de que importando tampoco parece haber mejoría.

Un saludo,
Emilio.
 Reply
#28
Hola a todos:

Debian 8.2 x64 bits instalado desde cero (virtualizado sobre VMware ESXi 5.5), y sólo restauradas la base de datos de pandora, pandora_server.conf y pandora_agent.conf de mi anterior instalación de Pandora FMS v6 (que a su vez provenía de una v5.2 actualizada a v6). No tengo plugins, ni collections, ...

Paquetes de Pandora FMS instalados por dpkg desde Sourceforge (antes fue por repositorio deb).

Y el error persiste... Sad... al dispararse una alarma que manda correo, vuelve a aparecer el mismo error no controlado...

¿Se os ocurre algo que pueda hacer? Por el momento voy a tener que volver a la v5.2, pero me temo que esto no se corrija y por tanto no pueda migrar a la v.6.x Sad
 Reply
#29
Yo he instalado desde cero con el Appliance CD (iso), he importado la base de datos y archivos de configuración (nada de binarios), y sigue saltando el mismo error.
 Reply
#30
Buenos días:

Gracias a todos por vuestras pruebas. Yo estoy comenzando a sospechar de "algo" relacionado con la base de datos, sobre todo después de la ultima prueba de Sergio.

Mi monitorización es muy simple, en todos los casos son módulos host alive y/o host latency, desde el agente de la misma máquina de pandora (consola, server, agente.. todo me corren en la misma máquina Debian, una VM en ESXi). Algunas otras consultas son mediante WMI (carga de CPU, memoria física libre, disco físico libre...). Sólo tengo un agente en una máquina Windows (más como prueba que otra cosa, y lo mismo lleva un tiempo sin actualizarse de versión).

Luego también recibo traps snmp.

Voy a probar, sobre mi instalación limpia de ayer, a mantener el server.conf y agent.conf, pero a borrar la BBDD y a forzar la creación de una nueva desde el asistente de instalación (install.php), a crear un agente y un módulo host alive y su correspondiente alerta y envío de mail, a ver si se reproduce el problema o no. Si se reproduce, me compraré un circo y me forraré haciendo crecer a los enanos, y si no, cada vez me olerá más a algo relacionado con la base de datos (estructura y/o registros).

Ahora os cuento...
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes