Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update DB Pandora FMS v5.1SP2 to Pandora FMS v6.0SP3
#1
Hello,

When i exec SQL to Update DB "pandoradb_migrate_5.1_to_6.0.mysql.sql"

I receive this error: ERROR 1048 (23000) at line 28: Column 'id_policy_module' cannot be null
 Reply
#2
Hello William,

Can you paste here the command you are using? What is your current version?

Kind regards,
Antonio.
 Reply
#3
Hello,

Command: cat pandoradb_migrate_5.1_to_6.0.mysql.sql | mysql -uroot -p -D pandora

Version: Pandora FMS v5.1SP2
New Version:  Pandora FMS v6.0SP3
 Reply
#4
Hello,

We need more details about your setup. What is the distribution you are using? Is it an appliance ISO installation or manual installation? What is your MySQL version?

Regards,
Antonio.
 Reply
#5
SO: CentOS Linux release 7.2.1511 (Core)
MySQL: mysql-community-server-5.6.34-2.el7.x86_64

Manual installation
 Reply
#6
Hello William,

It looks like some line of the pandoradb_migrate is incorrect. What is the console version you installed to get it? I would suggest you to manually update your console with rpm -Uvh with the packages you can find here: https://sourceforge.net/projects/pandora...EL_CentOS/
And then try to apply the database update.

Is your environment a new fresh installation or are you updating from an older installation that has already data on it?

Kind regards,
Antonio.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes