Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error al instalar pandorafms-console en Ubuntu 16.04
#1
Hola!
Soy un estudiante de prácticas en una empresa y me han indicado que instale Pandora FMS en su última version, tanto servidor como agente, y leyendo he visto que necesito también instalar la consola. Bien, ningún problema, voy a instalar todo... Pero al querer instalar el paquete pandorafms-console desde la terminal, me salta el siguiente error:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias     
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
pandorafms-console : Depende: php5 pero no es instalable
                      Depende: php5-snmp pero no es instalable
                      Depende: php5-gd pero no es instalable
                      Depende: php5-mysql pero no es instalable
                      Depende: php5-xmlrpc pero no es instalable
                      Depende: php5-curl pero no es instalable
                      Depende: php5-ldap pero no es instalable
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


El problema radica, al parecer, en la versión de php; Ubuntu 16.04 usa php7.0, mientras que la consola de pandora fms usa php5. He probado a descargar repositorios con versiones anteriores de php y que puedan funcionar juntas, sin éxito, y se me están agotando las ideas... ¿Podríais darme alguna solución?

Muchas gracias.
 Reply
#2
Hola lmcrespo,

Efectivamente Pandora FMS solo soporta PHP5. Dados los numerosos problemas que puedes encontrar para encontrar versiones compatibles tanto con Pandora como entre sí, mi sugerencia es que instales directamente en un sistema operativo CentOS, que es el que recomendamos y se utiliza un 90% de las veces. Si es posible de hecho te aconsejaría que realizases la instalación directamente con la ISO de Pandora, que trae CentOS y todo listo para funcionar, en media hora escasa puedes estar monitorizando.

Un saludo,
Antonio.
 Reply
#3
(03-23-2017, 04:31 PM)antonio Wrote: Hola lmcrespo,

Efectivamente Pandora FMS solo soporta PHP5. Dados los numerosos problemas que puedes encontrar para encontrar versiones compatibles tanto con Pandora como entre sí, mi sugerencia es que instales directamente en un sistema operativo CentOS, que es el que recomendamos y se utiliza un 90% de las veces. Si es posible de hecho te aconsejaría que realizases la instalación directamente con la ISO de Pandora, que trae CentOS y todo listo para funcionar, en media hora escasa puedes estar monitorizando.

Un saludo,
Antonio.

Antonio
Buenas noches, realmente te agradezco mucho el tomarte el tiempo para responder las inquietudes, pero siento que PANDORA debe tener un poco de seriedad en cuanto a lo que ofrece. Es molesto recibir respuesta como que sino funciona entonces usa otra herramienta es cmo cuando te dicen, sino puedes con el error  entonces "formatea el equipo". Quizas no soy el "experto" en linux, pero creo que es necesario elevar el nivel y dar soluciones mas profesionales si es que el caso esta a tu alcance. 


Tengo el mismo error, tengo Ubuntu Server 16.10 y fue IMPOSIBLE agregar los repositorios. 

Entonces en tal caso, la solicio mia es entonces cambiar de Herramienta? es decir Mejor uso NAGIOS? u otra herramienta de monitoreo?

Sin embargo espero que PANDORA pueda verificar su documentacion y su plataforma para que la instalacion de la herramienta sea lo menos traumatica posible, sino entonces le tomare la palabra y buscaquere una herramienta alterna

Espero no haberlo incomodado

Saludos
 Reply
#4
Buenos días kravmagas,

Recientemente hemos actualizado los paquetes para que sean compatibles con la versión 5.6 de php y que de estar manera se pudiera instalar en las nuevas versiones de Ubuntu.

Para ello puedes agregar este repositorio, e instalar php 5.6.
sudo add-apt-repository ppa:ondrej/php

Pandora no es compatible con php 7, por lo que instalando php5.6 desde el repositorio indicado, deberías poder instalar la herramienta sin problemas.

Un saludo,

Luis.
 Reply
#5
(06-19-2017, 07:22 AM)luis Wrote: Buenos días kravmagas,

Recientemente hemos actualizado los paquetes para que sean compatibles con la versión 5.6 de php y que de estar manera se pudiera instalar en las nuevas versiones de Ubuntu.

Para ello puedes agregar este repositorio, e instalar php 5.6.
sudo add-apt-repository ppa:ondrej/php

Pandora no es compatible con php 7, por lo que instalando php5.6 desde el repositorio indicado, deberías poder instalar la herramienta sin problemas.

Un saludo,

Luis.

Hola Luis, mucho gusto
Realmente te agradezco mucho el tiempo para atender esta falla que me imagino esta afectando a varias personas. Sobre todo como yo que soy fiel implementador de Pandora, realmente las otras herramientas no me gusta pero nada! 

Voy a tratar de seguir tus indicaciones a ver que tal resulta poder instalar php5.
Te cuento como me fue

Saludos
Krav
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes