Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Graphs not showing in 'default' critical email alert
#1
Just getting the dreaded red x in a box where the image is supposed to be.

No changes have been made to the standard 'email to admin' template. Red alarm image shows up fine, so pretty sure its not an outlook issue.

I can see the template is using this tag at the bottom '_modulegraph_24h_'

... and the email source when it arrives shows this ...<img src="cid:module_graph_24h">

Hope you can help,

Thanks
 Reply
#2
Hi dynamicl,

You have to go to the Pandora configuration, set the password and the allowed IP addresses.

[Image: QU2R3f6.png]

[Image: hg1XGXL.png]

Then you need modify the configuration file of the pandora server and uncomment these lines.

Code:
# console_api_pass: Api pass
console_api_pass apipass

# console_user: Console user name (admin by default)
console_user admin

Check if you can see the graph in the email.

Best regards,

vic.
 Reply
#3
Thanks Vic, worked perfectly!
 Reply
#4
(09-14-2017, 12:14 PM)vic Wrote: Hi dynamicl,

You have to go to the Pandora configuration, set the password and the allowed IP addresses.

[Image: QU2R3f6.png]

[Image: hg1XGXL.png]

Then you need modify the configuration file of the pandora server and uncomment these lines.

Code:
# console_api_pass: Api pass
console_api_pass apipass

# console_user: Console user name (admin by default)
console_user admin

Check if you can see the graph in the email.

Best regards,

vic.

I must be missing something here. 

I've updated my password via the gui, I just set as 'apipass' to test, and updated access to be 127.0.0.1 and *.  Then updated my pandora_server.conf to be the below.


Code:
console_api_url http://localhost/pandora_console/include/api.php
console_api_pass apipass
console_user admin

It sends out email via gmail and when i open it there i get no graphs.  Is it because I'm doing it via gmail?

Thanks
 Reply
#5
(02-25-2019, 07:01 PM)idic Wrote:
(09-14-2017, 12:14 PM)vic Wrote: Hi dynamicl,

You have to go to the Pandora configuration, set the password and the allowed IP addresses.

[Image: QU2R3f6.png]

[Image: hg1XGXL.png]

Then you need modify the configuration file of the pandora server and uncomment these lines.

Code:
# console_api_pass: Api pass
console_api_pass apipass

# console_user: Console user name (admin by default)
console_user admin

Check if you can see the graph in the email.

Best regards,

vic.

I must be missing something here. 

I've updated my password via the gui, I just set as 'apipass' to test, and updated access to be 127.0.0.1 and *.  Then updated my pandora_server.conf to be the below.


Code:
console_api_url http://localhost/pandora_console/include/api.php
console_api_pass apipass
console_user admin

It sends out email via gmail and when i open it there i get no graphs.  Is it because I'm doing it via gmail?

Thanks

Good morning idic,

What version of Pandora FMS do you have installed?

Alberto
 Reply
#6
I am running Pandora FMS v7.0NG.731 - Build PC190130 - MR 24
 Reply
#7
(02-26-2019, 10:41 PM)idic Wrote: I am running Pandora FMS v7.0NG.731 - Build PC190130 - MR 24

Greetings, idic

What graph are you trying to generate? A pdf or an alert related one? If its the second case, you'll need a console_pass parameter following the previous three. 

Code:
console_api_url http://localhost/pandora_console/include/api.php
console_api_pass apipass
console_user admin
console_pass userpass

You'll have to notice too that your url can't be localhost, you'll have to provide the IP. 

Regards, 

Eduardo.
 Reply
#8
Perfect!  Thank you.

This step which up to now I missed, was very helpful


Code:
# To make sure console_api_url, console_api_pass, console_user and console_pass are properly configured run:
#       curl "<console_api_url>?op=get&op2=test&apipass=<console_api_pass>&user=<console_user>&pass=<console_pass>"
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes