Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Physical Agent - Windows 7
#1
I am attempting to run a Agent on Windows 7 RC, Build 7100, 64-bit edition and when the service lanches I receive the following error in my system log:

Faulting application name: PandoraAgent.exe, version: 0.0.0.0, time stamp: 0x49abaef6
Faulting module name: msvcrt.dll, version: 7.0.7100.0, time stamp: 0x49eea5fe
Exception code: 0xc0000005
Fault offset: 0x000142ab
Faulting process id: 0xe1c
Faulting application start time: 0x01c9ff6662c7671a
Faulting application path: C:\Program Files (x86)\pandora_agent\PandoraAgent.exe
Faulting module path: C:\Windows\syswow64\msvcrt.dll
Report Id: a1c824ee-6b59-11de-bcde-00197ee0a9ad
 Reply
#2
you are running an agent built for a 32 bits and you are running it on a 64 bits S.O.
 Reply
#3
Hi.
I'm also trying to run an Agent on Windows 7 (final) 32 bit. Same problem: the service starts and after a few seconds it crashes:
Code:
Faulting application name: PandoraAgent.exe, version: 0.0.0.0, time stamp: 0x4ac9b256
Faulting module name: msvcrt.dll, version: 7.0.7600.16385, time stamp: 0x4a5bda6f
Exception code: 0xc0000005
Fault offset: 0x000143f9
Faulting process id: 0xf10
Faulting application start time: 0x01ca4599f7d7ccbd
Faulting application path: C:\Program Files\PandoraAgent\PandoraAgent.exe
Faulting module path: C:\Windows\system32\msvcrt.dll
Report Id: 38782209-b18d-11de-8787-444553544200

I already tried several agents (v2.0, v.2.1 and even a v3.0 beta) with the same result.
So I decided to compile it myself (acording to http://openideas.info/wiki/index.php?tit...dows_Agent  but not so «fine with a default installation», had to add 5 ou 6 packages). Same result.

I put a copy of msvcrt.dll from XP in Pandora folder but it keeps using the system32. Is there a way to tell PandoraAgent to use another path for msvcrt.dll?

Thanks.
 Reply
#4
Well, good news (at least for me): the agent works in Windows 2008 Server x64. Since I don't really need to monitor Windows 7 (it's just my workstation) everything is OK now.
 Reply
#5
Mmmm, we will work on windows 7 compatibility, I've made some tests and I get it running without problems, I don't know if problem is the 64bit or other issue.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes