Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas con Agentes, servidor no lee los datos de los agentes
#11
Me tienes totalmente intrigado la verdad, he visto de todo en Pandora, pero esto es nuevo !! :-)

Te recomiendo que te fijes muy muy bien en los logs y nos cuentes lo que ves, es la clave muchas veces. Por otro lado ¿que estas usando?

Distribucion, hardware, memoria, disco, version de pandora...

 Reply
#12
dudo que sea por lo de las 15 horas, mi servidor por ciertas razones lo he de apagar a las 19:00 y lo enciendo a las 8:30, esto cada día y no tengo problema.

realmente nos tienes intrigados, aumenta el debug y verbose.. miremos que dice.
 Reply
#13
Hola a todos,

Pues hoy es el primer día que no tengo ningun problema!!!

No he actualizado aún, lo haré en breve.

Os comento lo que he pensado. Para centrarme, por ssh sólo tenía un agente en un portatil (el resto los he aparcado). Los otros los creé en consola para hacer ping, ver el ssh, ftp, ...

Tengo otras máquinas que tampoco se apagan nunca, por lo que ayer, le puse el agente a otra máquina y sin problemas, lleva hasta ahora. Y maravillosamente hoy nada más enceder el portatil, el servidor ha procesado perfectamente los datos del agente del portatil.

Estos días atras accedía al servidor y estaban todos los archivos copiados en la carpeta /var/spool/.. y sin procesar, podría ser (la ignorancia es atrevida) que dejara de leer la carpeta tras x intentos sin información.

Bueno muchas gracias por todo y ya os iré comentando mis aventuras con Pandora.
 Reply
#14
en un principio pandora siempre lee el /var/spool/pandora/data_in y procesa todos los ficheros que hay, los que no puede procesar los marca cómo *.error y los deja allí.

lo que si parece es que alguno de esos agentes que has aparcado es el causante, ya que el resto siguen enviando información y el server funciona bien, ves eliminando posibilidades y si encuentras el causante pon la información para que podamos ver la causa.
 Reply
#15
Buenas,

Como os he comentado, le he instalado un agente a otro servidor, y sin problemas lo lee siempre. A partir de aquí, ya siempre lee los datos del agente del portatil.

No me ha vuelto a dar errores, y nunca me ha renombrado los datos como .error

Queréis que os ponga algún dato, algún log o algo. Si me da otros problemas os iré comentando.

Muchísimas gracias por vuestra ayuda.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes