Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
instalacion pandora server en Windows - OJO! NO SOPORTADO
#21
Acabo de instalar la BBDD segun las indicaciones de la web, y en principio todo parece correcto.
Ahora llega la hora de la verdad...la instalacion del servidor pandora!!!
Tengo que realizar algun paso que desconozca antes de nada o me teneis que dar alguna instrucion al respecto?
 Reply
#22
Me acaba de surgir una duda:
El tipo de seguridad que se pretende seguir es ssh, por lo que tengo que instalar,supongo, cygwin?
 Reply
#23
Bueno....aahora si que mis andanzas solitarias han tenido que parar hasta que alguien me eche un cable...
Tras configurar el archivo de configuracion con los parametrosque indicas en el foro q me comentaste,Raul, me sale el siguiente error:

[code:1]
Pandora Server 1.2 Beta2 Build PS60629 Copyright © 2004-2006 ArticaST
This program is Free Software, licensed under the terms of GPL License v2 or lat
er.
You can download latest versions and documentation at http://pandora.sourceforge
.net.

[ERROR] This isn't Linux. Pandora Server its only OFFICIALLY supported in Linux
Contact us if you require assistance running Pandora Server over other OS[/code]
con lo q pararé hasta tener noticias vuestras....
 Reply
#24
Bueno, esto estaba pensado para que no se utilizase otro sistema que no fuese GNU/Linux, pero una vez que ya se ha desatado todo el hilo...

La línea 75 del fichero pandora_server\bin\pandora_config.pm comienza con:

[code:1]die "[ERROR] This isn't Linux. Pandora Server...[/code]

Simplemente comenta esta línea (añadiendo un # delante de la misma)

No sé si habrá más verificaciones como esta que paren el servidor :-D

Pero, seguimos recomendando GNU/Linux.. no sabemos como va a responder en Windows en producción...

Raúl
 Reply
#25
Lo probaré en cuanto tenga un ratin y te comento, pero mientras me podrías comentar algo sobre el tema del cygwin?
lo necesito realmente por el tema del ssh? en principio me gustaria acceder con una cuenta local de administracion aunque si que barajaba la idea de accerlo con sspi o algo parecido que permitiese el login por usuario de dominio...
 Reply
#26
Sí, necesitas el SSh, claro

Quote:Lo probaré en cuanto tenga un ratin y te comento, pero mientras me podrías comentar algo sobre el tema del cygwin?
lo necesito realmente por el tema del ssh? en principio me gustaria acceder con una cuenta local de administracion aunque si que barajaba la idea de accerlo con sspi o algo parecido que permitiese el login por usuario de dominio...
 Reply
#27
Según está programado el agente de windows, necesitas un servidor SSH instalado para que recoga los datos, ya que SOLO envía los datos vía SSH, bien el openssh que tiene cygwin, o bien otro, si es que lo encuentras :-D

Otra opción es recoger los datos que genera el agente de forma temporal y depositarlos en el directorio del servidor Pandora, esto funcionaba en versiones anteriores del agente, pero desde luego no es la forma más correcta de hacerlo, con lo cual si lo intentas no podremos ayudarte mucho.

Solución: GNU/Linux o la imagen WMware (ver http://www.openideas.info/phpbb/viewtopic.php?t=93)

Raúl

Quote:Lo probaré en cuanto tenga un ratin y te comento, pero mientras me podrías comentar algo sobre el tema del cygwin?
lo necesito realmente por el tema del ssh? en principio me gustaria acceder con una cuenta local de administracion aunque si que barajaba la idea de accerlo con sspi o algo parecido que permitiese el login por usuario de dominio...
 Reply
#28
Por fin he terminado de instalar el servidor y la consola de este, y parece funcionar correctamente, pero el problema viene ahora con el agente:
De momento para realizar pruebas he instalado el agente en la misma maquina del servidor, os cuento los pasos que he seguido por si he metido la pata en alguno de ellos:
Descomprimo el directorio bin del agente en pandora_agente y cambiar los parametros de configuracion, genero las claves publica y privada y las copio a la ruta del servidor concatenandolas al fichero de autorizacion, tras arrancar el servicio sshd con el usuario SYSTEM, he probado a realizar el test de conexion quedandose en:
[code:1]C:\pandora_agent>pandoraAgent --test-ssh
Public key file: C:\pandora_agent\key\id_dsa.pub
Private key file: C:\pandora_agent\key\id_dsa
Connecting with 127.0.0.1...[/code]
y de ahí no pasa.

Por favor echadme un cable que despues de haber podido llegar hasta aqui no me gustaria quedar en el intento...
:lol:
Muchas gracias
 Reply
#29
¿Has probado con la versión 1.3 del agente? Había un pequeño bug que, según como generases las claves, puede darte algún problema.

Bájate el binario del SVN:

https://svn.sourceforge.net/svnroot/pand...aAgent.exe

y sustituye el tuyo :-D.

De todas formas, si has seguido los pasos del hilo http://www.openideas.info/phpbb/viewtopic.php?t=89 (acabo de añadir la generación completa de las claves, puedes acceder directamente a la dirección
http://www.openideas.info/phpbb/viewtopic.php?p=646#646), prueba a hacer una conexión local:

[code:1]ssh -vv [email protected]
[/code]

Verifica que la clave privada es del tipo:
[code:1]-----BEGIN DSA PRIVATE KEY-----
MIIBugIBAAKBgQDTFcDxgoUe2ueADSJIEHCAXJnQkzAmEZHOYQL17W0daVoj59Ur
SZPIIFAdQrfPIwn0A1TcpThagQKOg6VW5xxPH+0OywERy/EayRoE+ULMlrOFm93m
PetsMUM+8MyTJ5mee3LNbeG1uMaWhBbj3ACShc6bbNkPT6U9x5tPABPtcwIVAPki
u68N6kP6uzR6142Q1s/hd0FZAoGAZDjbdMUj36Qc3/HzBOu2u2+d2VahddOF0gHi
30M8W7gdNK0JB2io3IZnkXtxJMA/aV3+tbx0ZbRmPcobjueWll30vn63IMCVF5dr
2//t8zd34KaHes5iwG2zNJcj3bSI+GDWwCK1izULXLG4PfekeLVe1mC2ASI/Ak7R
ByZCPk4CgYBiuy30gWCbloQNpeYXNuxenUTjR6+2FgDpiy7NMCVfDIoqzj+r8Xj4
MAYWQA5Dofxh2kiOQsx9xhhdsgIiv/8sP38jYsbx6d8WgIbnrEvoSvkIlwRT9vpO
GaI/ZAHTovBmr85YIuBkfqFTX4MFp9blb4iHYnVnSwKK+UUW0jh7rwIUYHnkKDYz
LZlDqxfKn4PYjkvMu+k=
-----END DSA PRIVATE KEY-----
[/code]

y la pública del tipo:

[code:1]ssh-dss AAAAB3NzaC1kc3MAAACBANMVwPGChR7a54ANIkgQcIBcmdCTMCYRkc5hAvXtbR1pWiPn1StJ
k8ggUB1Ct88jCfQDVNylOFqBAo6DpVbnHE8f7Q7LARHL8RrJGgT5QsyWs4Wb3eY962wxQz7wzJMnmZ57
cs1t4bW4xpaEFuPcAJKFzpts2Q9PpT3Hm08AE+1zAAAAFQD5IruvDepD+rs0eteNkNbP4XdBWQAAAIBk
ONt0xSPfpBzf8fME67a7b53ZVqF104XSAeLfQzxbuB00rQkHaKjchmeRe3EkwD9pXf61vHRltGY9yhuO
55aWXfS+frcgwJUXl2vb/+3zN3fgpod6zmLAbbM0lyPdtIj4YNbAIrWLNQtcsbg996R4tV7WYLYBIj8C
TtEHJkI+TgAAAIBiuy30gWCbloQNpeYXNuxenUTjR6+2FgDpiy7NMCVfDIoqzj+r8Xj4MAYWQA5Dofxh
2kiOQsx9xhhdsgIiv/8sP38jYsbx6d8WgIbnrEvoSvkIlwRT9vpOGaI/ZAHTovBmr85YIuBkfqFTX4MF
p9blb4iHYnVnSwKK+UUW0jh7rw== dsa-key-20061115
[/code]

Recuerda que esta última debe estar en [code:1]/home/pandora/.ssh/authorized_keys[/code], con los permisos adecuados (me remito al Post citado al pincipio)

Las dos claves que he publicado me funcionan perfectamente, puedes usarlas como prueba.

También te pongo mi fichero /etc/sshd_config, al que he hecho algún cambio...:

[code:1]$ cat sshd_config
# $OpenBSD: sshd_config,v 1.73 2005/12/06 22:38:28 reyk Exp $

# This is the sshd server system-wide configuration file. See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/bin:/usr/sbin:/sbin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options change a
# default value.

Port 22
#Protocol 2,1
#AddressFamily any
ListenAddress 127.0.0.1
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh_host_rsa_key
HostKey /etc/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
PermitRootLogin yes
StrictModes no
#MaxAuthTries 6

RSAAuthentication no
PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no
PermitEmptyPasswords yes

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication mechanism.
# Depending on your PAM configuration, this may bypass the setting of
# PasswordAuthentication, PermitEmptyPasswords, and
# "PermitRootLogin without-password". If you just want the PAM account and
# session checks to run without PAM authentication, then enable this but set
# ChallengeResponseAuthentication=no
#UsePAM no

#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#PermitTunnel no

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem sftp /usr/sbin/sftp-server
[/code]

Verifica que el puerto 22 esté escuchando :-D:

[code:1]
C:\pandora\key>netstat -an |findstr 22
TCP 127.0.0.1:22 0.0.0.0:0 LISTENING
[/code]


Quote:Por fin he terminado de instalar el servidor y la consola de este, y parece funcionar correctamente, pero el problema viene ahora con el agente:
De momento para realizar pruebas he instalado el agente en la misma maquina del servidor, os cuento los pasos que he seguido por si he metido la pata en alguno de ellos:
Descomprimo el directorio bin del agente en pandora_agente y cambiar los parametros de configuracion, genero las claves publica y privada y las copio a la ruta del servidor concatenandolas al fichero de autorizacion, tras arrancar el servicio sshd con el usuario SYSTEM, he probado a realizar el test de conexion quedandose en:
[code:1]C:\pandora_agent>pandoraAgent --test-ssh
Public key file: C:\pandora_agent\key\id_dsa.pub
Private key file: C:\pandora_agent\key\id_dsa
Connecting with 127.0.0.1...[/code]
y de ahí no pasa.

Por favor echadme un cable que despues de haber podido llegar hasta aqui no me gustaria quedar en el intento...
:lol:
Muchas gracias
 Reply
#30
Nada....esto sigue igual y me empiezo a desesperar...cuando parece que todo esta a punto de salir...zas!...
Sigo en el mismo punto:

[code:1]C:\pandora_agent\bin>pandoraAgent --test-ssh
Public key file: C:\pandora_agent\bin\key\id_dsa.pub
Private key file: C:\pandora_agent\bin\key\id_dsa
Connecting with 127.0.0.1...[/code]

He generado de nuevo las claves como indicas, he cambiado la version del agente, y las pruebas de conectividad parecen correctas:

[code:1]ssh -vv [email protected][/code]
el resultado es:
[code:1]OpenSSH_4.5p1, OpenSSL 0.9.8d 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 127.0.0.1 [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /home/Administrator/.ssh/identity type -1
debug1: identity file /home/Administrator/.ssh/id_rsa type -1
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug2: key_type_from_name: unknown key type 'Proc-Type:'
debug2: key_type_from_name: unknown key type 'DEK-Info:'
debug2: key_type_from_name: unknown key type '-----END'
debug1: identity file /home/Administrator/.ssh/id_dsa type 2
debug1: Remote protocol version 1.99, remote software version OpenSSH_4.5
debug1: match: OpenSSH_4.5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-g
roup-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour1
28,arcfour256,arcfour,aes192-cbc,aes256-cbc,[email protected],aes128-c
tr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour1
28,arcfour256,arcfour,aes192-cbc,aes256-cbc,[email protected],aes128-c
tr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,[email protected]
ssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,[email protected]
ssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,[email protected]enssh.com,zlib
debug2: kex_parse_kexinit: none,[email protected],zlib
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-g
roup-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour1
28,arcfour256,arcfour,aes192-cbc,aes256-cbc,[email protected],aes128-c
tr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour1
28,arcfour256,arcfour,aes192-cbc,aes256-cbc,[email protected],aes128-c
tr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,[email protected]
ssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,[email protected]
ssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,[email protected]
debug2: kex_parse_kexinit: none,[email protected]
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: mac_init: found hmac-md5
debug1: kex: server->client aes128-cbc hmac-md5 none
debug2: mac_init: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 126/256
debug2: bits set: 518/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '127.0.0.1' is known and matches the RSA host key.
debug1: Found key in /home/Administrator/.ssh/known_hosts:1
debug2: bits set: 529/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/Administrator/.ssh/identity (0x0)
debug2: key: /home/Administrator/.ssh/id_rsa (0x0)
debug2: key: /home/Administrator/.ssh/id_dsa (0x66aab8)
debug1: Authentications that can continue: publickey,password,keyboard-interacti
ve
debug1: Next authentication method: publickey
debug1: Trying private key: /home/Administrator/.ssh/identity
debug1: Trying private key: /home/Administrator/.ssh/id_rsa
debug1: Offering public key: /home/Administrator/.ssh/id_dsa
debug2: we sent a publickey packet, wait for reply
Connection closed by 127.0.0.1[/code]

Al intentar cambiarle por el que me indicas que da varios errores como sino entendiese los parametros de configuracion
Me la la imperesion que no he heccho algo bien, te voy a intentar explicar como lo tengo y me dices si tengo algo mal:

Por el momento tengo todo(Servidor,consola y agente) instalado en la misma maquina.
La consola esta perfecta ya que arranca correctamente y puedo entrar en todos los parametros y ventanas.

El servidor esta instalado en una carpeta:c:\pandora server
El aente esta instalado en una carpeta: c:\pandora agente
En cygwin tengo la ruta de etc/pandora/.ssh
Todo lo estoy haciendo con el administrador local, en ningun momento he utilizado un usuario pandora ni nada por el estilo, aunque la he creado tanto windows como en cygwin

El servidor arranca correctamente al igual que el servicio del sshd de cygwin y el servicio del agente...

No se que mas te puedo decir, si quieres pregunta y te digo...

Al hacer un netstat del puerto 22 el resultado es:
[code:1]
TCP 0.0.0.0:22 0.0.0.0:0 LISTENING
TCP 127.0.0.1:22 127.0.0.1:3520 FIN_WAIT_2
TCP 127.0.0.1:3520 127.0.0.1:22 CLOSE_WAIT
TCP 127.0.0.1:3521 127.0.0.1:3522 TIME_WAIT[/code]


Esto es ya por puto orgullo...(perdona la expresion....) :twisted: :twisted: :twisted:
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes